summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-05-07 15:47:25 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-05-07 15:47:25 +0000
commita08dee2aa226dfceb55972acb03f2b8fb2ac5c17 (patch)
treeb7cb068df044c997f411ac5dced0d46250c574e3 /sys-firmware
parentRevision bump: migrate to distutils-r1 (diff)
downloadgentoo-2-a08dee2aa226dfceb55972acb03f2b8fb2ac5c17.tar.gz
gentoo-2-a08dee2aa226dfceb55972acb03f2b8fb2ac5c17.tar.bz2
gentoo-2-a08dee2aa226dfceb55972acb03f2b8fb2ac5c17.zip
Version bump. I generated the tarball from the git tag. The bios.bin file is from qemu 1.4.1.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/seabios/ChangeLog8
-rw-r--r--sys-firmware/seabios/seabios-1.7.2.1.ebuild86
2 files changed, 93 insertions, 1 deletions
diff --git a/sys-firmware/seabios/ChangeLog b/sys-firmware/seabios/ChangeLog
index 564c8bdc7ae7..ca30800abd2c 100644
--- a/sys-firmware/seabios/ChangeLog
+++ b/sys-firmware/seabios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-firmware/seabios
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/ChangeLog,v 1.13 2013/03/17 03:14:42 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/ChangeLog,v 1.14 2013/05/07 15:47:25 cardoe Exp $
+
+*seabios-1.7.2.1 (07 May 2013)
+
+ 07 May 2013; Doug Goldstein <cardoe@gentoo.org> +seabios-1.7.2.1.ebuild:
+ Version bump. I generated the tarball from the git tag. The bios.bin file is
+ from qemu 1.4.1.
17 Mar 2013; Doug Goldstein <cardoe@gentoo.org> seabios-1.7.1.ebuild,
seabios-1.7.2.ebuild:
diff --git a/sys-firmware/seabios/seabios-1.7.2.1.ebuild b/sys-firmware/seabios/seabios-1.7.2.1.ebuild
new file mode 100644
index 000000000000..826cc4400f74
--- /dev/null
+++ b/sys-firmware/seabios/seabios-1.7.2.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.7.2.1.ebuild,v 1.1 2013/05/07 15:47:25 cardoe Exp $
+
+EAPI=5
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+#BACKPORTS=1
+
+if [[ ${PV} = *9999* || ! -z "${EGIT_COMMIT}" ]]; then
+ EGIT_REPO_URI="git://git.seabios.org/seabios.git"
+ inherit git-2
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+ SRC_URI="http://code.coreboot.org/p/seabios/downloads/get/${P}.tar.gz
+ http://code.coreboot.org/p/seabios/downloads/get/bios.bin-${PV}.gz
+ http://dev.gentoo.org/~cardoe/distfiles/${P}.tar.gz
+ http://dev.gentoo.org/~cardoe/distfiles/bios.bin-${PV}.gz
+ ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${P}-bp-${BACKPORTS}.tar.bz2}"
+fi
+
+DESCRIPTION="Open Source implementation of a 16-bit x86 BIOS"
+HOMEPAGE="http://www.seabios.org"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+IUSE="+binary"
+
+REQUIRED_USE="ppc? ( binary )
+ ppc64? ( binary )"
+
+DEPEND="!binary? ( >=sys-power/iasl-20060912 )"
+RDEPEND=""
+
+pkg_pretend() {
+ if ! use binary; then
+ ewarn "You have decided to compile your own SeaBIOS. This is not"
+ ewarn "supported by upstream unless you use their recommended"
+ ewarn "toolchain (which you are not)."
+ elog
+ ewarn "If you are intending to use this build with QEMU, realize"
+ ewarn "you will not receive any support if you have compiled your"
+ ewarn "own SeaBIOS. Virtual machines subtly fail based on changes"
+ ewarn "in SeaBIOS."
+ fi
+}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ if [[ -z "${EGIT_COMMIT}" ]]; then
+ sed -e "s/VERSION=.*/VERSION=${PV}/" \
+ -i "${S}/Makefile"
+ else
+ sed -e "s/VERSION=.*/VERSION=${PV}_pre${EGIT_COMMIT}/" \
+ -i "${S}/Makefile"
+ fi
+
+ epatch_user
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ if ! use binary ; then
+ LANG=C emake out/bios.bin
+ fi
+}
+
+src_install() {
+ insinto /usr/share/seabios
+ if ! use binary ; then
+ doins out/bios.bin
+ else
+ newins ../bios.bin-${PV} bios.bin
+ fi
+}