summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-08-27 13:25:41 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-08-27 13:25:41 +0000
commit465969c386d906ac57dc194916644a932b588a14 (patch)
tree4e9a0bee810ccaed1c5d7c5a370474838d40e9f5 /sys-firmware/seabios
parentrevbump -> EAPI 5 (diff)
downloadgentoo-2-465969c386d906ac57dc194916644a932b588a14.tar.gz
gentoo-2-465969c386d906ac57dc194916644a932b588a14.tar.bz2
gentoo-2-465969c386d906ac57dc194916644a932b588a14.zip
Attempt to utilize toolchain functions rather than having it use the defaults.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'sys-firmware/seabios')
-rw-r--r--sys-firmware/seabios/ChangeLog5
-rw-r--r--sys-firmware/seabios/seabios-1.7.3.ebuild12
2 files changed, 14 insertions, 3 deletions
diff --git a/sys-firmware/seabios/ChangeLog b/sys-firmware/seabios/ChangeLog
index 8288a96867bb..f7db7ac6a2b2 100644
--- a/sys-firmware/seabios/ChangeLog
+++ b/sys-firmware/seabios/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-firmware/seabios
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/ChangeLog,v 1.21 2013/08/20 02:47:49 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/ChangeLog,v 1.22 2013/08/27 13:25:41 cardoe Exp $
+
+ 27 Aug 2013; Doug Goldstein <cardoe@gentoo.org> seabios-1.7.3.ebuild:
+ Attempt to utilize toolchain functions rather than having it use the defaults.
*seabios-1.7.3 (20 Aug 2013)
diff --git a/sys-firmware/seabios/seabios-1.7.3.ebuild b/sys-firmware/seabios/seabios-1.7.3.ebuild
index ae41bf4da641..4df897d3d2a3 100644
--- a/sys-firmware/seabios/seabios-1.7.3.ebuild
+++ b/sys-firmware/seabios/seabios-1.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.7.3.ebuild,v 1.1 2013/08/20 02:47:49 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.7.3.ebuild,v 1.2 2013/08/27 13:25:41 cardoe Exp $
EAPI=5
@@ -79,7 +79,15 @@ src_configure() {
src_compile() {
if ! use binary ; then
- LANG=C emake out/bios.bin
+ LANG=C emake \
+ CC=$(tc-getCC) \
+ LD="$(tc-getLD).bfd" \
+ AR=$(tc-getAR) \
+ OBJCOPY=$(tc-getOBJCOPY) \
+ RANLIB=$(tc-getRANLIB) \
+ OBJDUMP=$(tc-getPROG OBJDUMP objdump) \
+ HOST_CC=$(tc-getBUILD_CC) \
+ out/bios.bin
fi
}