summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-08-18 20:15:26 +0000
committerUlrich Müller <ulm@gentoo.org>2012-08-18 20:15:26 +0000
commit12c3f47bb47920cc83333078f5ae082cac4ec302 (patch)
tree89e755c9bd69cf7167a8211daac5d0b2bca520dc /sys-firmware/iwl6050-ucode
parentPackage moved from net-wireless to sys-firmware, bug 429868. (diff)
downloadgentoo-2-12c3f47bb47920cc83333078f5ae082cac4ec302.tar.gz
gentoo-2-12c3f47bb47920cc83333078f5ae082cac4ec302.tar.bz2
gentoo-2-12c3f47bb47920cc83333078f5ae082cac4ec302.zip
Package moved from net-wireless to sys-firmware, bug 429868.
(Portage version: 2.1.11.10/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-firmware/iwl6050-ucode')
-rw-r--r--sys-firmware/iwl6050-ucode/ChangeLog33
-rw-r--r--sys-firmware/iwl6050-ucode/iwl6050-ucode-41.28.5.1.ebuild38
-rw-r--r--sys-firmware/iwl6050-ucode/iwl6050-ucode-9.201.4.1.ebuild28
-rw-r--r--sys-firmware/iwl6050-ucode/metadata.xml7
4 files changed, 106 insertions, 0 deletions
diff --git a/sys-firmware/iwl6050-ucode/ChangeLog b/sys-firmware/iwl6050-ucode/ChangeLog
new file mode 100644
index 000000000000..f2488d468d1c
--- /dev/null
+++ b/sys-firmware/iwl6050-ucode/ChangeLog
@@ -0,0 +1,33 @@
+# ChangeLog for sys-firmware/iwl6050-ucode
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl6050-ucode/ChangeLog,v 1.1 2012/08/18 20:15:26 ulm Exp $
+
+ 18 Aug 2012; Ulrich Müller <ulm@gentoo.org> +iwl6050-ucode-9.201.4.1.ebuild,
+ +iwl6050-ucode-41.28.5.1.ebuild, +metadata.xml:
+ Package moved from net-wireless to sys-firmware, bug 429868.
+
+ 16 Feb 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ iwl6050-ucode-41.28.5.1.ebuild:
+ x86 stable wrt bug #401567
+
+ 31 Jan 2012; Agostino Sarubbo <ago@gentoo.org>
+ iwl6050-ucode-41.28.5.1.ebuild:
+ Stable for amd64, wrt bug #401567
+
+ 29 Dec 2010; Michael Pagano <mpagano@gentoo.org>
+ iwl6050-ucode-41.28.5.1.ebuild:
+ Remove dependency on gentoo-sources. Add ewarn for unsupported kernel
+ version
+
+*iwl6050-ucode-41.28.5.1 (28 Dec 2010)
+
+ 28 Dec 2010; Michael Pagano <mpagano@gentoo.org>
+ +iwl6050-ucode-41.28.5.1.ebuild:
+ Version bump.
+
+*iwl6050-ucode-9.201.4.1 (25 Jun 2010)
+
+ 25 Jun 2010; Michael Pagano <mpagano@gentoo.org>
+ +iwl6050-ucode-9.201.4.1.ebuild:
+ Initial import of ucode for IWL 6050 series cards.
+
diff --git a/sys-firmware/iwl6050-ucode/iwl6050-ucode-41.28.5.1.ebuild b/sys-firmware/iwl6050-ucode/iwl6050-ucode-41.28.5.1.ebuild
new file mode 100644
index 000000000000..324399e7ac3e
--- /dev/null
+++ b/sys-firmware/iwl6050-ucode/iwl6050-ucode-41.28.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl6050-ucode/iwl6050-ucode-41.28.5.1.ebuild,v 1.1 2012/08/18 20:15:26 ulm Exp $
+
+inherit linux-info
+
+MY_PN="iwlwifi-6050-ucode"
+
+DESCRIPTION="Intel (R) Wireless WiFi Link 6250-AGN ucode"
+HOMEPAGE="http://intellinuxwireless.org/?p=iwlwifi"
+SRC_URI="http://intellinuxwireless.org/iwlwifi/downloads/${MY_PN}-${PV}.tgz"
+
+LICENSE="ipw3945"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RDEPEND=""
+
+DEPEND="|| ( >=sys-fs/udev-096 >=sys-apps/hotplug-20040923 )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /lib/firmware
+ doins "${S}/iwlwifi-6050-5.ucode" || die
+
+ dodoc README* || die "dodoc failed"
+
+ if kernel_is lt 2 6 37; then
+ echo
+ ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}"
+ ewarn "This microcode image requires a kernel >= 2.6.37 or a 2.6.36 "
+ ewarn "kernel using >= genpatches-2.6.36-8 which is included"
+ ewarn "in gentoo-sources >= 2.6.36-r6 or any kernel version >= 2.6.37."
+ fi
+}
diff --git a/sys-firmware/iwl6050-ucode/iwl6050-ucode-9.201.4.1.ebuild b/sys-firmware/iwl6050-ucode/iwl6050-ucode-9.201.4.1.ebuild
new file mode 100644
index 000000000000..335f8503c79e
--- /dev/null
+++ b/sys-firmware/iwl6050-ucode/iwl6050-ucode-9.201.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl6050-ucode/iwl6050-ucode-9.201.4.1.ebuild,v 1.1 2012/08/18 20:15:26 ulm Exp $
+
+MY_PN="iwlwifi-6050-ucode"
+
+DESCRIPTION="Intel (R) Wireless WiFi Link 6250-AGN ucode"
+HOMEPAGE="http://intellinuxwireless.org/?p=iwlwifi"
+SRC_URI="http://intellinuxwireless.org/iwlwifi/downloads/${MY_PN}-${PV}.tgz"
+
+LICENSE="ipw3945"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND=""
+
+DEPEND="|| ( >=sys-fs/udev-096 >=sys-apps/hotplug-20040923 )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /lib/firmware
+ doins "${S}/iwlwifi-6050-4.ucode" || die
+
+ dodoc README* || die "dodoc failed"
+}
diff --git a/sys-firmware/iwl6050-ucode/metadata.xml b/sys-firmware/iwl6050-ucode/metadata.xml
new file mode 100644
index 000000000000..1c37e40592a6
--- /dev/null
+++ b/sys-firmware/iwl6050-ucode/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mpagano@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>