summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-07-12 05:49:45 +0000
committerFabian Groffen <grobian@gentoo.org>2011-07-12 05:49:45 +0000
commitf24b1cdc895ae9a7f33b08e5a9a0052419666c98 (patch)
tree50b8f97836a99dbf064012b20708aabd34eaa1df /sys-devel
parentVersion bump. (diff)
downloadgentoo-2-f24b1cdc895ae9a7f33b08e5a9a0052419666c98.tar.gz
gentoo-2-f24b1cdc895ae9a7f33b08e5a9a0052419666c98.tar.bz2
gentoo-2-f24b1cdc895ae9a7f33b08e5a9a0052419666c98.zip
Move forgotten hunks from Darwin 8 patch to Darwin 8+9 patch, bug #373533
(Portage version: 2.2.01.18890-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb-apple/ChangeLog6
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch52
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch48
3 files changed, 57 insertions, 49 deletions
diff --git a/sys-devel/gdb-apple/ChangeLog b/sys-devel/gdb-apple/ChangeLog
index 92217ddc51b4..bc7233def036 100644
--- a/sys-devel/gdb-apple/ChangeLog
+++ b/sys-devel/gdb-apple/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gdb-apple
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.11 2011/07/11 12:08:37 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.12 2011/07/12 05:49:45 grobian Exp $
+
+ 12 Jul 2011; Fabian Groffen <grobian@gentoo.org>
+ files/gdb-apple-1518-darwin8-9.patch, files/gdb-apple-1518-darwin8.patch:
+ Move forgotten hunks from Darwin 8 patch to Darwin 8+9 patch, bug #373533
11 Jul 2011; Fabian Groffen <grobian@gentoo.org> gdb-apple-1518.ebuild,
+files/gdb-apple-1518-darwin8-9.patch, files/gdb-apple-1518-darwin8.patch:
diff --git a/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch b/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch
index 1ee8ab014c63..a05169cec25d 100644
--- a/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch
+++ b/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch
@@ -33,3 +33,55 @@
default:
return;
return;
+--- src/gdb/macosx/macosx-nat-inferior.c
++++ src/gdb/macosx/macosx-nat-inferior.c
+@@ -2692,6 +2692,7 @@
+ if (tp->private == NULL || tp->private->app_thread_port == 0)
+ return NULL;
+
++#ifdef THREAD_IDENTIFIER_INFO_COUNT
+ thread_identifier_info_data_t tident;
+ unsigned int info_count;
+ kern_return_t kret;
+@@ -2719,6 +2720,7 @@
+ }
+ }
+ }
++#endif
+ return buf;
+ }
+
+--- src/gdb/macosx/macosx-nat-infthread.c
++++ src/gdb/macosx/macosx-nat-infthread.c
+@@ -809,6 +809,7 @@
+ print_stack_frame (get_selected_frame (NULL), 0, LOCATION);
+ switch_to_thread (current_ptid);
+
++#ifdef THREAD_IDENTIFIER_INFO_COUNT
+ thread_identifier_info_data_t tident;
+ info_count = THREAD_IDENTIFIER_INFO_COUNT;
+ kret = thread_info (tid, THREAD_IDENTIFIER_INFO, (thread_info_t) &tident,
+@@ -878,6 +879,7 @@
+ printf_filtered ("\tcurrent priority: %d\n", pth.pth_priority);
+ printf_filtered ("\tmax priority: %d\n", pth.pth_maxpriority);
+ }
++#endif
+
+ printf_filtered ("\tsuspend count: %d", info.suspend_count);
+
+@@ -1175,6 +1177,7 @@
+ ui_out_field_fmt (uiout, "mach-port-number", "0x%s",
+ paddr_nz (app_thread_name));
+
++#ifdef THREAD_IDENTIFIER_INFO_COUNT
+ thread_identifier_info_data_t tident;
+ info_count = THREAD_IDENTIFIER_INFO_COUNT;
+ kret = thread_info (tid, THREAD_IDENTIFIER_INFO, (thread_info_t) &tident,
+@@ -1207,6 +1210,7 @@
+ paddr_nz (struct_addr));
+ }
+ }
++#endif
+ }
+
+
diff --git a/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch b/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch
index 4e7ec8c1d667..f8ecc30be7f6 100644
--- a/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch
+++ b/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch
@@ -18,22 +18,6 @@
#include "macosx-nat-dyld.h"
#include "macosx-nat-inferior.h"
-@@ -2692,6 +2692,7 @@
- if (tp->private == NULL || tp->private->app_thread_port == 0)
- return NULL;
-
-+#ifdef THREAD_IDENTIFIER_INFO_COUNT
- thread_identifier_info_data_t tident;
- unsigned int info_count;
- kern_return_t kret;
-@@ -2719,6 +2720,7 @@
- }
- }
- }
-+#endif
- return buf;
- }
-
--- src/gdb/macosx/macosx-nat-info.c
+++ src/gdb/macosx/macosx-nat-info.c
@@ -45,6 +45,22 @@
@@ -72,38 +56,6 @@
#include "macosx-nat-inferior.h"
#include "macosx-nat-inferior-util.h"
-@@ -809,6 +809,7 @@
- print_stack_frame (get_selected_frame (NULL), 0, LOCATION);
- switch_to_thread (current_ptid);
-
-+#ifdef THREAD_IDENTIFIER_INFO_COUNT
- thread_identifier_info_data_t tident;
- info_count = THREAD_IDENTIFIER_INFO_COUNT;
- kret = thread_info (tid, THREAD_IDENTIFIER_INFO, (thread_info_t) &tident,
-@@ -878,6 +879,7 @@
- printf_filtered ("\tcurrent priority: %d\n", pth.pth_priority);
- printf_filtered ("\tmax priority: %d\n", pth.pth_maxpriority);
- }
-+#endif
-
- printf_filtered ("\tsuspend count: %d", info.suspend_count);
-
-@@ -1175,6 +1177,7 @@
- ui_out_field_fmt (uiout, "mach-port-number", "0x%s",
- paddr_nz (app_thread_name));
-
-+#ifdef THREAD_IDENTIFIER_INFO_COUNT
- thread_identifier_info_data_t tident;
- info_count = THREAD_IDENTIFIER_INFO_COUNT;
- kret = thread_info (tid, THREAD_IDENTIFIER_INFO, (thread_info_t) &tident,
-@@ -1207,6 +1210,7 @@
- paddr_nz (struct_addr));
- }
- }
-+#endif
- }
-
-
--- src/gdb/macosx/macosx-tdep.c
+++ src/gdb/macosx/macosx-tdep.c
@@ -64,7 +64,6 @@