summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-30 17:33:48 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-30 17:33:48 +0000
commite100310f52f41cd2cf40de9190517dd8c1693664 (patch)
tree373b1bc8c164abcbc8febadfa27a4c76cc5af947 /sys-devel
parentold (diff)
downloadgentoo-2-e100310f52f41cd2cf40de9190517dd8c1693664.tar.gz
gentoo-2-e100310f52f41cd2cf40de9190517dd8c1693664.tar.bz2
gentoo-2-e100310f52f41cd2cf40de9190517dd8c1693664.zip
If a target w/out a libc is selected, then error out while attempting a step that requires a libc.
(Portage version: 2.1.4_rc11, RepoMan options: --force)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/ChangeLog9
-rw-r--r--sys-devel/crossdev/crossdev-0.9.18-r6.ebuild21
-rwxr-xr-xsys-devel/crossdev/files/crossdev14
-rw-r--r--sys-devel/crossdev/files/digest-crossdev-0.9.18-r60
4 files changed, 37 insertions, 7 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 462404125021..cad9d2ea9ed6 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.55 2007/11/04 03:01:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.56 2007/12/30 17:33:48 vapier Exp $
+
+*crossdev-0.9.18-r6 (30 Dec 2007)
+
+ 30 Dec 2007; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ +crossdev-0.9.18-r6.ebuild:
+ If a target w/out a libc is selected, then error out while attempting a step
+ that requires a libc.
*crossdev-0.9.18-r5 (04 Nov 2007)
diff --git a/sys-devel/crossdev/crossdev-0.9.18-r6.ebuild b/sys-devel/crossdev/crossdev-0.9.18-r6.ebuild
new file mode 100644
index 000000000000..30d023235fd4
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-0.9.18-r6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9.18-r6.ebuild,v 1.1 2007/12/30 17:33:48 vapier Exp $
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ || ( dev-util/unifdef sys-freebsd/freebsd-ubin )"
+
+src_install() {
+ dosbin "${FILESDIR}"/crossdev || die
+ dosed "s:GENTOO_PV:${PV}:" /usr/sbin/crossdev
+}
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index 23502696c87a..ed6cf122d771 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.100 2007/11/04 03:01:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.101 2007/12/30 17:33:48 vapier Exp $
cd /
umask 0022 #159111
@@ -308,11 +308,11 @@ hr() {
&& c=50 \
|| c=${c##* }
fi
- local ext=${1:- _ - ~ -} br=""
- while [[ ${#br} -lt ${c} ]] ; do
- br=${br}${ext}
- done
- echo "${br:0:${c}}"
+ local ext=${1:- _ - ~ -}
+ local sext=${ext//?/ }
+ local br=$(printf "%$((c + ${#ext}))s")
+ local banner=${br//${sext}/${ext}}
+ echo "${banner:0:${c}}"
}
##################
@@ -612,6 +612,7 @@ is_s1 || exit 0
if with_headers ; then
USE="${KUSE} ${USE}" CROSSCOMPILE_OPTS="headers-only" \
doemerge ${KPKG} ${KPKG}-quick
+[[ -n ${LPKG} ]] && \
USE="${LUSE} ${USE}" CROSSCOMPILE_OPTS="headers-only" \
doemerge ${LPKG} ${LPKG}-headers
fi
@@ -624,6 +625,7 @@ USE="${KUSE} ${USE}" CROSSCOMPILE_OPTS="" \
doemerge ${KPKG}
is_s3 || exit 0
+[[ -z ${LPKG} ]] && die "Invalid target '${CTARGET}': unknown libc"
set_eopts_on_pkg_status ${LPKG} crosscompile_opts_headers-only
USE="${LUSE} ${USE}" CROSSCOMPILE_OPTS="" \
doemerge ${LPKG}
diff --git a/sys-devel/crossdev/files/digest-crossdev-0.9.18-r6 b/sys-devel/crossdev/files/digest-crossdev-0.9.18-r6
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/crossdev/files/digest-crossdev-0.9.18-r6