summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-29 22:49:49 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-29 22:49:49 +0000
commitdfe326c64bc5c882e6168572204d0fc8faa79b4f (patch)
treef2bee3caa0fffe0a35cfb0f79c395b7c8e43233b /sys-devel
parentDo not use subslots on dev-lang/perl in perl apps (as opposed to modules) (diff)
downloadgentoo-2-dfe326c64bc5c882e6168572204d0fc8faa79b4f.tar.gz
gentoo-2-dfe326c64bc5c882e6168572204d0fc8faa79b4f.tar.bz2
gentoo-2-dfe326c64bc5c882e6168572204d0fc8faa79b4f.zip
Explicitly require Makefiles from CMake, to avoid failures when people like to enable ninja globally. Bug #496426.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog7
-rw-r--r--sys-devel/llvm/llvm-3.3-r2.ebuild7
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild7
3 files changed, 18 insertions, 3 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 3861112e62c5..457aa2b9acd4 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.162 2013/12/28 22:56:42 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.163 2013/12/29 22:49:49 mgorny Exp $
+
+ 29 Dec 2013; Michał Górny <mgorny@gentoo.org> llvm-3.3-r2.ebuild,
+ llvm-9999.ebuild:
+ Explicitly require Makefiles from CMake, to avoid failures when people like to
+ enable ninja globally. Bug #496426.
28 Dec 2013; Michał Górny <mgorny@gentoo.org> llvm-3.3-r2.ebuild:
Fix building R600 target, bug #496308.
diff --git a/sys-devel/llvm/llvm-3.3-r2.ebuild b/sys-devel/llvm/llvm-3.3-r2.ebuild
index aef1974f4f7c..df50241a90f6 100644
--- a/sys-devel/llvm/llvm-3.3-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.3-r2.ebuild,v 1.3 2013/12/28 22:56:42 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.3-r2.ebuild,v 1.4 2013/12/29 22:49:49 mgorny Exp $
EAPI=5
@@ -63,6 +63,11 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
S=${WORKDIR}/${P}.src
+# Some people actually override that in make.conf. That sucks since
+# we need to run install per-directory, and ninja can't do that...
+# so why did it call itself ninja in the first place?
+CMAKE_MAKEFILE_GENERATOR=emake
+
pkg_pretend() {
# in megs
# !clang !debug !multitarget -O2 400
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 08ba07caea52..9dce4ecf63e8 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.73 2013/12/28 14:02:19 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.74 2013/12/29 22:49:49 mgorny Exp $
EAPI=5
@@ -59,6 +59,11 @@ RDEPEND="${COMMON_DEPEND}
REQUIRED_USE="${PYTHON_REQUIRED_USE}
test? ( || ( $(python_gen_useflags 'python*') ) )"
+# Some people actually override that in make.conf. That sucks since
+# we need to run install per-directory, and ninja can't do that...
+# so why did it call itself ninja in the first place?
+CMAKE_MAKEFILE_GENERATOR=emake
+
pkg_pretend() {
# in megs
# !clang !debug !multitarget -O2 400