summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2014-10-21 18:55:02 +0000
committerFabian Groffen <grobian@gentoo.org>2014-10-21 18:55:02 +0000
commitdea22ecc70ce7c27d26b9df5565ee6397a223be5 (patch)
tree09c97bbcf1b3bf86a3aa4e291546201ab4fd977c /sys-devel
parentMark arm/arm64/m68k/s390/sh stable. (diff)
downloadgentoo-2-dea22ecc70ce7c27d26b9df5565ee6397a223be5.tar.gz
gentoo-2-dea22ecc70ce7c27d26b9df5565ee6397a223be5.tar.bz2
gentoo-2-dea22ecc70ce7c27d26b9df5565ee6397a223be5.zip
Finalise fixes for Yosemite
(Portage version: 2.2.14_rc1-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-apple/ChangeLog7
-rw-r--r--sys-devel/gcc-apple/files/gcc-apple-4.2.1_p5666-darwin14.patch28
-rw-r--r--sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild5
3 files changed, 23 insertions, 17 deletions
diff --git a/sys-devel/gcc-apple/ChangeLog b/sys-devel/gcc-apple/ChangeLog
index 07689ed794e3..3df27625ad70 100644
--- a/sys-devel/gcc-apple/ChangeLog
+++ b/sys-devel/gcc-apple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc-apple
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/ChangeLog,v 1.27 2014/10/19 19:03:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/ChangeLog,v 1.28 2014/10/21 18:55:02 grobian Exp $
+
+ 21 Oct 2014; Fabian Groffen <grobian@gentoo.org>
+ files/gcc-apple-4.2.1_p5666-darwin14.patch,
+ files/gcc-apple-4.2.1_p5666-perl-5.18.patch, gcc-apple-4.2.1_p5666-r1.ebuild:
+ Finalise fixes for Yosemite
19 Oct 2014; Fabian Groffen <grobian@gentoo.org>
+files/gcc-apple-4.2.1_p5666-darwin14.patch,
diff --git a/sys-devel/gcc-apple/files/gcc-apple-4.2.1_p5666-darwin14.patch b/sys-devel/gcc-apple/files/gcc-apple-4.2.1_p5666-darwin14.patch
index d33d66d7ffbe..a06c78365578 100644
--- a/sys-devel/gcc-apple/files/gcc-apple-4.2.1_p5666-darwin14.patch
+++ b/sys-devel/gcc-apple/files/gcc-apple-4.2.1_p5666-darwin14.patch
@@ -4,17 +4,16 @@ encode everything from Darwin 14 and up as 10.9.
Darwin 14 has some newer preprocessor stuff in its headers, work around
that.
-Lift some seemingly arbitrary restriction for Darwin 14 and up.
-
--- gcc/config/darwin-c.c
+++ gcc/config/darwin-c.c
-@@ -945,6 +945,10 @@
+@@ -945,6 +945,11 @@
result[2] = darwin_macosx_version_min[3];
if (darwin_macosx_version_min[4] != '\0')
{
+ if (ISDIGIT(darwin_macosx_version_min[4]))
+ {
+ result[2] = '9'; /* latest version we can encode */
++ result[3] = '0';
+ } else {
if (darwin_macosx_version_min[4] != '.')
goto fail;
@@ -27,6 +26,18 @@ Lift some seemingly arbitrary restriction for Darwin 14 and up.
}
else
result[3] = '0';
+--- gcc/config/darwin-driver.c
++++ gcc/config/darwin-driver.c
+@@ -174,8 +174,8 @@
+ version_p = osversion + 1;
+ if (ISDIGIT (*version_p))
+ major_vers = major_vers * 10 + (*version_p++ - '0');
+ if (major_vers > 4 + 9)
+- goto parse_failed;
++ major_vers = 4 + 9;
+ if (*version_p++ != '.')
+ goto parse_failed;
+ version_pend = strchr(version_p, '.');
--- gcc/libgcov.c
+++ gcc/libgcov.c
@@ -34,6 +34,14 @@
@@ -44,14 +55,3 @@ Lift some seemingly arbitrary restriction for Darwin 14 and up.
/* APPLE LOCAL begin instant off 6414141 */
#if defined(__APPLE__) && !defined(__STATIC__) && !defined(__ppc__) && !defined(__ppc64__) && !defined(__arm__)
#include <vproc.h>
---- gcc/config/darwin-driver.c
-+++ gcc/config/darwin-driver.c
-@@ -174,8 +174,6 @@
- version_p = osversion + 1;
- if (ISDIGIT (*version_p))
- major_vers = major_vers * 10 + (*version_p++ - '0');
-- if (major_vers > 4 + 9)
-- goto parse_failed;
- if (*version_p++ != '.')
- goto parse_failed;
- version_pend = strchr(version_p, '.');
diff --git a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild
index 431809fc2c60..431b0177ce0f 100644
--- a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild
+++ b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild,v 1.5 2014/10/19 19:03:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild,v 1.6 2014/10/21 18:55:02 grobian Exp $
EAPI="3"
@@ -112,7 +112,8 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-${GCC_VERS}-dsymutil.patch
# Pseudo-support OS X 10.10
- epatch "${FILESDIR}"/${P}-darwin14.patch
+ [[ ${CHOST} == *-darwin14 ]] && \
+ epatch "${FILESDIR}"/${P}-darwin14.patch
# bootstrapping might fail with host provided gcc on 10.4/x86
if ! is_crosscompile && ! echo "int main(){return 0;}" | gcc -o "${T}"/foo \