summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-04-08 23:55:16 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-04-08 23:55:16 +0000
commitd37c30fbe703c1055c289de663784d95e92c6e17 (patch)
tree5dba7791c37022711b84b8dc64c38a3cdfb11bdf /sys-devel
parentdev-util/netbeans: bumped to 7.0 rc2 (diff)
downloadgentoo-2-d37c30fbe703c1055c289de663784d95e92c6e17.tar.gz
gentoo-2-d37c30fbe703c1055c289de663784d95e92c6e17.tar.bz2
gentoo-2-d37c30fbe703c1055c289de663784d95e92c6e17.zip
Fix testsuite with GCC 4.6 (bug #362661).
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autogen/ChangeLog6
-rw-r--r--sys-devel/autogen/autogen-5.11.6.ebuild8
-rw-r--r--sys-devel/autogen/files/autogen-5.11.6-gcc46.patch26
3 files changed, 38 insertions, 2 deletions
diff --git a/sys-devel/autogen/ChangeLog b/sys-devel/autogen/ChangeLog
index 99aaaab59b85..cc436937d146 100644
--- a/sys-devel/autogen/ChangeLog
+++ b/sys-devel/autogen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/autogen
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/ChangeLog,v 1.73 2011/03/20 12:37:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/ChangeLog,v 1.74 2011/04/08 23:55:16 dirtyepic Exp $
+
+ 09 Apr 2011; Ryan Hill <dirtyepic@gentoo.org> autogen-5.11.6.ebuild,
+ +files/autogen-5.11.6-gcc46.patch:
+ Fix testsuite with GCC 4.6 (bug #362661).
20 Mar 2011; Raúl Porcel <armin76@gentoo.org> autogen-5.11.5.ebuild:
alpha/arm/ia64/s390/sh/sparc/x86 stable wrt #355941
diff --git a/sys-devel/autogen/autogen-5.11.6.ebuild b/sys-devel/autogen/autogen-5.11.6.ebuild
index 96991eb015bd..9e742f1200c1 100644
--- a/sys-devel/autogen/autogen-5.11.6.ebuild
+++ b/sys-devel/autogen/autogen-5.11.6.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/autogen-5.11.6.ebuild,v 1.1 2011/02/22 03:24:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/autogen-5.11.6.ebuild,v 1.2 2011/04/08 23:55:16 dirtyepic Exp $
EAPI="3"
+inherit eutils
+
DESCRIPTION="Program and text file generation"
HOMEPAGE="http://www.gnu.org/software/autogen/"
SRC_URI="mirror://gnu/${PN}/rel${PV}/${P}.tar.bz2"
@@ -16,6 +18,10 @@ IUSE=""
DEPEND=">=dev-scheme/guile-1.8
dev-libs/libxml2"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO
diff --git a/sys-devel/autogen/files/autogen-5.11.6-gcc46.patch b/sys-devel/autogen/files/autogen-5.11.6-gcc46.patch
new file mode 100644
index 000000000000..820472bea3e3
--- /dev/null
+++ b/sys-devel/autogen/files/autogen-5.11.6-gcc46.patch
@@ -0,0 +1,26 @@
+Fix testsuite
+
+https://bugs.gentoo.org/362661
+https://sourceforge.net/tracker/?func=detail&atid=103593&aid=3280108&group_id=3593
+
+--- a/autoopts/test/cond.test
++++ b/autoopts/test/cond.test
+@@ -112,13 +112,11 @@ ${AG_L} ${testname}.def || \
+
+ ( eval `echo ${cc_cmd} | \
+ ${SED} 's/-Werror//;s/-DTEST_TEST/-DSECOND -DTEST_TEST/' ` 2>&1 ) \
+- | ${SED} -n 's/.*# *warning:*/#warning/p' > ${testname}-cc.log
+-
+-echo '#warning undefining SECOND due to option name conflict' \
+- > ${testname}-xx.log
+-
+-cmp -s ${testname}-??.log || \
+- failure "warning diffs: `diff ${testname}-??.log`"
++ | ${SED} -n '/undefining SECOND due to option name conflict/p' \
++ > ${testname}-cc.log
++
++test -s ${testname}-cc.log || \
++ failure "warning diffs: 'undefining SECOND' not found"
+
+ # # # # # # # # # # FOURTH TEST # # # # # # # # #
+