summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-02-23 13:09:45 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-02-23 13:09:45 +0000
commitbba9562d9e616f08bd215bf90f876f8b527992d2 (patch)
treed334806c91432166b3d03421989342de355a4656 /sys-devel
parentUpdate llvm/clang 3.6 mask (diff)
downloadgentoo-2-bba9562d9e616f08bd215bf90f876f8b527992d2.tar.gz
gentoo-2-bba9562d9e616f08bd215bf90f876f8b527992d2.tar.bz2
gentoo-2-bba9562d9e616f08bd215bf90f876f8b527992d2.zip
Add 3.6 rc ebuild for testers
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog8
-rw-r--r--sys-devel/clang/clang-3.6.0_rc4-r100.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index f5a7ae293a52..9fac5efed22d 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.119 2015/02/21 10:08:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.120 2015/02/23 13:09:45 voyageur Exp $
+
+*clang-3.6.0_rc4-r100 (23 Feb 2015)
+
+ 23 Feb 2015; Bernard Cafarelli <voyageur@gentoo.org>
+ +clang-3.6.0_rc4-r100.ebuild:
+ Add 3.6 rc ebuild for testers
21 Feb 2015; Agostino Sarubbo <ago@gentoo.org> clang-3.5.0-r100.ebuild:
Stable for ppc64, wrt bug #530882
diff --git a/sys-devel/clang/clang-3.6.0_rc4-r100.ebuild b/sys-devel/clang/clang-3.6.0_rc4-r100.ebuild
new file mode 100644
index 000000000000..b4594f492738
--- /dev/null
+++ b/sys-devel/clang/clang-3.6.0_rc4-r100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.6.0_rc4-r100.ebuild,v 1.1 2015/02/23 13:09:45 voyageur Exp $
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.5"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug multitarget python +static-analyzer"
+
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer,${MULTILIB_USEDEP}]"
+
+# Please keep this package around since it's quite likely that we'll
+# return to separate LLVM & clang ebuilds when the cmake build system
+# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}