summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-05 20:37:40 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-05 20:37:40 +0000
commitaf0945b16f7c2f7cfaee8c5e111e1949c9ab9746 (patch)
tree9e5b14241698f82e75a04a24c35810429c40651e /sys-devel
parentfix revert SLOT behavior (diff)
downloadgentoo-2-af0945b16f7c2f7cfaee8c5e111e1949c9ab9746.tar.gz
gentoo-2-af0945b16f7c2f7cfaee8c5e111e1949c9ab9746.tar.bz2
gentoo-2-af0945b16f7c2f7cfaee8c5e111e1949c9ab9746.zip
change SLOT to be the same for all ebuilds now
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r8.ebuild9
-rw-r--r--sys-devel/gcc/gcc-3.2.3-r4.ebuild9
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r2.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r5.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r7.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.3.2.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.3.3-r3.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.3.3-r6.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.3.4-r1.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.3.4-r2.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.4.1-r3.ebuild9
11 files changed, 22 insertions, 93 deletions
diff --git a/sys-devel/gcc/gcc-2.95.3-r8.ebuild b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
index edb2aadfa93e..e9befdcce5da 100644
--- a/sys-devel/gcc/gcc-2.95.3-r8.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.33 2004/10/06 22:25:17 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.34 2004/12/05 20:37:40 vapier Exp $
inherit eutils flag-o-matic gcc versionator
@@ -49,12 +49,7 @@ IUSE="static nls bootstrap java build"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-if [ "${CHOST}" == "${CCHOST}" ]
-then
- SLOT="${MY_PV}"
-else
- SLOT="${CCHOST}-${MY_PV}"
-fi
+SLOT="${CTARGET:-${CHOST}}-${MY_PV}"
DEPEND="virtual/libc
>=sys-devel/gcc-config-1.2
diff --git a/sys-devel/gcc/gcc-3.2.3-r4.ebuild b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
index 3d1837d6a7ff..03e9d4176bec 100644
--- a/sys-devel/gcc/gcc-3.2.3-r4.ebuild
+++ b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.11 2004/10/06 22:18:48 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.12 2004/12/05 20:37:40 vapier Exp $
inherit eutils flag-o-matic libtool versionator
@@ -105,12 +105,7 @@ IUSE="static nls bootstrap java build"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-if [ "${CHOST}" == "${CCHOST}" ]
-then
- SLOT="${MY_PV}"
-else
- SLOT="${CCHOST}-${MY_PV}"
-fi
+SLOT="${CTARGET:-${CHOST}}-${MY_PV}"
DEPEND=">=sys-libs/glibc-2.3.2-r3
mips? ( >=sys-devel/binutils-2.13.90.0.16 )
diff --git a/sys-devel/gcc/gcc-3.3.2-r2.ebuild b/sys-devel/gcc/gcc-3.3.2-r2.ebuild
index 95ec2af42ada..737e8d31a9af 100644
--- a/sys-devel/gcc/gcc-3.3.2-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r2.ebuild,v 1.15 2004/11/21 16:58:56 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r2.ebuild,v 1.16 2004/12/05 20:37:40 vapier Exp $
IUSE="static nls bootstrap java build X multilib"
@@ -103,14 +103,7 @@ KEYWORDS="-* ~x86 ~mips ~sparc amd64 -hppa alpha ia64"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-if [ "${CHOST}" == "${CCHOST}" ]
-then
-# SLOT="${MY_PV}"
- SLOT="3.3"
-else
-# SLOT="${CCHOST}-${MY_PV}"
- SLOT="${CCHOST}-3.3"
-fi
+SLOT="${CTARGET:-${CHOST}}-3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.2-r5.ebuild b/sys-devel/gcc/gcc-3.3.2-r5.ebuild
index b8bea52aae46..68ccbdf6792d 100644
--- a/sys-devel/gcc/gcc-3.3.2-r5.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r5.ebuild,v 1.22 2004/11/21 16:58:56 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r5.ebuild,v 1.23 2004/12/05 20:37:40 vapier Exp $
IUSE="static nls bootstrap java build X multilib gcj"
@@ -107,14 +107,7 @@ KEYWORDS="x86 mips ~sparc ~amd64 -hppa alpha -ia64 ppc64"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-if [ "${CHOST}" == "${CCHOST}" ]
-then
-# SLOT="${MY_PV}"
- SLOT="3.3"
-else
-# SLOT="${CCHOST}-${MY_PV}"
- SLOT="${CCHOST}-3.3"
-fi
+SLOT="${CTARGET:-${CHOST}}-3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.2-r7.ebuild b/sys-devel/gcc/gcc-3.3.2-r7.ebuild
index a6b1409ee9a8..c02164b558b2 100644
--- a/sys-devel/gcc/gcc-3.3.2-r7.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r7.ebuild,v 1.13 2004/11/21 16:58:56 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r7.ebuild,v 1.14 2004/12/05 20:37:40 vapier Exp $
IUSE="static nls bootstrap java build X multilib gcj"
@@ -107,14 +107,7 @@ KEYWORDS="~x86 ~mips ~sparc ~amd64 -hppa ~alpha ~ia64 ~ppc64"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-if [ "${CHOST}" == "${CCHOST}" ]
-then
-# SLOT="${MY_PV}"
- SLOT="3.3"
-else
-# SLOT="${CCHOST}-${MY_PV}"
- SLOT="${CCHOST}-3.3"
-fi
+SLOT="${CTARGET:-${CHOST}}-3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.2.ebuild b/sys-devel/gcc/gcc-3.3.2.ebuild
index fdcdaf81a607..60929ad079d2 100644
--- a/sys-devel/gcc/gcc-3.3.2.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2.ebuild,v 1.16 2004/11/21 16:58:56 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2.ebuild,v 1.17 2004/12/05 20:37:40 vapier Exp $
inherit eutils flag-o-matic libtool versionator
@@ -90,14 +90,7 @@ IUSE="static nls bootstrap java build X multilib"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-if [ "${CHOST}" == "${CCHOST}" ]
-then
-# SLOT="${MY_PV}"
- SLOT="3.3"
-else
-# SLOT="${CCHOST}-${MY_PV}"
- SLOT="${CCHOST}-3.3"
-fi
+SLOT="${CTARGET:-${CHOST}}-3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.3-r3.ebuild b/sys-devel/gcc/gcc-3.3.3-r3.ebuild
index 0ceb64a1c1c0..491687c246bf 100644
--- a/sys-devel/gcc/gcc-3.3.3-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.3.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r3.ebuild,v 1.20 2004/11/21 16:58:56 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r3.ebuild,v 1.21 2004/12/05 20:37:40 vapier Exp $
inherit eutils flag-o-matic libtool versionator
@@ -100,14 +100,7 @@ IUSE="static nls bootstrap java build X multilib gcj fortran objc hardened uclib
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-if [ "${CHOST}" == "${CCHOST}" ]
-then
-# SLOT="${MY_PV}"
- SLOT="3.3"
-else
-# SLOT="${CCHOST}-${MY_PV}"
- SLOT="${CCHOST}-3.3"
-fi
+SLOT="${CTARGET:-${CHOST}}-3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.3-r6.ebuild b/sys-devel/gcc/gcc-3.3.3-r6.ebuild
index afd26dbdb4f1..a8917d906e0e 100644
--- a/sys-devel/gcc/gcc-3.3.3-r6.ebuild
+++ b/sys-devel/gcc/gcc-3.3.3-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r6.ebuild,v 1.21 2004/11/21 16:58:56 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r6.ebuild,v 1.22 2004/12/05 20:37:40 vapier Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -104,14 +104,7 @@ IUSE="static nls bootstrap java build X multilib gcj fortran objc pic hardened u
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-if [ "${CHOST}" == "${CCHOST}" ]
-then
-# SLOT="${MY_PV}"
- SLOT="3.3"
-else
-# SLOT="${CCHOST}-${MY_PV}"
- SLOT="${CCHOST}-3.3"
-fi
+SLOT="${CTARGET:-${CHOST}}-3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.4-r1.ebuild b/sys-devel/gcc/gcc-3.3.4-r1.ebuild
index aedb6a0fa3fc..7695a065b9f5 100644
--- a/sys-devel/gcc/gcc-3.3.4-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r1.ebuild,v 1.20 2004/11/21 16:58:56 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r1.ebuild,v 1.21 2004/12/05 20:37:40 vapier Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -108,14 +108,7 @@ IUSE="static nls bootstrap build X multilib gcj fortran objc pic hardened uclibc
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-if [ "${CHOST}" == "${CCHOST}" ]
-then
-# SLOT="${MY_PV}"
- SLOT="3.3"
-else
-# SLOT="${CCHOST}-${MY_PV}"
- SLOT="${CCHOST}-3.3"
-fi
+SLOT="${CTARGET:-${CHOST}}-3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.4-r2.ebuild b/sys-devel/gcc/gcc-3.3.4-r2.ebuild
index 8125b3ce4617..3e3fa8c35493 100644
--- a/sys-devel/gcc/gcc-3.3.4-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.3.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r2.ebuild,v 1.7 2004/11/21 16:58:56 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r2.ebuild,v 1.8 2004/12/05 20:37:40 vapier Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -108,14 +108,7 @@ IUSE="static nls bootstrap build X multilib gcj fortran objc pic hardened uclibc
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-if [ "${CHOST}" == "${CCHOST}" ]
-then
-# SLOT="${MY_PV}"
- SLOT="3.3"
-else
-# SLOT="${CCHOST}-${MY_PV}"
- SLOT="${CCHOST}-3.3"
-fi
+SLOT="${CTARGET:-${CHOST}}-3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.4.1-r3.ebuild b/sys-devel/gcc/gcc-3.4.1-r3.ebuild
index cd248932e379..3dd12c466f28 100644
--- a/sys-devel/gcc/gcc-3.4.1-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r3.ebuild,v 1.8 2004/11/08 00:27:48 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r3.ebuild,v 1.9 2004/12/05 20:37:40 vapier Exp $
IUSE="static nls bootstrap build multilib gcj gtk fortran objc hardened uclibc n32 n64"
@@ -194,12 +194,7 @@ STDCXX_INCDIR="${LIBPATH}/include/g++-v${MY_PV/\.*/}"
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
# GCC 3.4 introduces a new version of libstdc++
-if [ "${CHOST}" == "${CCHOST}" ]
-then
- SLOT="${MY_PV}"
-else
- SLOT="${CCHOST}-${MY_PV}"
-fi
+SLOT="${CTARGET:-${CHOST}}-${MY_PV}"
has_lib64() {
use amd64 && return 0