summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-23 02:12:54 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-23 02:12:54 +0000
commit9b71c222e857dfecf260ea37b0122f13a35dc01c (patch)
tree2117ade41b573fa5191fe55cb82a9821f91a0f99 /sys-devel
parentmarked x86 per bug 417145 (diff)
downloadgentoo-2-9b71c222e857dfecf260ea37b0122f13a35dc01c.tar.gz
gentoo-2-9b71c222e857dfecf260ea37b0122f13a35dc01c.tar.bz2
gentoo-2-9b71c222e857dfecf260ea37b0122f13a35dc01c.zip
Fix building with glibc-2.16+.
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gettext/ChangeLog6
-rw-r--r--sys-devel/gettext/files/gettext-0.18.1.1-no-gets.patch42
-rw-r--r--sys-devel/gettext/gettext-0.18.1.1-r3.ebuild3
3 files changed, 49 insertions, 2 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index 3341808a7653..f0fcbb9a82c8 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gettext
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.198 2012/04/26 13:32:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.199 2012/05/23 02:12:54 vapier Exp $
+
+ 23 May 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/gettext-0.18.1.1-no-gets.patch, gettext-0.18.1.1-r3.ebuild:
+ Fix building with glibc-2.16+.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> gettext-0.18.1.1-r3.ebuild:
keyword ~amd64-fbsd
diff --git a/sys-devel/gettext/files/gettext-0.18.1.1-no-gets.patch b/sys-devel/gettext/files/gettext-0.18.1.1-no-gets.patch
new file mode 100644
index 000000000000..9daa48eae649
--- /dev/null
+++ b/sys-devel/gettext/files/gettext-0.18.1.1-no-gets.patch
@@ -0,0 +1,42 @@
+hack until gzip pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/gettext-tools/libgettextpo/stdio.in.h
++++ b/gettext-tools/libgettextpo/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
+--- a/gettext-tools/gnulib-lib/stdio.in.h
++++ b/gettext-tools/gnulib-lib/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
+--- a/gettext-runtime/gnulib-lib/stdio.in.h
++++ b/gettext-runtime/gnulib-lib/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
diff --git a/sys-devel/gettext/gettext-0.18.1.1-r3.ebuild b/sys-devel/gettext/gettext-0.18.1.1-r3.ebuild
index 7ad1fc4a8ac2..37037e3df4bd 100644
--- a/sys-devel/gettext/gettext-0.18.1.1-r3.ebuild
+++ b/sys-devel/gettext/gettext-0.18.1.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.18.1.1-r3.ebuild,v 1.3 2012/04/26 13:32:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.18.1.1-r3.ebuild,v 1.4 2012/05/23 02:12:54 vapier Exp $
EAPI="2"
@@ -31,6 +31,7 @@ src_prepare() {
epunt_cxx
elibtoolize
epatch "${FILESDIR}"/${P}-uclibc-sched_param-def.patch
+ epatch "${FILESDIR}"/${P}-no-gets.patch
}
src_configure() {