summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-18 21:52:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-18 21:52:29 +0000
commit7e21a779a98740f509b59530989babd03e0f3a95 (patch)
tree701b58cb104efe28bf42138f0cdaff02cf4654d7 /sys-devel
parent2.2.0_alpha181 version bump. This includes all of the fixes in 2.1.12.6. (diff)
downloadgentoo-2-7e21a779a98740f509b59530989babd03e0f3a95.tar.gz
gentoo-2-7e21a779a98740f509b59530989babd03e0f3a95.tar.bz2
gentoo-2-7e21a779a98740f509b59530989babd03e0f3a95.zip
Drop a FreeBSD specific patch that causes problem with multilib on FreeBSD.
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog6
-rw-r--r--sys-devel/clang/clang-3.3_rc3.ebuild6
-rw-r--r--sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch8
3 files changed, 17 insertions, 3 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index 591ddbd40187..c3407539a3c0 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.89 2013/06/17 14:04:31 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.90 2013/06/18 21:52:29 aballier Exp $
+
+ 18 Jun 2013; Alexis Ballier <aballier@gentoo.org> clang-3.3_rc3.ebuild,
+ files/clang-3.1-gentoo-freebsd-fix-lib-path.patch:
+ Drop a FreeBSD specific patch that causes problem with multilib on FreeBSD.
17 Jun 2013; Bernard Cafarelli <voyageur@gentoo.org> clang-3.3_rc3.ebuild,
clang-9999.ebuild:
diff --git a/sys-devel/clang/clang-3.3_rc3.ebuild b/sys-devel/clang/clang-3.3_rc3.ebuild
index 32abc77f15e3..ea27939ed971 100644
--- a/sys-devel/clang/clang-3.3_rc3.ebuild
+++ b/sys-devel/clang/clang-3.3_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.3_rc3.ebuild,v 1.3 2013/06/17 14:04:31 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.3_rc3.ebuild,v 1.4 2013/06/18 21:52:29 aballier Exp $
EAPI=5
@@ -81,7 +81,9 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.1-gentoo-runtime-gcc-detection-v3.patch
# Fix search paths on FreeBSD, bug #409269
- epatch "${FILESDIR}"/${PN}-3.1-gentoo-freebsd-fix-lib-path.patch
+ # This patch causes problem for multilib on fbsd, see comments in the patch
+ # (aballier@g.o)
+ # epatch "${FILESDIR}"/${PN}-3.1-gentoo-freebsd-fix-lib-path.patch
# Fix regression caused by removal of USE=system-cxx-headers, bug #417541
# Needs to be updated for 3.2
diff --git a/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch b/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch
index 69ce7820df2b..702606f8a0ca 100644
--- a/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch
+++ b/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch
@@ -1,3 +1,11 @@
+This patch causes problem for multilib: GCCInstallation.getInstallPath() is
+empty in that case and 'clang -m32 foo.c' will put a -L with nothing after it
+but the .o file generated, effectively dropping it.
+With recent freebsd-lib versions, it is only needed for c++ with libstdc++,
+which is actually broken because clang++ cannot find the headers. it is fine
+with clang++ -stdlib=libc++.
+aballier@g.o
+
diff -upNr a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp
--- a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp 2012-05-24 04:08:48.393073000 -0400
+++ b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp 2012-05-24 04:11:38.113153421 -0400