summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-07 00:14:39 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-07 00:14:39 +0000
commit6bdfd455969b444e788d35097cbfe77accda76de (patch)
tree442f31121276c6270da24e4514f5d429dfc6970e /sys-devel
parenttweak the SLOT logic (diff)
downloadgentoo-2-6bdfd455969b444e788d35097cbfe77accda76de.tar.gz
gentoo-2-6bdfd455969b444e788d35097cbfe77accda76de.tar.bz2
gentoo-2-6bdfd455969b444e788d35097cbfe77accda76de.zip
dont screw with SLOTs that dont need it
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r8.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.2.3-r4.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r2.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r5.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r7.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.2.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.3-r3.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.3-r6.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.4-r1.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.4-r2.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.4.1-r3.ebuild4
11 files changed, 22 insertions, 22 deletions
diff --git a/sys-devel/gcc/gcc-2.95.3-r8.ebuild b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
index e9befdcce5da..b08bf2c14671 100644
--- a/sys-devel/gcc/gcc-2.95.3-r8.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.34 2004/12/05 20:37:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.35 2004/12/07 00:14:39 vapier Exp $
inherit eutils flag-o-matic gcc versionator
@@ -49,7 +49,7 @@ IUSE="static nls bootstrap java build"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-SLOT="${CTARGET:-${CHOST}}-${MY_PV}"
+SLOT="${MY_PV}"
DEPEND="virtual/libc
>=sys-devel/gcc-config-1.2
diff --git a/sys-devel/gcc/gcc-3.2.3-r4.ebuild b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
index 03e9d4176bec..81c7ce6130ad 100644
--- a/sys-devel/gcc/gcc-3.2.3-r4.ebuild
+++ b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.12 2004/12/05 20:37:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.13 2004/12/07 00:14:39 vapier Exp $
inherit eutils flag-o-matic libtool versionator
@@ -105,7 +105,7 @@ IUSE="static nls bootstrap java build"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-SLOT="${CTARGET:-${CHOST}}-${MY_PV}"
+SLOT="${MY_PV}"
DEPEND=">=sys-libs/glibc-2.3.2-r3
mips? ( >=sys-devel/binutils-2.13.90.0.16 )
diff --git a/sys-devel/gcc/gcc-3.3.2-r2.ebuild b/sys-devel/gcc/gcc-3.3.2-r2.ebuild
index 737e8d31a9af..8656a193a7ca 100644
--- a/sys-devel/gcc/gcc-3.3.2-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r2.ebuild,v 1.16 2004/12/05 20:37:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r2.ebuild,v 1.17 2004/12/07 00:14:39 vapier Exp $
IUSE="static nls bootstrap java build X multilib"
@@ -103,7 +103,7 @@ KEYWORDS="-* ~x86 ~mips ~sparc amd64 -hppa alpha ia64"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-SLOT="${CTARGET:-${CHOST}}-3.3"
+SLOT="3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.2-r5.ebuild b/sys-devel/gcc/gcc-3.3.2-r5.ebuild
index 68ccbdf6792d..e53c062675f8 100644
--- a/sys-devel/gcc/gcc-3.3.2-r5.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r5.ebuild,v 1.23 2004/12/05 20:37:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r5.ebuild,v 1.24 2004/12/07 00:14:39 vapier Exp $
IUSE="static nls bootstrap java build X multilib gcj"
@@ -107,7 +107,7 @@ KEYWORDS="x86 mips ~sparc ~amd64 -hppa alpha -ia64 ppc64"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-SLOT="${CTARGET:-${CHOST}}-3.3"
+SLOT="3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.2-r7.ebuild b/sys-devel/gcc/gcc-3.3.2-r7.ebuild
index c02164b558b2..bfc5d0c9e563 100644
--- a/sys-devel/gcc/gcc-3.3.2-r7.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r7.ebuild,v 1.14 2004/12/05 20:37:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r7.ebuild,v 1.15 2004/12/07 00:14:39 vapier Exp $
IUSE="static nls bootstrap java build X multilib gcj"
@@ -107,7 +107,7 @@ KEYWORDS="~x86 ~mips ~sparc ~amd64 -hppa ~alpha ~ia64 ~ppc64"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-SLOT="${CTARGET:-${CHOST}}-3.3"
+SLOT="3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.2.ebuild b/sys-devel/gcc/gcc-3.3.2.ebuild
index 60929ad079d2..13ced62bc3c5 100644
--- a/sys-devel/gcc/gcc-3.3.2.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2.ebuild,v 1.17 2004/12/05 20:37:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2.ebuild,v 1.18 2004/12/07 00:14:39 vapier Exp $
inherit eutils flag-o-matic libtool versionator
@@ -90,7 +90,7 @@ IUSE="static nls bootstrap java build X multilib"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-SLOT="${CTARGET:-${CHOST}}-3.3"
+SLOT="3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.3-r3.ebuild b/sys-devel/gcc/gcc-3.3.3-r3.ebuild
index 491687c246bf..3f24ce8140a4 100644
--- a/sys-devel/gcc/gcc-3.3.3-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.3.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r3.ebuild,v 1.21 2004/12/05 20:37:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r3.ebuild,v 1.22 2004/12/07 00:14:39 vapier Exp $
inherit eutils flag-o-matic libtool versionator
@@ -100,7 +100,7 @@ IUSE="static nls bootstrap java build X multilib gcj fortran objc hardened uclib
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-SLOT="${CTARGET:-${CHOST}}-3.3"
+SLOT="3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.3-r6.ebuild b/sys-devel/gcc/gcc-3.3.3-r6.ebuild
index a8917d906e0e..549474e37e3b 100644
--- a/sys-devel/gcc/gcc-3.3.3-r6.ebuild
+++ b/sys-devel/gcc/gcc-3.3.3-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r6.ebuild,v 1.22 2004/12/05 20:37:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r6.ebuild,v 1.23 2004/12/07 00:14:39 vapier Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -104,7 +104,7 @@ IUSE="static nls bootstrap java build X multilib gcj fortran objc pic hardened u
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-SLOT="${CTARGET:-${CHOST}}-3.3"
+SLOT="3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.4-r1.ebuild b/sys-devel/gcc/gcc-3.3.4-r1.ebuild
index 7695a065b9f5..15d03b6ede4d 100644
--- a/sys-devel/gcc/gcc-3.3.4-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r1.ebuild,v 1.21 2004/12/05 20:37:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r1.ebuild,v 1.22 2004/12/07 00:14:39 vapier Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -108,7 +108,7 @@ IUSE="static nls bootstrap build X multilib gcj fortran objc pic hardened uclibc
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-SLOT="${CTARGET:-${CHOST}}-3.3"
+SLOT="3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.3.4-r2.ebuild b/sys-devel/gcc/gcc-3.3.4-r2.ebuild
index 3e3fa8c35493..d2b260aad43c 100644
--- a/sys-devel/gcc/gcc-3.3.4-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.3.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r2.ebuild,v 1.8 2004/12/05 20:37:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r2.ebuild,v 1.9 2004/12/07 00:14:39 vapier Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -108,7 +108,7 @@ IUSE="static nls bootstrap build X multilib gcj fortran objc pic hardened uclibc
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-SLOT="${CTARGET:-${CHOST}}-3.3"
+SLOT="3.3"
# We need the later binutils for support of the new cleanup attribute.
# 'make check' fails for about 10 tests (if I remember correctly) less
diff --git a/sys-devel/gcc/gcc-3.4.1-r3.ebuild b/sys-devel/gcc/gcc-3.4.1-r3.ebuild
index 3dd12c466f28..a2eb0f72ff40 100644
--- a/sys-devel/gcc/gcc-3.4.1-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r3.ebuild,v 1.9 2004/12/05 20:37:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r3.ebuild,v 1.10 2004/12/07 00:14:39 vapier Exp $
IUSE="static nls bootstrap build multilib gcj gtk fortran objc hardened uclibc n32 n64"
@@ -194,7 +194,7 @@ STDCXX_INCDIR="${LIBPATH}/include/g++-v${MY_PV/\.*/}"
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
# GCC 3.4 introduces a new version of libstdc++
-SLOT="${CTARGET:-${CHOST}}-${MY_PV}"
+SLOT="${MY_PV}"
has_lib64() {
use amd64 && return 0