summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-21 05:43:32 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-21 05:43:32 +0000
commit589950e7eb169897cc5e345a88d27a7e264d9cef (patch)
treef1ef1177431eaf5deb7439f238a9b6cd672fccc7 /sys-devel
parent*** empty log message *** (diff)
downloadgentoo-2-589950e7eb169897cc5e345a88d27a7e264d9cef.tar.gz
gentoo-2-589950e7eb169897cc5e345a88d27a7e264d9cef.tar.bz2
gentoo-2-589950e7eb169897cc5e345a88d27a7e264d9cef.zip
*** empty log message ***
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-2.95.2-r1.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/sys-devel/gcc/gcc-2.95.2-r1.ebuild b/sys-devel/gcc/gcc-2.95.2-r1.ebuild
index 87e79aa0f17c..454c841e2183 100644
--- a/sys-devel/gcc/gcc-2.95.2-r1.ebuild
+++ b/sys-devel/gcc/gcc-2.95.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.2-r1.ebuild,v 1.3 2000/08/21 05:42:23 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.2-r1.ebuild,v 1.4 2000/08/21 05:43:32 achim Exp $
P=gcc-2.95.2
A="gcc-2.95.2.tar.gz libg++-2.8.1.3.tar.gz libg++-2.8.1.3-20000816.diff.gz"
@@ -20,17 +20,17 @@ HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
src_unpack() {
unpack gcc-2.95.2.tar.gz
-# unpack libg++-2.8.1.3.tar.gz
-# cd ${S}/../libg++-2.8.1.3
-# gzip -dc ${DISTDIR}/libg++-2.8.1.3-20000816.diff.gz | patch -p1
-# einfo "Moving trees"
+ unpack libg++-2.8.1.3.tar.gz
+ cd ${S}/../libg++-2.8.1.3
+ gzip -dc ${DISTDIR}/libg++-2.8.1.3-20000816.diff.gz | patch -p1
+ einfo "Moving trees"
cd ${S}
-# rm -rf texinfo
-# mv ../libg++-2.8.1.3/* .
-# rmdir ../libg++-2.8.1.3
-# zcat ${O}/files/${A0} | patch -p0
-# zcat ${O}/files/${A1} | patch -p0
-# zcat ${O}/files/${A2} | patch -p0
+ rm -rf texinfo
+ mv ../libg++-2.8.1.3/* .
+ rmdir ../libg++-2.8.1.3
+ zcat ${O}/files/${A0} | patch -p0
+ zcat ${O}/files/${A1} | patch -p0
+ zcat ${O}/files/${A2} | patch -p0
}
src_compile() {
@@ -43,10 +43,8 @@ src_compile() {
fi
${S}/configure --prefix=${T} --enable-version-specific-runtime-libs \
--host=${CHOST} --enable-threads --enable-shared \
- --with-local-prefix=${T}/local --enable-nls
-# --with-gxx-include-dir=${T}/include/g++ \
-# --enable-nls
-#--enable-language=c,c++
+ --with-local-prefix=${T}/local --enable-nls \
+ --with-gxx-include-dir=${T}/include/g++ \
make bootstrap-lean
}