summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-05-27 13:39:40 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-05-27 13:39:40 +0000
commit508fe414d6fcd931a3c9d43ec3153b7615375137 (patch)
treef9b625354fa6a352717de2374d38375aea6da267 /sys-devel
parentFixing bug #51821 (gcc 3.3 compilation problems) (Manifest recommit) (diff)
downloadgentoo-2-508fe414d6fcd931a3c9d43ec3153b7615375137.tar.gz
gentoo-2-508fe414d6fcd931a3c9d43ec3153b7615375137.tar.bz2
gentoo-2-508fe414d6fcd931a3c9d43ec3153b7615375137.zip
New version which incorporates a new ac-wrapper for a few bug fixes (#47772 and #41389)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog12
-rw-r--r--sys-devel/autoconf/Manifest3
-rw-r--r--sys-devel/autoconf/autoconf-2.59-r4.ebuild145
-rw-r--r--sys-devel/autoconf/files/ac-wrapper-4.pl83
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.59-r42
5 files changed, 244 insertions, 1 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 98358a6de720..9e8caa000705 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-devel/autoconf
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.45 2004/05/27 13:13:51 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.46 2004/05/27 13:39:40 caleb Exp $
+
+*autoconf-2.59-r4 (27 May 2004)
+
+ 27 May 2004; Caleb Tennis <caleb@gentoo.org> autoconf-2.59-r4.ebuild:
+ New version which incorporates a new ac-wrapper-4.pl
+ Use a subroutine which will pull out the greatest AC_PREREQ() value in
+ a configure.in file in case there is more than one (see Bug #41389).
+ Also, change the gt statements to be 2.13 instead of 2.1 or AC_PREREQs fail
+ on seeing 2.12 for example (actually, don't fail, but use autoconf-2.5x which
+ is not correct).
27 May 2004; Caleb Tennis <caleb@gentoo.org> autoconf-2.59-r3.ebuild:
Mark x86 stable
diff --git a/sys-devel/autoconf/Manifest b/sys-devel/autoconf/Manifest
index 4e3bff188144..d271b261d9aa 100644
--- a/sys-devel/autoconf/Manifest
+++ b/sys-devel/autoconf/Manifest
@@ -3,6 +3,7 @@ MD5 04e24adcbc105ab2e0bffe76e12508b5 autoconf-2.58-r1.ebuild 3491
MD5 996d335822c6fbb0fa1cc4e4ea6fe4f5 autoconf-2.58.ebuild 3489
MD5 5edbafe42e7ce5f0cd6c2552822111f1 autoconf-2.57a-r1.ebuild 3380
MD5 21258175b382f1909e536bbbf8c3b0c9 autoconf-2.57-r1.ebuild 3225
+MD5 d7a25a3dd679f5f32015854d3f1d3ff5 autoconf-2.59-r4.ebuild 3486
MD5 411c2bb9303f39fbb4f0b87d3d0d89f6 ChangeLog 7564
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 c98042870fa4228b40ce57442d91ca47 files/autoconf-2.57a-infopage-namechange.patch 5119
@@ -16,7 +17,9 @@ MD5 f935499520b964a1fcfc23b68d8c8558 files/autoconf-2.13-configure.in-gentoo.dif
MD5 e3137dce2883f1c5fa9adbee73a86113 files/autoconf-2.5-infopage-namechange.patch 4043
MD5 1afb97b888b8302d8083fc7a794b0e39 files/ac-wrapper-2.pl 2527
MD5 6a3f9163d26cfd51653d90bebda1cb5d files/ac-wrapper-3.pl 2769
+MD5 75ca061e12707aa8d07627da4e50d6aa files/ac-wrapper-4.pl 2783
MD5 cff703b5ddfcb647f18aeed0111b8138 files/digest-autoconf-2.57-r1 131
MD5 d7f6caec3dfd602a77238546246b91b7 files/digest-autoconf-2.58-r1 131
MD5 b310d32d1d5c26cb84206bfda473da1c files/digest-autoconf-2.59-r3 131
+MD5 b310d32d1d5c26cb84206bfda473da1c files/digest-autoconf-2.59-r4 131
MD5 12f8fb67eaf50f87ed7825356503e8d7 files/autoconf-2.13-configure-gentoo.diff 958
diff --git a/sys-devel/autoconf/autoconf-2.59-r4.ebuild b/sys-devel/autoconf/autoconf-2.59-r4.ebuild
new file mode 100644
index 000000000000..6b81b1003fc7
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.59-r4.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.59-r4.ebuild,v 1.1 2004/05/27 13:39:40 caleb Exp $
+
+inherit eutils
+
+OLD_PV="2.13"
+OLD_P="${PN}-${OLD_PV}"
+S="${WORKDIR}/${P}"
+OLD_S="${WORKDIR}/${OLD_P}"
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+SRC_URI="http://ftp.gnu.org/gnu/${PN}/${P}.tar.bz2
+ mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gnu/${PN}/${OLD_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+KEYWORDS="~x86 ~ppc ~ppc64 ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390"
+IUSE=""
+
+DEPEND=">=sys-apps/texinfo-4.3
+ =sys-devel/m4-1.4*
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${OLD_S}
+ epatch ${FILESDIR}/${OLD_P}-configure-gentoo.diff
+ epatch ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff
+
+ cd ${S}
+ # Enable both autoconf-2.1 and autoconf-2.5 info pages
+ epatch ${FILESDIR}/${PN}-2.58-infopage-namechange.patch
+ ln -snf ${S}/doc/autoconf.texi ${S}/doc/autoconf25.texi
+}
+
+src_compile() {
+ #
+ # ************ autoconf-2.5x ************
+ #
+ cd ${S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+ cd ${OLD_S}
+
+ sed -i 's|\* Autoconf:|\* Autoconf v2.1:|' autoconf.texi
+ cp autoconf.texi autoconf.texi.orig
+ sed -e '/START-INFO-DIR-ENTRY/ i INFO-DIR-SECTION GNU programming tools' \
+ autoconf.texi.orig > autoconf.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ newexe ${FILESDIR}/ac-wrapper-4.pl ac-wrapper.pl
+ dosed "s:2\.5x:${PV}:g" /usr/lib/${PN}/ac-wrapper.pl
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+
+ # need to use 'DESTDIR' here, else perl stuff puke
+ cd ${S}
+ make DESTDIR=${D} \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${PV}
+ done
+ # new in 2.5x
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
+
+# mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+
+ docinto ${PV}
+ dodoc AUTHORS BUGS NEWS README TODO THANKS
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+
+ # need to use 'prefix' here, else we get sandbox problems
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD_PV}
+ dodoc AUTHORS NEWS README TODO
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1
+
+ # from binutils
+ rm -f ${D}/usr/share/info/standards.info*
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ if [ -e ${ROOT}/usr/bin/${x} ]
+ then
+ rm -f ${ROOT}/usr/bin/${x}
+ fi
+ done
+}
+
+pkg_postinst() {
+
+ echo
+ einfo "Please note that the 'WANT_AUTOCONF_?_?=1' have changed to:"
+ echo
+ einfo " WANT_AUTOCONF=<required version>"
+ echo
+ einfo "For instance: WANT_AUTOCONF=2.5"
+ echo
+}
diff --git a/sys-devel/autoconf/files/ac-wrapper-4.pl b/sys-devel/autoconf/files/ac-wrapper-4.pl
new file mode 100644
index 000000000000..e03c0fdd666c
--- /dev/null
+++ b/sys-devel/autoconf/files/ac-wrapper-4.pl
@@ -0,0 +1,83 @@
+#!/usr/bin/perl
+#
+#
+# Guillaume Cottenceau (gc@mandrakesoft.com)
+#
+# Copyright 2001 MandrakeSoft
+#
+# This software may be freely redistributed under the terms of the GNU
+# public license.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#
+#
+# Executes the correct autoconf version.
+#
+# - defaults to autoconf-2.13
+# - runs autoconf-2.5x if it exists and...
+# - envvar WANT_AUTOCONF is set to `2.5'
+# -or-
+# - configure.ac is present
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# are stringwise greater than '2.1'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.1'
+# -or-
+# - `Makefile.in' was generated by automake-1.6 or superior, which
+# specifically needs autoconf-2.5x
+#
+
+#use MDK::Common;
+
+sub cat_ { local *F; open F, $_[0] or return; my @l = <F>; wantarray ? @l : join '', @l }
+sub ac_version {
+ return ((@versions = cat_(shift) =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{3}[0-9]?)[^\)]*\]?\)/mg) ? ((sort @versions)[-1]) : '');
+}
+
+my $binary = "$0-2.13";
+my $binary_new = "$0-2.5x";
+
+# Autoconf is really getting out of hand, so rather start supporting
+# WANT_AUTOCONF = "2.5" the like. Unfortunately it override the old
+# variables, so if not set, just convert the old variables ....
+if ($ENV{WANT_AUTOCONF} eq "") {
+ if ($ENV{WANT_AUTOCONF_2_1}) {
+ $ENV{WANT_AUTOCONF} = '2.1';
+ } elsif ($ENV{WANT_AUTOCONF_2_5}) {
+ $ENV{WANT_AUTOCONF} = '2.5';
+ }
+}
+
+if ($ENV{WANT_AUTOCONF} ne '2.1') {
+ if ((! -x $binary) # handle stuff like autom4te, where only 2.5x have the binary
+ || (-x $binary_new # user may have only 2.13
+ && (($ENV{WANT_AUTOCONF} eq '2.5')
+ || -r 'configure.ac'
+ || ac_version('configure.in') gt '2.13'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.13'
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
+ || ac_version('aclocal.m4') gt '2.13'))) {
+ $ENV{WANT_AUTOCONF} = '2.5'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_new;
+ } else {
+ $ENV{WANT_AUTOCONF} = '2.1'; # for further consistency
+ }
+}
+
+# Set AUTOM4TE to the proper version (bug #40983).
+# Do not set it for 2.13 though, as it does not ship autom4te.
+if(($ENV{AUTOM4TE} eq "")
+ && ($ENV{WANT_AUTOCONF} = '2.5')
+ && ($0 ne 'autom4te')) {
+ $ENV{AUTOM4TE} = "autom4te-2.5x";
+}
+
+$ENV{WANT_ACWRAPPER_DEBUG} and print STDERR "ac-wrapper: will execute <$binary>\n";
+
+exec $binary, @ARGV;
+
+die "ac-wrapper: ouch, couldn't call binary ($binary).\n";
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.59-r4 b/sys-devel/autoconf/files/digest-autoconf-2.59-r4
new file mode 100644
index 000000000000..a9ae401381fd
--- /dev/null
+++ b/sys-devel/autoconf/files/digest-autoconf-2.59-r4
@@ -0,0 +1,2 @@
+MD5 1ee40f7a676b3cfdc0e3f7cd81551b5f autoconf-2.59.tar.bz2 925073
+MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844