summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-07-11 12:08:37 +0000
committerFabian Groffen <grobian@gentoo.org>2011-07-11 12:08:37 +0000
commit3abf93684b47afedd96881b7aefe992723d87b94 (patch)
tree9b66c8b84ae72d9ee8edf68cb0f27fea47759ab1 /sys-devel
parentRemoved unnecessary maskings of sec-policy/selinux-*-3 (diff)
downloadgentoo-2-3abf93684b47afedd96881b7aefe992723d87b94.tar.gz
gentoo-2-3abf93684b47afedd96881b7aefe992723d87b94.tar.bz2
gentoo-2-3abf93684b47afedd96881b7aefe992723d87b94.zip
Fix compilation on Darwin 9 (10.5) by extracting parts of the Darwin 8 patch
(Portage version: 2.2.01.18826-prefix/cvs/SunOS i386)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb-apple/ChangeLog6
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch35
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch35
-rw-r--r--sys-devel/gdb-apple/gdb-apple-1518.ebuild3
4 files changed, 42 insertions, 37 deletions
diff --git a/sys-devel/gdb-apple/ChangeLog b/sys-devel/gdb-apple/ChangeLog
index a8da67ad9922..92217ddc51b4 100644
--- a/sys-devel/gdb-apple/ChangeLog
+++ b/sys-devel/gdb-apple/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gdb-apple
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.10 2011/04/03 09:52:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.11 2011/07/11 12:08:37 grobian Exp $
+
+ 11 Jul 2011; Fabian Groffen <grobian@gentoo.org> gdb-apple-1518.ebuild,
+ +files/gdb-apple-1518-darwin8-9.patch, files/gdb-apple-1518-darwin8.patch:
+ Fix compilation on Darwin 9 (10.5) by extracting parts of the Darwin 8 patch
*gdb-apple-1518 (03 Apr 2011)
diff --git a/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch b/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch
new file mode 100644
index 000000000000..1ee8ab014c63
--- /dev/null
+++ b/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch
@@ -0,0 +1,35 @@
+--- src/gdb/macosx/macosx-nat-dyld.c
++++ src/gdb/macosx/macosx-nat-dyld.c
+@@ -2083,7 +2083,9 @@
+ case MH_DYLIB:
+ case MH_DYLINKER:
+ case MH_BUNDLE:
++#ifdef MH_KEXT_BUNDLE
+ case MH_KEXT_BUNDLE:
++#endif
+ break;
+ case MH_FVMLIB:
+ case MH_PRELOAD:
+@@ -2412,7 +2414,9 @@
+ break;
+ case MH_DYLINKER:
+ case MH_BUNDLE:
++#ifdef MH_KEXT_BUNDLE
+ case MH_KEXT_BUNDLE:
++#endif
+ entry->reason = dyld_reason_dyld;
+ break;
+ default:
+--- src/gdb/macosx/macosx-nat-dyld-process.c
++++ src/gdb/macosx/macosx-nat-dyld-process.c
+@@ -407,7 +407,9 @@
+ case MH_DYLIB:
+ break;
+ case MH_BUNDLE:
++#ifdef MH_KEXT_BUNDLE
+ case MH_KEXT_BUNDLE:
++#endif
+ break;
+ default:
+ return;
+ return;
diff --git a/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch b/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch
index 171b7711b2ed..4e7ec8c1d667 100644
--- a/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch
+++ b/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch
@@ -174,38 +174,3 @@
/* Create a string containing the full error/warning message. Need
to call query with this full string, as otherwize the reason
---- src/gdb/macosx/macosx-nat-dyld.c
-+++ src/gdb/macosx/macosx-nat-dyld.c
-@@ -2083,7 +2083,9 @@
- case MH_DYLIB:
- case MH_DYLINKER:
- case MH_BUNDLE:
-+#ifdef MH_KEXT_BUNDLE
- case MH_KEXT_BUNDLE:
-+#endif
- break;
- case MH_FVMLIB:
- case MH_PRELOAD:
-@@ -2412,7 +2414,9 @@
- break;
- case MH_DYLINKER:
- case MH_BUNDLE:
-+#ifdef MH_KEXT_BUNDLE
- case MH_KEXT_BUNDLE:
-+#endif
- entry->reason = dyld_reason_dyld;
- break;
- default:
---- src/gdb/macosx/macosx-nat-dyld-process.c
-+++ src/gdb/macosx/macosx-nat-dyld-process.c
-@@ -407,7 +407,9 @@
- case MH_DYLIB:
- break;
- case MH_BUNDLE:
-+#ifdef MH_KEXT_BUNDLE
- case MH_KEXT_BUNDLE:
-+#endif
- break;
- default:
- return;
- return;
diff --git a/sys-devel/gdb-apple/gdb-apple-1518.ebuild b/sys-devel/gdb-apple/gdb-apple-1518.ebuild
index d4c4314c7a3d..9979cfff1c50 100644
--- a/sys-devel/gdb-apple/gdb-apple-1518.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-1518.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-1518.ebuild,v 1.1 2011/04/03 09:52:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-1518.ebuild,v 1.2 2011/07/11 12:08:37 grobian Exp $
EAPI="3"
@@ -29,6 +29,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-no-global-gdbinit.patch
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
epatch "${FILESDIR}"/${P}-task_dyld_info.patch
+ epatch "${FILESDIR}"/${P}-darwin8-9.patch
[[ ${CHOST} == *-darwin8 ]] && epatch "${FILESDIR}"/${P}-darwin8.patch
}