summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-28 13:18:23 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-28 13:18:23 +0000
commit2df81b7cd78ab9e78bccab2cf9eb18ede2bc3558 (patch)
tree6299e11166a6b626511212d30ca81ae11c50a62f /sys-devel
parentBump to TeX Live 2011 (diff)
downloadgentoo-2-2df81b7cd78ab9e78bccab2cf9eb18ede2bc3558.tar.gz
gentoo-2-2df81b7cd78ab9e78bccab2cf9eb18ede2bc3558.tar.bz2
gentoo-2-2df81b7cd78ab9e78bccab2cf9eb18ede2bc3558.zip
[sys-devel/ucpp] Initial import to tree
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/ucpp/ChangeLog10
-rw-r--r--sys-devel/ucpp/files/tune.h.patch28
-rw-r--r--sys-devel/ucpp/metadata.xml8
-rw-r--r--sys-devel/ucpp/ucpp-1.3.ebuild34
4 files changed, 80 insertions, 0 deletions
diff --git a/sys-devel/ucpp/ChangeLog b/sys-devel/ucpp/ChangeLog
new file mode 100644
index 000000000000..16d782f990f9
--- /dev/null
+++ b/sys-devel/ucpp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-devel/ucpp
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ucpp/ChangeLog,v 1.1 2011/07/28 13:18:23 alexxy Exp $
+
+*ucpp-1.3 (28 Jul 2011)
+
+ 28 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +ucpp-1.3.ebuild,
+ +files/tune.h.patch, +metadata.xml:
+ Initial import to tree
+
diff --git a/sys-devel/ucpp/files/tune.h.patch b/sys-devel/ucpp/files/tune.h.patch
new file mode 100644
index 000000000000..7455dd2425bf
--- /dev/null
+++ b/sys-devel/ucpp/files/tune.h.patch
@@ -0,0 +1,28 @@
+--- tune.h 2008-10-01 19:15:41.000000000 +0200
++++ tune.h.new 2009-03-22 11:59:42.000000000 +0100
+@@ -281,10 +281,10 @@
+ *
+ * If you want no standard assertion, define STD_ASSERT to 0.
+ */
+-/*
++
+ #define STD_ASSERT "cpu(i386)", "machine(i386)", "system(unix)", \
+ "system(freebsd)"
+-*/
++
+
+ /* ====================================================================== */
+ /*
+@@ -293,10 +293,10 @@
+ * Each string must be either "name" or "name=token-list". If you want
+ * no predefined macro, define STD_MACROS to 0.
+ */
+-/*
++
+ #define STD_MACROS "__FreeBSD=4", "__unix", "__i386", \
+ "__FreeBSD__=4", "__unix__", "__i386__"
+-*/
++
+
+ /* ====================================================================== */
+ /*
diff --git a/sys-devel/ucpp/metadata.xml b/sys-devel/ucpp/metadata.xml
new file mode 100644
index 000000000000..efb490d78817
--- /dev/null
+++ b/sys-devel/ucpp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>sci@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-devel/ucpp/ucpp-1.3.ebuild b/sys-devel/ucpp/ucpp-1.3.ebuild
new file mode 100644
index 000000000000..02afcbfe3559
--- /dev/null
+++ b/sys-devel/ucpp/ucpp-1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ucpp/ucpp-1.3.ebuild,v 1.1 2011/07/28 13:18:23 alexxy Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A quick and light preprocessor, but anyway fully compliant to C99"
+HOMEPAGE="http://code.google.com/p/ucpp/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/tune.h.patch
+}
+
+src_compile() {
+ emake \
+ FLAGS="${CFLAGS} -DSTAND_ALONE" \
+ CC=$(tc-getCC) \
+ STAND_ALONE="-DSTAND_ALONE" || die
+}
+
+src_install() {
+ dolib.a lib${PN}.a || die
+ doman ${PN}.1 || die
+ dobin ${PN} || die
+ dodoc README || die
+}