summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-09-05 09:17:49 +0000
committerMike Frysinger <vapier@gentoo.org>2013-09-05 09:17:49 +0000
commit1df122106184619adbdcfdc3d369fccc4796997e (patch)
tree385680ebff0891ffcb8f6ef9a594e3727fdbe8e6 /sys-devel
parentWhitespace (diff)
downloadgentoo-2-1df122106184619adbdcfdc3d369fccc4796997e.tar.gz
gentoo-2-1df122106184619adbdcfdc3d369fccc4796997e.tar.bz2
gentoo-2-1df122106184619adbdcfdc3d369fccc4796997e.zip
Add USE=llvm support #483026 by Daniel M. Weeks.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/sparse/ChangeLog6
-rw-r--r--sys-devel/sparse/metadata.xml8
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild7
3 files changed, 13 insertions, 8 deletions
diff --git a/sys-devel/sparse/ChangeLog b/sys-devel/sparse/ChangeLog
index e3362a37c6a4..b73843b483b1 100644
--- a/sys-devel/sparse/ChangeLog
+++ b/sys-devel/sparse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/sparse
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.54 2013/05/09 17:42:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.55 2013/09/05 09:17:49 vapier Exp $
+
+ 05 Sep 2013; Mike Frysinger <vapier@gentoo.org> metadata.xml,
+ sparse-9999.ebuild:
+ Add USE=llvm support #483026 by Daniel M. Weeks.
*sparse-0.4.4 (09 May 2013)
diff --git a/sys-devel/sparse/metadata.xml b/sys-devel/sparse/metadata.xml
index ca0df322a6dc..5d4128c7ae5b 100644
--- a/sys-devel/sparse/metadata.xml
+++ b/sys-devel/sparse/metadata.xml
@@ -4,13 +4,13 @@
<herd>kernel-misc</herd>
<herd>toolchain</herd>
<use>
- <flag name='xml'>
- Build the c2xml utility (requires <pkg>dev-libs/libxml2</pkg>).
- </flag>
-
<flag name='gtk'>
Build the test-inspect utility (requires
<pkg>x11-libs/gtk+</pkg> version 2)
</flag>
+ <flag name='llvm'>support llvm</flag>
+ <flag name='xml'>
+ Build the c2xml utility (requires <pkg>dev-libs/libxml2</pkg>).
+ </flag>
</use>
</pkgmetadata>
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index 5f8232877997..056f404f5f5b 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-9999.ebuild,v 1.12 2013/05/09 17:42:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-9999.ebuild,v 1.13 2013/09/05 09:17:49 vapier Exp $
EAPI="4"
@@ -23,9 +23,10 @@ fi
LICENSE="OSL-1.1"
SLOT="0"
-IUSE="gtk test xml"
+IUSE="gtk llvm test xml"
RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ llvm? ( >=sys-devel/llvm-3.0 )
xml? ( dev-libs/libxml2 )"
DEPEND="${RDEPEND}
gtk? ( virtual/pkgconfig )
@@ -39,7 +40,7 @@ src_prepare() {
-e '/^CFLAGS =/{s:=:+= $(CPPFLAGS):;s:-O2 -finline-functions::}' \
-e "s:pkg-config:${PKG_CONFIG}:" \
Makefile || die
- export MAKEOPTS+=" V=1 AR=${AR} CC=${CC} HAVE_GTK2=$(usex gtk) HAVE_LIBXML=$(usex xml)"
+ export MAKEOPTS+=" V=1 AR=${AR} CC=${CC} HAVE_GTK2=$(usex gtk) HAVE_LLVM=$(usex llvm) HAVE_LIBXML=$(usex xml)"
}
src_compile() {