summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-06-05 22:20:41 +0000
committerTravis Tilley <lv@gentoo.org>2004-06-05 22:20:41 +0000
commit1a1b83cb81a4e149cdc55369b1b49a04dc7a592f (patch)
treef6fba73de182c6e7686f6dc16f1f0dca296532c1 /sys-devel
parentInitial import, see bug #48952. (Manifest recommit) (diff)
downloadgentoo-2-1a1b83cb81a4e149cdc55369b1b49a04dc7a592f.tar.gz
gentoo-2-1a1b83cb81a4e149cdc55369b1b49a04dc7a592f.tar.bz2
gentoo-2-1a1b83cb81a4e149cdc55369b1b49a04dc7a592f.zip
added fix for compiling on reiser4 filesystems
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/files/3.4.0/reiser4-why-do-you-hate-me.patch22
-rw-r--r--sys-devel/gcc/gcc-3.4.0-r6.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index e3b80c181e04..158278910784 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.265 2004/06/04 23:19:52 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.266 2004/06/05 22:20:41 lv Exp $
+
+ 05 Jun 2004; Travis Tilley <lv@gentoo.org>
+ +files/3.4.0/reiser4-why-do-you-hate-me.patch, gcc-3.4.0-r6.ebuild:
+ added fix for compiling on reiser4 filesystems
04 Jun 2004; Travis Tilley <lv@gentoo.org>
+files/3.4.0/gcc-3.4.0-cc1-no-stack-protector.patch,
diff --git a/sys-devel/gcc/files/3.4.0/reiser4-why-do-you-hate-me.patch b/sys-devel/gcc/files/3.4.0/reiser4-why-do-you-hate-me.patch
new file mode 100644
index 000000000000..f43be66b1677
--- /dev/null
+++ b/sys-devel/gcc/files/3.4.0/reiser4-why-do-you-hate-me.patch
@@ -0,0 +1,22 @@
+--- gcc/cppfiles.c 2004/06/02 09:00:36 1.1
++++ gcc/cppfiles.c 2004/06/02 09:20:49
+@@ -329,8 +329,17 @@ find_file_in_dir (cpp_reader *pfile, _cp
+
+ if (file->err_no != ENOENT)
+ {
+- open_file_failed (pfile, file);
+- return true;
++ if (file->err_no == EACCES)
++ {
++ /* make EACCES non-fatal to fix bug ?? (glibc 2.3.3 on reiser4) */
++ cpp_errno (pfile, CPP_DL_WARNING, file->path);
++ return false;
++ }
++ else
++ {
++ open_file_failed (pfile, file);
++ return true;
++ }
+ }
+
+ free (path);
diff --git a/sys-devel/gcc/gcc-3.4.0-r6.ebuild b/sys-devel/gcc/gcc-3.4.0-r6.ebuild
index b02e92435a3b..b490aee16272 100644
--- a/sys-devel/gcc/gcc-3.4.0-r6.ebuild
+++ b/sys-devel/gcc/gcc-3.4.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0-r6.ebuild,v 1.8 2004/06/04 23:19:52 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0-r6.ebuild,v 1.9 2004/06/05 22:20:41 lv Exp $
IUSE="static nls bootstrap java build X multilib gcj f77 objc hardened uclibc n32 n64"
@@ -467,6 +467,7 @@ src_unpack() {
epatch ${FILESDIR}/3.4.0/gcc34-ppc64-m32-m64-multilib-only.patch
epatch ${FILESDIR}/3.4.0/gcc34-ia64-lib64.patch
epatch ${FILESDIR}/3.4.0/gcc34-multi32-hack.patch
+ epatch ${FILESDIR}/3.4.0/reiser4-why-do-you-hate-me.patch
# Misdesign in libstdc++ (Redhat)
cp -a ${S}/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h