summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-06-07 13:18:11 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-06-07 13:18:11 +0000
commit972885453a364298694bd33ebad9ac44f92caa2b (patch)
tree95034b399b902ad0cab89476bc44e9571f651aa6 /sys-devel/make/make-3.82-r1.ebuild
parentMake triangle configure optional. Thanks to Donnie for spotting. (diff)
downloadgentoo-2-972885453a364298694bd33ebad9ac44f92caa2b.tar.gz
gentoo-2-972885453a364298694bd33ebad9ac44f92caa2b.tar.bz2
gentoo-2-972885453a364298694bd33ebad9ac44f92caa2b.zip
Revision bump. Patch from upstream fixes memory corruption for Android/Cyanogenmod builds; Savannah bug report #33125. As reported by blackd in bug #355907; patch scavenged by Mike "SpanKY" Frysinger, additional research by Peter "loki_val" Alfredsen & Samuli Suominen.
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/make/make-3.82-r1.ebuild')
-rw-r--r--sys-devel/make/make-3.82-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-devel/make/make-3.82-r1.ebuild b/sys-devel/make/make-3.82-r1.ebuild
new file mode 100644
index 000000000000..938c25b58c89
--- /dev/null
+++ b/sys-devel/make/make-3.82-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-3.82-r1.ebuild,v 1.1 2011/06/07 13:18:10 chainsaw Exp $
+
+EAPI="2"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Standard tool to compile source trees"
+HOMEPAGE="http://www.gnu.org/software/make/make.html"
+SRC_URI="mirror://gnu//make/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls static"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-archives-many-objs.patch #334889
+ epatch "${FILESDIR}"/${P}-MAKEFLAGS-reexec.patch #31975
+ epatch "${FILESDIR}"/${P}-memory-corruption.patch #355907
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ --program-prefix=g \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README*
+ if [[ ${USERLAND} == "GNU" ]] ; then
+ # we install everywhere as 'gmake' but on GNU systems,
+ # symlink 'make' to 'gmake'
+ dosym gmake /usr/bin/make
+ dosym gmake.1 /usr/share/man/man1/make.1
+ fi
+}