summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-12-07 07:40:05 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-12-07 07:40:05 +0000
commit9dbfd301a3d47b85dbd0c5bb6c3904dd3d821721 (patch)
tree8c42630237cfddbf0c0ffc05992d180436c15c50 /sys-devel/dev86
parentVersion bump and cleanup. (diff)
downloadgentoo-2-9dbfd301a3d47b85dbd0c5bb6c3904dd3d821721.tar.gz
gentoo-2-9dbfd301a3d47b85dbd0c5bb6c3904dd3d821721.tar.bz2
gentoo-2-9dbfd301a3d47b85dbd0c5bb6c3904dd3d821721.zip
Version bump.
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/dev86')
-rw-r--r--sys-devel/dev86/ChangeLog7
-rw-r--r--sys-devel/dev86/dev86-0.16.18.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sys-devel/dev86/ChangeLog b/sys-devel/dev86/ChangeLog
index 11d18ab7f17e..585a55cadd98 100644
--- a/sys-devel/dev86/ChangeLog
+++ b/sys-devel/dev86/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/dev86
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/ChangeLog,v 1.18 2010/11/15 06:19:51 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/ChangeLog,v 1.19 2010/12/07 07:40:05 polynomial-c Exp $
+
+*dev86-0.16.18 (07 Dec 2010)
+
+ 07 Dec 2010; Lars Wendler <polynomial-c@gentoo.org> +dev86-0.16.18.ebuild:
+ Version bump.
15 Nov 2010; Lars Wendler <polynomial-c@gentoo.org>
dev86-0.16.17-r6.ebuild:
diff --git a/sys-devel/dev86/dev86-0.16.18.ebuild b/sys-devel/dev86/dev86-0.16.18.ebuild
new file mode 100644
index 000000000000..eecc1300b561
--- /dev/null
+++ b/sys-devel/dev86/dev86-0.16.18.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/dev86-0.16.18.ebuild,v 1.1 2010/12/07 07:40:05 polynomial-c Exp $
+
+inherit eutils
+
+DESCRIPTION="Bruce's C compiler - Simple C compiler to generate 8086 code"
+HOMEPAGE="http://www.debath.co.uk/"
+SRC_URI="http://www.debath.co.uk/dev86/Dev86src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-devel/bin86"
+DEPEND="${RDEPEND}
+ dev-util/gperf"
+
+src_unpack() {
+ unpack ${A}
+ # elksemu doesn't compile under amd64
+ if use amd64; then
+ einfo "Not compiling elksemu on amd64"
+ sed -i.orig \
+ -e 's,alt-libs elksemu,alt-libs,' \
+ -e 's,install-lib install-emu,install-lib,' \
+ "${S}"/makefile.in
+ fi
+ cd "${S}"
+ epatch "${FILESDIR}"/dev86-pic.patch
+ epatch "${FILESDIR}"/${PN}-0.16.17-fortify.patch
+ sed -i \
+ -e "s:-O2 -g:${CFLAGS}:" \
+ -e '/INEXE=/s:-s::' \
+ makefile.in
+ sed -i -e '/INSTALL_OPTS=/s:-s::' bin86/Makefile
+ sed -i -e '/install -m 755 -s/s:-s::' dis88/Makefile
+}
+
+src_compile() {
+ # Don't mess with CPPFLAGS as they tend to break compilation
+ # (bug #343655).
+ CPPFLAGS=""
+
+ emake -j1 DIST="${D}" || die
+
+ export PATH=${S}/bin:${PATH}
+ cd bin
+ ln -s ncc bcc
+ cd ..
+ cd bootblocks
+ ln -s ../bcc/version.h .
+ emake DIST="${D}" || die
+}
+
+src_install() {
+ emake -j1 install-all DIST="${D}" || die
+ dobin bootblocks/makeboot || die
+ # remove all the stuff supplied by bin86
+ cd "${D}"
+ rm usr/bin/{as,ld,nm,objdump,size}86 || die
+ rm usr/man/man1/{as,ld}86.1 || die
+ dodir /usr/share/man
+ mv usr/man usr/share/ || die
+}