summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-11-14 15:02:31 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-11-14 15:02:31 +0000
commita13cb9ed780233412cccfd4d87102085878ae57d (patch)
tree2aaf7b3d5d9ed5bc9eb412fd3db2e6989dce9714 /sys-devel/clang
parentUpdated dep to require spice-protocol >=0.10.0 (unfortunately spice and spice... (diff)
downloadgentoo-2-a13cb9ed780233412cccfd4d87102085878ae57d.tar.gz
gentoo-2-a13cb9ed780233412cccfd4d87102085878ae57d.tar.bz2
gentoo-2-a13cb9ed780233412cccfd4d87102085878ae57d.zip
gcc-config 1.5 dropped the -X option, thanks Leonid Volnitsky <leonid@volnitsky.com> in bug #388621
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/ChangeLog7
-rw-r--r--sys-devel/clang/clang-2.8-r3.ebuild4
-rw-r--r--sys-devel/clang/clang-2.9-r1.ebuild4
-rw-r--r--sys-devel/clang/clang-3.0_rc3.ebuild4
-rw-r--r--sys-devel/clang/clang-9999.ebuild4
5 files changed, 14 insertions, 9 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index 15b30749bfbe..94ca6a13781c 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.46 2011/11/10 14:01:41 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.47 2011/11/14 15:02:31 voyageur Exp $
+
+ 14 Nov 2011; Bernard Cafarelli <voyageur@gentoo.org> clang-2.8-r3.ebuild,
+ clang-2.9-r1.ebuild, clang-3.0_rc3.ebuild, clang-9999.ebuild:
+ gcc-config 1.5 dropped the -X option, thanks Leonid Volnitsky
+ <leonid@volnitsky.com> in bug #388621
10 Nov 2011; Bernard Cafarelli <voyageur@gentoo.org> clang-3.0_rc3.ebuild:
Fix tests (needs full compilation of llvm, remove broken test)
diff --git a/sys-devel/clang/clang-2.8-r3.ebuild b/sys-devel/clang/clang-2.8-r3.ebuild
index d624806ed157..62e21b48842f 100644
--- a/sys-devel/clang/clang-2.8-r3.ebuild
+++ b/sys-devel/clang/clang-2.8-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.8-r3.ebuild,v 1.6 2011/10/04 11:52:07 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.8-r3.ebuild,v 1.7 2011/11/14 15:02:31 voyageur Exp $
EAPI=3
@@ -109,7 +109,7 @@ src_configure() {
if use system-cxx-headers; then
# Try to get current gcc headers path
- local CXX_PATH=$(gcc-config -X| cut -d: -f1 | sed 's,/include/g++-v4$,,')
+ local CXX_PATH=$(gcc-config -L| cut -d: -f1)
CONF_FLAGS="${CONF_FLAGS} --with-c-include-dirs=/usr/include:${CXX_PATH}/include"
CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-root=${CXX_PATH}/include/g++-v4"
CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-arch=$CHOST"
diff --git a/sys-devel/clang/clang-2.9-r1.ebuild b/sys-devel/clang/clang-2.9-r1.ebuild
index 20f097524d11..268435edbc72 100644
--- a/sys-devel/clang/clang-2.9-r1.ebuild
+++ b/sys-devel/clang/clang-2.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.9-r1.ebuild,v 1.3 2011/10/04 11:52:07 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.9-r1.ebuild,v 1.4 2011/11/14 15:02:31 voyageur Exp $
EAPI=3
@@ -98,7 +98,7 @@ src_configure() {
if use system-cxx-headers; then
# Try to get current gcc headers path
- local CXX_PATH=$(gcc-config -X| cut -d: -f1 | sed 's,/include/g++-v4$,,')
+ local CXX_PATH=$(gcc-config -L| cut -d: -f1)
CONF_FLAGS="${CONF_FLAGS} --with-c-include-dirs=/usr/include:${CXX_PATH}/include"
CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-root=${CXX_PATH}/include/g++-v4"
CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-arch=$CHOST"
diff --git a/sys-devel/clang/clang-3.0_rc3.ebuild b/sys-devel/clang/clang-3.0_rc3.ebuild
index d98bb9a42c23..4e1be4e36b1f 100644
--- a/sys-devel/clang/clang-3.0_rc3.ebuild
+++ b/sys-devel/clang/clang-3.0_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.0_rc3.ebuild,v 1.2 2011/11/10 14:01:41 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.0_rc3.ebuild,v 1.3 2011/11/14 15:02:31 voyageur Exp $
EAPI=3
@@ -86,7 +86,7 @@ src_configure() {
if use system-cxx-headers; then
# Try to get current gcc headers path
- local CXX_PATH=$(gcc-config -X| cut -d: -f1 | sed 's,/include/g++-v4$,,')
+ local CXX_PATH=$(gcc-config -L| cut -d: -f1)
CONF_FLAGS="${CONF_FLAGS} --with-c-include-dirs=/usr/include:${CXX_PATH}/include"
CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-root=${CXX_PATH}/include/g++-v4"
CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-arch=$CHOST"
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 54834c843b83..b5fc4a8aaddd 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.19 2011/11/09 22:55:22 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.20 2011/11/14 15:02:31 voyageur Exp $
EAPI=3
@@ -88,7 +88,7 @@ src_configure() {
if use system-cxx-headers; then
# Try to get current gcc headers path
- local CXX_PATH=$(gcc-config -X| cut -d: -f1 | sed 's,/include/g++-v4$,,')
+ local CXX_PATH=$(gcc-config -L| cut -d: -f1)
CONF_FLAGS="${CONF_FLAGS} --with-c-include-dirs=/usr/include:${CXX_PATH}/include"
CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-root=${CXX_PATH}/include/g++-v4"
CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-arch=$CHOST"