summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-05-19 20:58:55 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-05-19 20:58:55 +0000
commit78b97f6bdcef666de80747d2f7d6a2bbfbec9d9a (patch)
tree09ee0c37a1309069473907f15c214c63b810d7b6 /sys-devel/automake
parentAdded eawpatches for Timidity++ (diff)
downloadgentoo-2-78b97f6bdcef666de80747d2f7d6a2bbfbec9d9a.tar.gz
gentoo-2-78b97f6bdcef666de80747d2f7d6a2bbfbec9d9a.tar.bz2
gentoo-2-78b97f6bdcef666de80747d2f7d6a2bbfbec9d9a.zip
new version and fixes
Diffstat (limited to 'sys-devel/automake')
-rw-r--r--sys-devel/automake/ChangeLog14
-rw-r--r--sys-devel/automake/automake-1.6.1-r1.ebuild235
-rw-r--r--sys-devel/automake/files/automake-1.5-target_hook.patch36
-rw-r--r--sys-devel/automake/files/digest-automake-1.6.1-r13
4 files changed, 287 insertions, 1 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index ec85d54b9ed4..e1c5f642ce5a 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for sys-devel/automake
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.6 2002/05/19 17:46:30 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.7 2002/05/19 20:58:55 azarah Exp $
+
+automake-1.6.1-r1 (19 May 2002)
+
+ 19 May 2002; M.Schlemmer <azarah@gentoo.org> automake-1.6.1-r1.ebuild :
+
+ Use automake-1.5 instead of automake-1.5d to try and fix KDE.
+
+ Another big change, is that we now have all the macros (.m4 files) for
+ each version of automake in their own private dirs, but then add
+ /usr/share/aclocal/ to each version's aclocal's include path. This
+ makes it possible for each version to use custom macros added by
+ other programs to /usr/share/aclocal/.
automake-1.6.1 (19 May 2002)
diff --git a/sys-devel/automake/automake-1.6.1-r1.ebuild b/sys-devel/automake/automake-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..3b2cbe2d7995
--- /dev/null
+++ b/sys-devel/automake/automake-1.6.1-r1.ebuild
@@ -0,0 +1,235 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/sys-devel/automake/automake-1.6.1.ebuild,v 1.4 2002/04/23 19:42:16 azarah Exp
+
+# OLD14 = 1.4
+# OLD15 = 1.5
+# NEW = 1.6 (.1)
+
+# NOTE: For all of those brave souls out there that wants to fix
+# or update this, note that all three versions install
+# .m4 files to /usr/share/aclocal-${ver}/ and am files
+# to /usr/share/automake-${ver}/. We then add the default
+# /usr/share/aclocal/ to aclocal's search path by adding
+# "push (@dirlist, \"/usr/share/aclocal\");" after @dirlist
+# is defined the first time (done in fix_bins() function).
+#
+# The theory thus is, all version specific data goes into
+# version specific directories, but programs like ogg/whatever
+# can still install thier .m4 macros into /usr/share/aclocal/.
+#
+# Martin Schlemmer <azarah@gentoo.org>
+# 19 May 2002
+
+
+# Currently this is 1.6, but it could change to 1.6.x as it
+# does with 1.5d ... to determine this, install latest version
+# of 1.6, and look at the generated files in the bin dir ..
+# it should be something like (for 1.6.1):
+#
+# nosferatu automake-1.6.1 # ls /myinstallroot/bin/
+# aclocal aclocal-1.6 automake automake-1.6
+# nosferatu automake-1.6.1 #
+#
+# You should then set NEW_PV to 1.6, as this is the suffix
+NEW_PV=1.6
+
+OLD15_PV=1.5
+OLD15_P=${PN}-${OLD15_PV}
+OLD14_PV=1.4-p5
+OLD14_P=${PN}-${OLD14_PV}
+S=${WORKDIR}/${P}
+OLD15_S=${WORKDIR}/${OLD15_P}
+OLD14_S=${WORKDIR}/${OLD14_P}
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD15_P}.tar.gz
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD14_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/automake/automake.html"
+
+DEPEND="sys-devel/perl
+ >=sys-devel/autoconf-2.53-r1"
+
+SLOT="1.5"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${OLD15_S}
+ patch -p1 <${FILESDIR}/${PN}-${OLD15_PV}-target_hook.patch || die
+}
+
+src_compile() {
+
+ #
+ # ************ automake-1.6x ************
+ #
+
+ # stupid configure script goes and run autoconf in a subdir,
+ # so 'ac-wrapper.pl' do not detect that it should use
+ # autoconf-2.5x
+ export WANT_AUTOCONF_2_5=1
+
+ cd ${S}
+
+ cp automake.texi automake.texi.orig
+ sed -e "s:setfilename automake.info:setfilename automake-1.6.info:" \
+ automake.texi.orig >automake.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake ${MAKEOPTS} || die
+
+ #
+ # ************ automake-1.5x ************
+ #
+
+ cd ${OLD15_S}
+
+ cp automake.texi automake.texi.orig
+ sed -e "s:setfilename automake.info:setfilename automake-1.5.info:" \
+ automake.texi.orig >automake.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake ${MAKEOPTS} || die
+ unset WANT_AUTOCONF_2_5
+
+ #
+ # ************ automake-1.4-p5 ************
+ #
+ cd ${OLD14_S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake ${MAKEOPTS} || die
+}
+
+# This basically fix aclocal and automake so that they
+# use the correct directories, and also adds the normal
+# /usr/share/aclocal for aclocal to include.
+fix_bins() {
+
+ for x in aclocal automake
+ do
+ cp ${x} ${x}.orig
+ sed -e "s:share/automake\":share/automake-${1}\":g" \
+ -e "s:share/aclocal\":share/aclocal-${1}\":g" \
+ ${x}.orig >${x}
+ done
+
+ # add "/usr/share/aclocal" to m4 search patch
+ cp aclocal aclocal.orig
+ sed -e '/&scan_m4_files (@dirlist);/i \push (@dirlist, \"/usr/share/aclocal\");' \
+ aclocal.orig >aclocal
+ # same as above, but 1.4 looks a bit differently
+ cp aclocal aclocal.orig
+ sed -e '/&scan_m4_files ($acdir, @dirlist);/i \push (@dirlist, \"/usr/share/aclocal\");' \
+ aclocal.orig >aclocal
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ newexe ${FILESDIR}/am-wrapper.pl-1.6 am-wrapper.pl
+ # Name binaries to exact version, as they have limited support for
+ # more than one version installs
+ dosed "s:1\.6x:${NEW_PV}:g" /usr/lib/${PN}/am-wrapper.pl
+ dosed "s:1\.5x:${OLD15_PV}:g" /usr/lib/${PN}/am-wrapper.pl
+
+ #
+ # ************ automake-1.6x ************
+ #
+
+ cd ${S}
+ fix_bins ${NEW_PV}
+
+ make DESTDIR=${D} \
+ install || die
+
+ for x in automake aclocal
+ do
+# mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${NEW_PV}
+ rm -f ${D}/usr/bin/${x}
+ done
+
+ doinfo automake-1.6.info*
+
+ docinto ${PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ automake-1.5x ************
+ #
+
+ cd ${OLD15_S}
+ fix_bins ${OLD15_PV}
+
+ make DESTDIR=${D} \
+ pkgdatadir=/usr/share/automake-${OLD15_PV} \
+ m4datadir=/usr/share/aclocal-${OLD15_PV} \
+ install || die
+
+ for x in automake aclocal
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD15_PV}
+ rm -f ${D}/usr/bin/${x}
+ done
+
+ doinfo automake-1.5.info*
+
+ docinto ${OLD15_PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ automake-1.4-p5 ************
+ #
+
+ cd ${OLD14_S}
+ fix_bins "1.4"
+
+ make DESTDIR=${D} \
+ pkgdatadir=/usr/share/automake-1.4 \
+ m4datadir=/usr/share/aclocal-1.4 \
+ install || die
+
+ for x in automake aclocal
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-1.4
+ dosym ../lib/${PN}/am-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD14_PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ # This is the default macro directory that apps use ..
+ dodir /usr/share/aclocal
+ touch ${D}/usr/share/aclocal/.keep
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in automake aclocal
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+
diff --git a/sys-devel/automake/files/automake-1.5-target_hook.patch b/sys-devel/automake/files/automake-1.5-target_hook.patch
new file mode 100644
index 000000000000..6f40cbb67d39
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.5-target_hook.patch
@@ -0,0 +1,36 @@
+diff -C 2 -r -N /tmp/automake-1.5/automake.in automake-1.5/automake.in
+*** /tmp/automake-1.5/automake.in Thu Aug 23 07:26:53 2001
+--- automake-1.5/automake.in Tue Feb 5 20:38:55 2002
+***************
+*** 1941,1945 ****
+
+ # Let the language do some special magic if required.
+! $lang->target_hook ($aggregate, $object, $full);
+
+ if ($derived_source)
+--- 1941,1947 ----
+
+ # Let the language do some special magic if required.
+! if (defined $lang) {
+! $lang->target_hook ($aggregate, $object, $full);
+! }
+
+ if ($derived_source)
+diff -C 2 -r -N /tmp/automake-1.5/m4/depout.m4 automake-1.5/m4/depout.m4
+*** /tmp/automake-1.5/m4/depout.m4 Mon May 14 02:01:09 2001
+--- automake-1.5/m4/depout.m4 Wed Jan 30 22:03:33 2002
+***************
+*** 13,18 ****
+ for mf in $CONFIG_FILES; do
+ case "$mf" in
+! Makefile) dirpart=.;;
+! */Makefile) dirpart=`echo "$mf" | sed -e 's|/[^/]*$||'`;;
+ *) continue;;
+ esac
+--- 13,18 ----
+ for mf in $CONFIG_FILES; do
+ case "$mf" in
+! Makefile|GNUmakefile) dirpart=.;;
+! */Makefile|*/GNUmakefile) dirpart=`echo "$mf" | sed -e 's|/[^/]*$||'`;;
+ *) continue;;
+ esac
diff --git a/sys-devel/automake/files/digest-automake-1.6.1-r1 b/sys-devel/automake/files/digest-automake-1.6.1-r1
new file mode 100644
index 000000000000..12868257e467
--- /dev/null
+++ b/sys-devel/automake/files/digest-automake-1.6.1-r1
@@ -0,0 +1,3 @@
+MD5 8729428639b5baa74a5a708776727ff5 automake-1.6.1.tar.gz 595788
+MD5 74a22ac0581378e807ecb334a55c5bab automake-1.5.tar.gz 526934
+MD5 e10679bba411f8602eed004012d915e3 automake-1.4-p5.tar.gz 376992