summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-21 01:06:27 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-21 01:06:27 +0000
commitec5596d9f8874ad601fac6e7e2fa9adcfef15449 (patch)
tree5336d4bee06d890219a389d8d84c8540c5137bb0 /sys-devel/autoconf/autoconf-2.13.ebuild
parentinitial import (diff)
downloadgentoo-2-ec5596d9f8874ad601fac6e7e2fa9adcfef15449.tar.gz
gentoo-2-ec5596d9f8874ad601fac6e7e2fa9adcfef15449.tar.bz2
gentoo-2-ec5596d9f8874ad601fac6e7e2fa9adcfef15449.zip
SLOT-ed versions of autoconf
Diffstat (limited to 'sys-devel/autoconf/autoconf-2.13.ebuild')
-rw-r--r--sys-devel/autoconf/autoconf-2.13.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sys-devel/autoconf/autoconf-2.13.ebuild b/sys-devel/autoconf/autoconf-2.13.ebuild
new file mode 100644
index 000000000000..373d0505510f
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.13.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.13.ebuild,v 1.1 2004/10/21 01:06:27 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="${PV:0:3}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/texinfo-4.3
+ sys-devel/autoconf-wrapper
+ =sys-devel/m4-1.4*
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+ epatch ${FILESDIR}/${P}-destdir.patch
+ touch configure # make sure configure is newer than configure.in
+
+ rm -f standards.{texi,info} # binutils installs this infopage
+
+ sed -i \
+ -e 's|\* Autoconf:|\* Autoconf v2.1:|' \
+ -e '/START-INFO-DIR-ENTRY/ i INFO-DIR-SECTION GNU programming tools' \
+ autoconf.texi \
+ || die "sed failed"
+}
+
+src_compile() {
+ # need to include --exec-prefix and --bindir or our
+ # DESTDIR patch will trigger sandbox hate :(
+ econf \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --program-suffix="-${PV}" \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ dodoc AUTHORS NEWS README TODO \
+ ChangeLog ChangeLog.0 ChangeLog.1
+
+ mv "${D}"/usr/share/info/autoconf{,-${PV}}.info
+}
+
+pkg_postinst() {
+ einfo "Please note that the 'WANT_AUTOCONF_2_1=1' syntax is now:"
+ einfo " WANT_AUTOCONF=2.1"
+}