summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2012-02-03 21:55:52 +0000
committerJustin Bronder <jsbronder@gentoo.org>2012-02-03 21:55:52 +0000
commitfadabb5fbc363a559b87481ee6d318a58236df77 (patch)
tree7ed3c62313509e862991e0482fdffccf4ab27ccf /sys-cluster
parentMarking lineak-xosdplugin-0.9.0-r1 ppc for bug 397271 (diff)
downloadgentoo-2-fadabb5fbc363a559b87481ee6d318a58236df77.tar.gz
gentoo-2-fadabb5fbc363a559b87481ee6d318a58236df77.tar.bz2
gentoo-2-fadabb5fbc363a559b87481ee6d318a58236df77.zip
cleanup
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog8
-rw-r--r--sys-cluster/openmpi/openmpi-1.5.4-r3.ebuild (renamed from sys-cluster/openmpi/openmpi-1.5.4-r2.ebuild)45
2 files changed, 30 insertions, 23 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index e7d66e5e3c69..fd2b9cc9dd13 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.97 2012/02/03 20:44:18 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.98 2012/02/03 21:55:52 jsbronder Exp $
+
+*openmpi-1.5.4-r3 (03 Feb 2012)
+
+ 03 Feb 2012; Justin Bronder <jsbronder@gentoo.org> -openmpi-1.5.4-r2.ebuild,
+ +openmpi-1.5.4-r3.ebuild:
+ cleanup
*openmpi-1.4.4 (03 Feb 2012)
diff --git a/sys-cluster/openmpi/openmpi-1.5.4-r2.ebuild b/sys-cluster/openmpi/openmpi-1.5.4-r3.ebuild
index 624de8b2b87f..3c0df1af4dc3 100644
--- a/sys-cluster/openmpi/openmpi-1.5.4-r2.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.5.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.4-r2.ebuild,v 1.1 2012/01/20 13:15:19 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.4-r3.ebuild,v 1.1 2012/02/03 21:55:52 jsbronder Exp $
EAPI=4
inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
@@ -10,34 +10,31 @@ S=${WORKDIR}/${MY_P}
DESCRIPTION="A high-performance message passing library (MPI)"
HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.5/downloads/${MY_P}.tar.bz2"
+SRC_URI="http://www.open-mpi.org/software/ompi/v${P%.*}/downloads/${MY_P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
IUSE="+cxx elibc_FreeBSD fortran heterogeneous infiniband ipv6 knem mpi-threads
- +numa pbs open-mx psm romio sctp slurm threads vt"
+ +numa open-mx pbs psm romio sctp slurm threads vt"
-REQUIRED_USE="^^ (
- ( !slurm !pbs )
- ( slurm !pbs )
- ( !slurm pbs )
- )
- psm? ( infiniband )"
+REQUIRED_USE="slurm? ( !pbs )
+ pbs? ( !slurm )
+ psm? ( infiniband )"
RDEPEND="
+ elibc_FreeBSD? ( dev-libs/libexecinfo )
fortran? ( virtual/fortran )
- pbs? ( sys-cluster/torque )
infiniband? ( sys-infiniband/openib )
+ knem? ( sys-cluster/knem )
+ numa? ( sys-process/numactl )
+ open-mx? ( sys-cluster/open-mx )
+ pbs? ( sys-cluster/torque )
+ psm? ( sys-infiniband/infinipath-psm )
sctp? ( net-misc/lksctp-tools )
vt? (
!dev-libs/libotf
!app-text/lcdf-typetools
)
- elibc_FreeBSD? ( dev-libs/libexecinfo )
- knem? ( sys-cluster/knem )
- numa? ( sys-process/numactl )
- open-mx? ( sys-cluster/open-mx )
- psm? ( sys-infiniband/infinipath-psm )
>=sys-apps/hwloc-1.3
!sys-cluster/mpich
!sys-cluster/lam-mpi
@@ -82,8 +79,7 @@ src_configure() {
)
if use mpi-threads; then
- myconf+=(
- --enable-mpi-thread-multiple
+ myconf+=(--enable-mpi-thread-multiple
--enable-opal-multi-threads
)
fi
@@ -93,10 +89,10 @@ src_configure() {
myconf+=(--disable-mpi-f90)
elif [[ $(tc-getFC) =~ if ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
- myconf+=( --with-mpi-f90-size=medium )
+ myconf+=(--with-mpi-f90-size=medium)
fi
else
- myconf+=( --disable-mpi-f90 --disable-mpi-f77 )
+ myconf+=(--disable-mpi-f90 --disable-mpi-f77)
fi
! use vt && myconf+=(--enable-contrib-no-build=vt)
@@ -111,10 +107,15 @@ src_configure() {
$(use_enable cxx mpi-cxx) \
$(use_enable romio io-romio) \
$(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_with slurm) \
$(use_enable ipv6) \
- $(use_with sctp sctp)
+ $(use_with infiniband openib "${EPREFIX}"/usr) \
+ $(use_with knem knem "${EPREFIX}"/usr) \
+ $(use_with numa libnuma "${EPREFIX}"/usr) \
+ $(use_with open-mx mx "${EPREFIX}"/usr) \
+ $(use_with pbs tm) \
+ $(use_with psm psm "${EPREFIX}"/usr) \
+ $(use_with sctp sctp) \
+ $(use_with slurm)
}
src_install () {