summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-05 19:59:15 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-05 19:59:15 +0000
commitdc4b6b729f604457356090bb2908b7c3ed7165da (patch)
treed51a565e2a9f1b5a1c1d482a2d54d3e9bf87340f /sys-cluster
parentStable on hppa (diff)
downloadgentoo-2-dc4b6b729f604457356090bb2908b7c3ed7165da.tar.gz
gentoo-2-dc4b6b729f604457356090bb2908b7c3ed7165da.tar.bz2
gentoo-2-dc4b6b729f604457356090bb2908b7c3ed7165da.zip
Revision bump for new virtual/pbs and shared init scripts.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openpbs/ChangeLog10
-rw-r--r--sys-cluster/openpbs/files/digest-openpbs-2.3.16-r21
-rw-r--r--sys-cluster/openpbs/openpbs-2.3.16-r2.ebuild81
3 files changed, 90 insertions, 2 deletions
diff --git a/sys-cluster/openpbs/ChangeLog b/sys-cluster/openpbs/ChangeLog
index 73c251b97931..6b5071311365 100644
--- a/sys-cluster/openpbs/ChangeLog
+++ b/sys-cluster/openpbs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/openpbs
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openpbs/ChangeLog,v 1.18 2004/11/24 22:23:57 tantive Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openpbs/ChangeLog,v 1.19 2005/07/05 19:59:15 robbat2 Exp $
+
+*openpbs-2.3.16-r2 (05 Jul 2005)
+
+ 05 Jul 2005; Robin H. Johnson <robbat2@gentoo.org>
+ +openpbs-2.3.16-r2.ebuild:
+ Revision bump for new virtual/pbs and shared init scripts.
24 Nov 2004; Michael Imhof <tantive@gentoo.org> -openpbs-2.3.16.ebuild:
Cleaned out old version.
diff --git a/sys-cluster/openpbs/files/digest-openpbs-2.3.16-r2 b/sys-cluster/openpbs/files/digest-openpbs-2.3.16-r2
new file mode 100644
index 000000000000..2918ceafa227
--- /dev/null
+++ b/sys-cluster/openpbs/files/digest-openpbs-2.3.16-r2
@@ -0,0 +1 @@
+MD5 42be627d513839a2daf258692b0092aa OpenPBS_2_3_16.tar.gz 1307483
diff --git a/sys-cluster/openpbs/openpbs-2.3.16-r2.ebuild b/sys-cluster/openpbs/openpbs-2.3.16-r2.ebuild
new file mode 100644
index 000000000000..a5537f65b345
--- /dev/null
+++ b/sys-cluster/openpbs/openpbs-2.3.16-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openpbs/openpbs-2.3.16-r2.ebuild,v 1.1 2005/07/05 19:59:15 robbat2 Exp $
+
+inherit eutils
+
+NAME="${P/openpbs-/OpenPBS_}"
+NAME="${NAME//./_}"
+DESCRIPTION="The Portable Batch System (PBS) is a flexible batch queuing and workload management system"
+HOMEPAGE="http://www.openpbs.org/"
+SRC_URI="${NAME}.tar.gz"
+
+LICENSE="openpbs"
+PROVIDE="virtual/pbs"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="X tcltk crypt doc"
+RESTRICT="fetch"
+
+DEPEND="virtual/libc
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl )
+ !virtual/pbs"
+RDEPEND="${DEPEND}
+ crypt? ( net-misc/openssh )"
+PDEPEND="sys-cluster/openpbs-common"
+
+S="${WORKDIR}/${NAME}"
+
+pkg_nofetch() {
+ einfo "Please visit http://www.openpbs.org/."
+ einfo "You must register to download the archive."
+ einfo "Place ${A} in ${DISTDIR}."
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # apply a patch I made for gcc3.
+ # maybe this should be done with sed but I'm too lazy
+ epatch ${FILESDIR}/makedepend-sh-gcc3.patch
+ epatch ${FILESDIR}/${PF}-errno-fixup.patch
+ # this thing doesn't use make install, but rather it's own install script
+ # fix it here so the install dirs are set to the ${D} directory
+ cd buildutils
+ mv pbs_mkdirs.in pbs_mkdirs.in-orig
+ sed -e "s|prefix=@prefix@|prefix=\${D}@prefix@| ; \
+ s|PBS_SERVER_HOME=@PBS_SERVER_HOME@|PBS_SERVER_HOME=\${D}@PBS_SERVER_HOME@| ; \
+ s|PBS_DEFAULT_FILE=@PBS_DEFAULT_FILE@|PBS_DEFAULT_FILE=\${D}@PBS_DEFAULT_FILE@| ; \
+ s|PBS_ENVIRON=@PBS_ENVIRON@|PBS_ENVIRON=\${D}@PBS_ENVIRON@|" \
+ pbs_mkdirs.in-orig > pbs_mkdirs.in
+}
+
+src_compile() {
+ local myconf
+ use X || myconf="--disable-gui"
+ use tcltk && myconf="${myconf} --with-tcl"
+
+ use crypt && myconf="${myconf} --with-scp"
+ use doc && myconf="${myconf} --enable-docs"
+
+ ./configure ${myconf} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-server \
+ --enable-clients \
+ --set-server-home=/var/spool/PBS \
+ --set-environ=/etc/pbs_environment \
+ --enable-mom || die "./configure failed"
+
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ PBS_SERVER_HOME=${D}/var/spool/PBS \
+ install || die
+
+ dodoc INSTALL PBS_License.text Read.Me Release_Notes
+}