summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-03-05 10:29:28 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-03-05 10:29:28 +0000
commit8e364cfa34575c4fa2d0661aa7cb2f7d0827406c (patch)
treeb260fe5d2acb97bf635ebab84e404af1d179b191 /sys-cluster
parentCorrectly work with hamster applett (diff)
downloadgentoo-2-8e364cfa34575c4fa2d0661aa7cb2f7d0827406c.tar.gz
gentoo-2-8e364cfa34575c4fa2d0661aa7cb2f7d0827406c.tar.bz2
gentoo-2-8e364cfa34575c4fa2d0661aa7cb2f7d0827406c.zip
Version bump wrt #357493
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/maui/ChangeLog9
-rw-r--r--sys-cluster/maui/maui-3.3.1.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/sys-cluster/maui/ChangeLog b/sys-cluster/maui/ChangeLog
index d99eaebf0110..5db119aea3da 100644
--- a/sys-cluster/maui/ChangeLog
+++ b/sys-cluster/maui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/maui
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.16 2010/07/15 07:06:30 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.17 2011/03/05 10:29:28 xarthisius Exp $
+
+*maui-3.3.1 (05 Mar 2011)
+
+ 05 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> +maui-3.3.1.ebuild:
+ Version bump wrt #357493
*maui-3.3 (14 Jul 2010)
diff --git a/sys-cluster/maui/maui-3.3.1.ebuild b/sys-cluster/maui/maui-3.3.1.ebuild
new file mode 100644
index 000000000000..947b0f5ff6bf
--- /dev/null
+++ b/sys-cluster/maui/maui-3.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/maui-3.3.1.ebuild,v 1.1 2011/03/05 10:29:28 xarthisius Exp $
+
+EAPI="3"
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Maui Cluster Scheduler"
+HOMEPAGE="http://www.clusterresources.com/products/maui/"
+SRC_URI="http://www.adaptivecomputing.com/download/maui/${P}.tar.gz"
+
+IUSE=""
+SLOT="0"
+LICENSE="maui"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+DEPEND="sys-cluster/torque"
+RDEPEND="${DEPEND}"
+
+RESTRICT="fetch mirror"
+
+src_prepare() {
+ epatch "${FILESDIR}"/3.2.6_p21-autoconf-2.60-compat.patch
+ sed -e "s:\$(INST_DIR)/lib:\$(INST_DIR)/$(get_libdir):" \
+ -i src/{moab,server,mcom}/Makefile || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-spooldir="${EPREFIX}"/usr/spool/maui \
+ --with-pbs="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake install BUILDROOT="${D}" INST_DIR="${ED}/usr" || die
+ dodoc docs/README CHANGELOG || die
+ dohtml docs/mauidocs.html || die
+}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}, obtain the file"
+ einfo "${P}.tar.gz and put it in ${DISTDIR}"
+}