summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-06 00:03:02 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-06 00:03:02 +0000
commit7adc9cbccc7a348190f9c2ff7cb1cc38ae7b4f1c (patch)
tree7e2adbf88f409bc50a284596be78b5728cb99211 /sys-cluster
parentPatch for security bug #97651 (diff)
downloadgentoo-2-7adc9cbccc7a348190f9c2ff7cb1cc38ae7b4f1c.tar.gz
gentoo-2-7adc9cbccc7a348190f9c2ff7cb1cc38ae7b4f1c.tar.bz2
gentoo-2-7adc9cbccc7a348190f9c2ff7cb1cc38ae7b4f1c.zip
Clean up the ebuild usage of SMP, to allow control of shmem builds with USE=sharedmem. Move to using virtual/pbs and virtual/mpi as mpiexec works with both of them. Clean up the ebuild a bit as well.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpiexec/ChangeLog12
-rw-r--r--sys-cluster/mpiexec/Manifest12
-rw-r--r--sys-cluster/mpiexec/files/digest-mpiexec-0.76-r21
-rw-r--r--sys-cluster/mpiexec/mpiexec-0.76-r2.ebuild49
4 files changed, 62 insertions, 12 deletions
diff --git a/sys-cluster/mpiexec/ChangeLog b/sys-cluster/mpiexec/ChangeLog
index 047f204d052c..fa895e4820bd 100644
--- a/sys-cluster/mpiexec/ChangeLog
+++ b/sys-cluster/mpiexec/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/mpiexec
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpiexec/ChangeLog,v 1.11 2004/09/19 18:55:59 tantive Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpiexec/ChangeLog,v 1.12 2005/07/06 00:03:02 robbat2 Exp $
+
+*mpiexec-0.76-r2 (06 Jul 2005)
+
+ 06 Jul 2005; Robin H. Johnson <robbat2@gentoo.org>
+ +mpiexec-0.76-r2.ebuild:
+ Clean up the ebuild usage of SMP, to allow control of shmem builds with
+ USE=sharedmem. Move to using virtual/pbs and virtual/mpi as mpiexec works
+ with both of them. Clean up the ebuild a bit as well.
19 Sep 2004; Michael Imhof <tantive@gentoo.org> -mpiexec-0.74-r1.ebuild:
Cleaned out old ebuild.
diff --git a/sys-cluster/mpiexec/Manifest b/sys-cluster/mpiexec/Manifest
index 16f6b7386d51..b5d24c8c7c37 100644
--- a/sys-cluster/mpiexec/Manifest
+++ b/sys-cluster/mpiexec/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 4bb512a529ce6a2c2cabc13973c61064 mpiexec-0.76-r2.ebuild 1409
MD5 051144fb727380bc09c1af789a4c06e2 mpiexec-0.75.ebuild 1391
MD5 12dded207fa3f63e288e53d5864db50f ChangeLog 1646
MD5 cde8b4e93c9339eb99fe3ad45941c99b metadata.xml 160
MD5 6653280d5e5d0c0aba4960f8eed0b0be mpiexec-0.76-r1.ebuild 1429
MD5 88ea7f9716c435f83937243bca1b32d8 files/digest-mpiexec-0.75 61
MD5 f92cd38fa54d44e0c7545219ab1984d8 files/digest-mpiexec-0.76-r1 61
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBw2s+I1lqEGTUzyQRAqpZAJ9iNF2g/zUTE6kCrZ5qMjWAjXvUxgCgkSM/
-FSUWFlF4KnU33jmST1Z8JcM=
-=OwGk
------END PGP SIGNATURE-----
+MD5 f92cd38fa54d44e0c7545219ab1984d8 files/digest-mpiexec-0.76-r2 61
diff --git a/sys-cluster/mpiexec/files/digest-mpiexec-0.76-r2 b/sys-cluster/mpiexec/files/digest-mpiexec-0.76-r2
new file mode 100644
index 000000000000..f29c7300584d
--- /dev/null
+++ b/sys-cluster/mpiexec/files/digest-mpiexec-0.76-r2
@@ -0,0 +1 @@
+MD5 5bd0512b7e6a2f86ac0397f93e6e6966 mpiexec-0.76.tgz 145241
diff --git a/sys-cluster/mpiexec/mpiexec-0.76-r2.ebuild b/sys-cluster/mpiexec/mpiexec-0.76-r2.ebuild
new file mode 100644
index 000000000000..55420f4cca40
--- /dev/null
+++ b/sys-cluster/mpiexec/mpiexec-0.76-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpiexec/mpiexec-0.76-r2.ebuild,v 1.1 2005/07/06 00:03:02 robbat2 Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="replacement for mpirun, integrates MPI with PBS."
+SRC_URI="http://www.osc.edu/~pw/mpiexec/${P}.tgz"
+HOMEPAGE="http://www.osc.edu/~pw/mpiexec/"
+IUSE="sharedmem"
+
+DEPEND="virtual/libc
+ virtual/pbs
+ virtual/mpi"
+RDEPEND="net-misc/openssh"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+src_compile() {
+ # sharedmem should NOT be used on SMP boxes
+ myconf="`use_enable sharedmem p4-shmem`"
+
+ # mpich-p4 is the best default
+ append-ldflags -L/usr/$(get_libdir)/pbs
+ ./configure --mandir=/usr/share/man/man1/ \
+ --prefix=/usr \
+ --with-pbs=/usr \
+ --with-default-comm=mpich-p4 \
+ ${myconf} || die "configure failed"
+
+ make || die "compile failed"
+
+ ## demo-hello: usefull for debugging
+ make hello || die "compile hello failed"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1/ \
+ install || die "install failed"
+
+ ## demo-hello:
+ dodoc hello.c
+ newbin hello hello_mpiexec
+
+ dodoc LICENSE README README.lam ChangeLog
+}