summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-08-06 15:13:12 +0000
committerYixun Lan <dlan@gentoo.org>2015-08-06 15:13:12 +0000
commit5c98da3bc6991decb4bb444a0a14be0cbab1a8a9 (patch)
tree36891bbe324e58de6f5b681926b1e6bf1bcdefca /sys-cluster
parentadd systemd support, bug 550892, thanks Michael Seifert (diff)
downloadgentoo-2-5c98da3bc6991decb4bb444a0a14be0cbab1a8a9.tar.gz
gentoo-2-5c98da3bc6991decb4bb444a0a14be0cbab1a8a9.tar.bz2
gentoo-2-5c98da3bc6991decb4bb444a0a14be0cbab1a8a9.zip
drop old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ChangeLog6
-rw-r--r--sys-cluster/ceph/ceph-0.80.10.ebuild137
-rw-r--r--sys-cluster/ceph/ceph-0.87.2.ebuild146
-rw-r--r--sys-cluster/ceph/ceph-0.94.2.ebuild143
4 files changed, 5 insertions, 427 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index 102ca2b620a8..7084120d7083 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.77 2015/08/06 15:10:06 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.78 2015/08/06 15:13:12 dlan Exp $
+
+ 06 Aug 2015; Yixun Lan <dlan@gentoo.org> -ceph-0.80.10.ebuild,
+ -ceph-0.87.2.ebuild, -ceph-0.94.2.ebuild:
+ drop old
*ceph-0.94.2-r1 (06 Aug 2015)
diff --git a/sys-cluster/ceph/ceph-0.80.10.ebuild b/sys-cluster/ceph/ceph-0.80.10.ebuild
deleted file mode 100644
index 666fba92be74..000000000000
--- a/sys-cluster/ceph/ceph-0.80.10.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.80.10.ebuild,v 1.1 2015/07/15 08:57:51 dlan Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-if [[ $PV = *9999* ]]; then
- scm_eclass=git-r3
- EGIT_REPO_URI="
- git://github.com/ceph/ceph.git
- https://github.com/ceph/ceph.git"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://ceph.com/download/${P}.tar.bz2"
- KEYWORDS="~amd64 ~x86"
-fi
-
-inherit autotools eutils multilib python-any-r1 udev readme.gentoo ${scm_eclass}
-
-DESCRIPTION="Ceph distributed filesystem"
-HOMEPAGE="http://ceph.com/"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="cryptopp debug fuse gtk libatomic +libaio +nss radosgw static-libs tcmalloc xfs zfs"
-
-CDEPEND="
- app-arch/snappy
- <dev-libs/boost-1.56.0:=[threads]
- dev-libs/fcgi
- dev-libs/libaio
- dev-libs/libedit
- dev-libs/leveldb[snappy]
- nss? ( dev-libs/nss )
- cryptopp? ( dev-libs/crypto++ )
- sys-apps/keyutils
- sys-apps/util-linux
- dev-libs/libxml2
- fuse? ( sys-fs/fuse )
- libatomic? ( dev-libs/libatomic_ops )
- xfs? ( sys-fs/xfsprogs )
- zfs? ( sys-fs/zfs )
- gtk? (
- x11-libs/gtk+:2
- dev-cpp/gtkmm:2.4
- gnome-base/librsvg
- )
- radosgw? (
- dev-libs/fcgi
- dev-libs/expat
- net-misc/curl
- )
- tcmalloc? ( dev-util/google-perftools )
- $(python_gen_any_dep '
- ' )
- ${PYTHON_DEPS}
- "
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- sys-apps/hdparm
- $(python_gen_any_dep '
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ' )"
-REQUIRED_USE="
- ^^ ( nss cryptopp )
- "
-
-STRIP_MASK="/usr/lib*/rados-classes/*"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.79-libzfs.patch
-)
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- [[ ${PATCHES[@]} ]] && epatch "${PATCHES[@]}"
-
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- econf \
- --without-hadoop \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --includedir=/usr/include \
- $(use_with debug) \
- $(use_with fuse) \
- $(use_with libaio) \
- $(use_with libatomic libatomic-ops) \
- $(use_with nss) \
- $(use_with cryptopp) \
- $(use_with radosgw) \
- $(use_with gtk gtk2) \
- $(use_enable static-libs static) \
- $(use_with tcmalloc) \
- $(use_with xfs libxfs) \
- $(use_with zfs libzfs)
-}
-
-src_install() {
- default
-
- prune_libtool_files --all
-
- exeinto /usr/$(get_libdir)/ceph
- newexe src/init-ceph ceph_init.sh
-
- insinto /etc/logrotate.d/
- newins "${FILESDIR}"/ceph.logrotate ${PN}
-
- chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
-
- keepdir /var/lib/${PN}
- keepdir /var/lib/${PN}/tmp
- keepdir /var/log/${PN}/stat
-
- newinitd "${FILESDIR}/${PN}.initd-r1" ${PN}
- newconfd "${FILESDIR}/${PN}.confd-r1" ${PN}
-
- python_fix_shebang \
- "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
- "${ED}"/usr/bin/{ceph,ceph-rest-api}
-
- #install udev rules
- udev_dorules udev/50-rbd.rules
- udev_dorules udev/95-ceph-osd.rules
-
- readme.gentoo_create_doc
-}
diff --git a/sys-cluster/ceph/ceph-0.87.2.ebuild b/sys-cluster/ceph/ceph-0.87.2.ebuild
deleted file mode 100644
index 17ad373b65b3..000000000000
--- a/sys-cluster/ceph/ceph-0.87.2.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.87.2.ebuild,v 1.2 2015/08/04 15:47:03 dlan Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-if [[ $PV = *9999* ]]; then
- scm_eclass=git-r3
- EGIT_REPO_URI="
- git://github.com/ceph/ceph.git
- https://github.com/ceph/ceph.git"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://ceph.com/download/${P}.tar.bz2"
- KEYWORDS="~amd64 ~x86"
-fi
-
-inherit autotools eutils multilib python-any-r1 udev readme.gentoo ${scm_eclass}
-
-DESCRIPTION="Ceph distributed filesystem"
-HOMEPAGE="http://ceph.com/"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="babeltrace cryptopp debug fuse gtk libatomic +libaio lttng +nss radosgw static-libs tcmalloc xfs zfs"
-
-CDEPEND="
- app-arch/snappy
- dev-libs/boost:=[threads]
- dev-libs/fcgi
- dev-libs/libaio
- dev-libs/libedit
- dev-libs/leveldb[snappy]
- nss? ( dev-libs/nss )
- cryptopp? ( dev-libs/crypto++ )
- sys-apps/keyutils
- sys-apps/util-linux
- dev-libs/libxml2
- babeltrace? ( dev-util/babeltrace )
- fuse? ( sys-fs/fuse )
- libatomic? ( dev-libs/libatomic_ops )
- xfs? ( sys-fs/xfsprogs )
- zfs? ( sys-fs/zfs )
- gtk? (
- x11-libs/gtk+:2
- dev-cpp/gtkmm:2.4
- gnome-base/librsvg
- )
- radosgw? (
- dev-libs/fcgi
- dev-libs/expat
- net-misc/curl
- )
- tcmalloc? ( dev-util/google-perftools )
- lttng? ( dev-util/lttng-ust )
- $(python_gen_any_dep '
- ' )
- ${PYTHON_DEPS}
- "
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- sys-apps/hdparm
- $(python_gen_any_dep '
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ' )"
-REQUIRED_USE="
- ^^ ( nss cryptopp )
- "
-
-STRIP_MASK="/usr/lib*/rados-classes/*"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.79-libzfs.patch
-)
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- [[ ${PATCHES[@]} ]] && epatch "${PATCHES[@]}"
-
- sed -e '1i#include <stdint.h>' \
- -i src/tracing/{objectstore,oprequest,osd,pg}.tp || die
-
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- econf \
- --without-hadoop \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --includedir=/usr/include \
- $(use_with debug) \
- $(use_with fuse) \
- $(use_with libaio) \
- $(use_with libatomic libatomic-ops) \
- $(use_with nss) \
- $(use_with cryptopp) \
- $(use_with radosgw) \
- $(use_with gtk gtk2) \
- $(use_enable static-libs static) \
- $(use_with tcmalloc) \
- $(use_with xfs libxfs) \
- $(use_with zfs libzfs) \
- --without-kinetic \
- --without-librocksdb \
- $(use_with lttng ) \
- $(use_with babeltrace)
-}
-
-src_install() {
- default
-
- prune_libtool_files --all
-
- exeinto /usr/$(get_libdir)/ceph
- newexe src/init-ceph ceph_init.sh
-
- insinto /etc/logrotate.d/
- newins "${FILESDIR}"/ceph.logrotate ${PN}
-
- chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
-
- keepdir /var/lib/${PN}
- keepdir /var/lib/${PN}/tmp
- keepdir /var/log/${PN}/stat
-
- newinitd "${FILESDIR}/${PN}.initd-r1" ${PN}
- newconfd "${FILESDIR}/${PN}.confd-r1" ${PN}
-
- python_fix_shebang \
- "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
- "${ED}"/usr/bin/{ceph,ceph-rest-api}
-
- #install udev rules
- udev_dorules udev/50-rbd.rules
- udev_dorules udev/95-ceph-osd.rules
-
- readme.gentoo_create_doc
-}
diff --git a/sys-cluster/ceph/ceph-0.94.2.ebuild b/sys-cluster/ceph/ceph-0.94.2.ebuild
deleted file mode 100644
index 2f313ed9a89c..000000000000
--- a/sys-cluster/ceph/ceph-0.94.2.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.94.2.ebuild,v 1.2 2015/08/06 02:38:08 dlan Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-if [[ $PV = *9999* ]]; then
- scm_eclass=git-r3
- EGIT_REPO_URI="
- git://github.com/ceph/ceph.git
- https://github.com/ceph/ceph.git"
- SRC_URI=""
-else
- SRC_URI="http://ceph.com/download/${P}.tar.bz2"
-fi
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-
-inherit autotools eutils multilib python-any-r1 udev readme.gentoo ${scm_eclass}
-
-DESCRIPTION="Ceph distributed filesystem"
-HOMEPAGE="http://ceph.com/"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="babeltrace cryptopp debug fuse gtk libatomic +libaio lttng +nss radosgw static-libs tcmalloc xfs zfs"
-
-CDEPEND="
- app-arch/snappy
- dev-libs/boost:=[threads]
- dev-libs/fcgi
- dev-libs/libaio
- dev-libs/libedit
- dev-libs/leveldb[snappy]
- nss? ( dev-libs/nss )
- cryptopp? ( dev-libs/crypto++ )
- sys-apps/keyutils
- sys-apps/util-linux
- dev-libs/libxml2
- babeltrace? ( dev-util/babeltrace )
- fuse? ( sys-fs/fuse )
- libatomic? ( dev-libs/libatomic_ops )
- xfs? ( sys-fs/xfsprogs )
- zfs? ( sys-fs/zfs )
- gtk? (
- x11-libs/gtk+:2
- dev-cpp/gtkmm:2.4
- gnome-base/librsvg
- )
- radosgw? (
- dev-libs/fcgi
- dev-libs/expat
- net-misc/curl
- )
- tcmalloc? ( dev-util/google-perftools )
- lttng? ( dev-util/lttng-ust )
- $(python_gen_any_dep '
- ' )
- ${PYTHON_DEPS}
- "
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- sys-apps/hdparm
- $(python_gen_any_dep '
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ' )"
-REQUIRED_USE="
- ^^ ( nss cryptopp )
- "
-
-STRIP_MASK="/usr/lib*/rados-classes/*"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.79-libzfs.patch
-)
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- [[ ${PATCHES[@]} ]] && epatch "${PATCHES[@]}"
-
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- econf \
- --without-hadoop \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --includedir=/usr/include \
- $(use_with debug) \
- $(use_with fuse) \
- $(use_with libaio) \
- $(use_with libatomic libatomic-ops) \
- $(use_with nss) \
- $(use_with cryptopp) \
- $(use_with radosgw) \
- $(use_with gtk gtk2) \
- $(use_enable static-libs static) \
- $(use_with tcmalloc) \
- $(use_with xfs libxfs) \
- $(use_with zfs libzfs) \
- --without-kinetic \
- --without-librocksdb \
- $(use_with lttng ) \
- $(use_with babeltrace)
-}
-
-src_install() {
- default
-
- prune_libtool_files --all
-
- exeinto /usr/$(get_libdir)/ceph
- newexe src/init-ceph ceph_init.sh
-
- insinto /etc/logrotate.d/
- newins "${FILESDIR}"/ceph.logrotate ${PN}
-
- chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
-
- keepdir /var/lib/${PN}
- keepdir /var/lib/${PN}/tmp
- keepdir /var/log/${PN}/stat
-
- newinitd "${FILESDIR}/rbdmap.initd" rbdmap
- newinitd "${FILESDIR}/${PN}.initd-r1" ${PN}
- newconfd "${FILESDIR}/${PN}.confd-r1" ${PN}
-
- python_fix_shebang \
- "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
- "${ED}"/usr/bin/{ceph,ceph-rest-api}
-
- #install udev rules
- udev_dorules udev/50-rbd.rules
- udev_dorules udev/95-ceph-osd.rules
-
- readme.gentoo_create_doc
-}