summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2008-01-17 01:52:44 +0000
committerJustin Bronder <jsbronder@gentoo.org>2008-01-17 01:52:44 +0000
commit112412c5cddd9c164b2f53dbac7dd5c9336c51d4 (patch)
tree3b2440467e205db203b21ed554093353ef50a13b /sys-cluster
parentMarking old ppc64 profiles as deprecated. Way overdue (diff)
downloadgentoo-2-112412c5cddd9c164b2f53dbac7dd5c9336c51d4.tar.gz
gentoo-2-112412c5cddd9c164b2f53dbac7dd5c9336c51d4.tar.bz2
gentoo-2-112412c5cddd9c164b2f53dbac7dd5c9336c51d4.zip
Version bump. Remove slurm USE flag as slurm isn't in the tree. Let configure find libtorque via pbs-config.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog10
-rw-r--r--sys-cluster/openmpi/files/digest-openmpi-1.2.53
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.5.ebuild91
3 files changed, 102 insertions, 2 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 6bb79bd76713..c51f4b166400 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/openmpi
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.11 2007/12/13 22:39:53 jsbronder Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.12 2008/01/17 01:52:43 jsbronder Exp $
+
+*openmpi-1.2.5 (17 Jan 2008)
+
+ 17 Jan 2008; Justin Bronder <jsbronder@gentoo.org> +openmpi-1.2.5.ebuild:
+ Version bump. Remove slurm USE flag as slurm isn't in the tree. Let
+ configure find libtorque via pbs-config.
13 Dec 2007; Justin Bronder <jsbronder@gentoo.org> openmpi-1.2.4.ebuild:
Minor fixes to sys-cluster/openmpi-1.2.4, thanks to dberkholz for pointing
diff --git a/sys-cluster/openmpi/files/digest-openmpi-1.2.5 b/sys-cluster/openmpi/files/digest-openmpi-1.2.5
new file mode 100644
index 000000000000..48e9849525fa
--- /dev/null
+++ b/sys-cluster/openmpi/files/digest-openmpi-1.2.5
@@ -0,0 +1,3 @@
+MD5 c6e82aab6cdcd425bf29217e8317d7dc openmpi-1.2.5.tar.bz2 3554443
+RMD160 609a2070d69bbcde883d2f0d1d6364c5903ae59f openmpi-1.2.5.tar.bz2 3554443
+SHA256 3c3aed872c17165131c77bd7a12fe8aec776cb23da946b7d12840db93ab79322 openmpi-1.2.5.tar.bz2 3554443
diff --git a/sys-cluster/openmpi/openmpi-1.2.5.ebuild b/sys-cluster/openmpi/openmpi-1.2.5.ebuild
new file mode 100644
index 000000000000..378270af1b4d
--- /dev/null
+++ b/sys-cluster/openmpi/openmpi-1.2.5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.5.ebuild,v 1.1 2008/01/17 01:52:43 jsbronder Exp $
+
+inherit eutils multilib flag-o-matic toolchain-funcs fortran
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A high-performance message passing library (MPI)"
+HOMEPAGE="http://www.open-mpi.org"
+SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pbs fortran nocxx threads romio heterogeneous smp ipv6"
+RDEPEND="pbs? ( sys-cluster/torque )
+ !sys-cluster/mpich
+ !sys-cluster/lam-mpi
+ !sys-cluster/mpich2"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use threads; then
+ ewarn
+ ewarn "WARNING: use of threads is still disabled by default in"
+ ewarn "upstream builds."
+ ewarn "You may stop now and set USE=-threads"
+ ewarn
+ epause 5
+ fi
+
+ elog
+ elog "OpenMPI has an overwhelming count of configuration options."
+ elog "Don't forget the EXTRA_ECONF environment variable can let you"
+ elog "specify configure options if you find them necessary."
+ elog
+
+ if use fortran; then
+ FORTRAN="g77 gfortran ifc"
+ fortran_pkg_setup
+ fi
+}
+
+src_compile() {
+ local myconf="
+ --sysconfdir=/etc/${PN}
+ --without-xgrid
+ --enable-pretty-print-stacktrace
+ --enable-orterun-prefix-by-default
+ --without-slurm"
+
+ if use threads; then
+ myconf="${myconf}
+ --enable-mpi-threads
+ --with-progress-threads
+ --with-threads=posix"
+ fi
+
+ if use fortran; then
+ if [[ "${FORTRANC}" = "g77" ]]; then
+ myconf="${myconf} --disable-mpi-f90"
+ elif [[ "${FORTRANC}" = "gfortran" ]]; then
+ # Because that's just a pain in the butt.
+ myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
+ elif [[ "${FORTRANC}" = if* ]]; then
+ # Enabled here as gfortran compile times are huge with this enabled.
+ myconf="${myconf} --with-mpi-f90-size=medium"
+ fi
+ else
+ myconf="${myconf}
+ --disable-mpi-f90
+ --disable-mpi-f77"
+ fi
+
+ econf ${myconf} \
+ $(use_enable !nocxx mpi-cxx) \
+ $(use_enable romio romio-io) \
+ $(use_enable smp smp-locks) \
+ $(use_enable heterogeneous) \
+ $(use_with pbs tm) \
+ $(use_enable ipv6) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README AUTHORS NEWS VERSION
+}