summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-08-05 02:19:21 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-08-05 02:19:21 +0000
commit0d77196e566aeb779f2d6637e7d2ade332acb13c (patch)
tree9673e23ca01f14620fad29ed472f4d361c0923f5 /sys-cluster
parentAdd conditional 3to2 build dep. (diff)
downloadgentoo-2-0d77196e566aeb779f2d6637e7d2ade332acb13c.tar.gz
gentoo-2-0d77196e566aeb779f2d6637e7d2ade332acb13c.tar.bz2
gentoo-2-0d77196e566aeb779f2d6637e7d2ade332acb13c.zip
updating nova deps to work with cinder
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/nova/ChangeLog6
-rw-r--r--sys-cluster/nova/nova-2015.1.1-r1.ebuild12
-rw-r--r--sys-cluster/nova/nova-2015.1.9999.ebuild12
3 files changed, 25 insertions, 5 deletions
diff --git a/sys-cluster/nova/ChangeLog b/sys-cluster/nova/ChangeLog
index 9dea242547b4..41e3a0e16ff4 100644
--- a/sys-cluster/nova/ChangeLog
+++ b/sys-cluster/nova/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/nova
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.104 2015/07/30 05:40:53 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.105 2015/08/05 02:19:21 prometheanfire Exp $
+
+ 05 Aug 2015; Matthew Thode <prometheanfire@gentoo.org>
+ nova-2015.1.1-r1.ebuild, nova-2015.1.9999.ebuild:
+ updating nova deps to work with cinder
*nova-2015.1.1-r1 (30 Jul 2015)
diff --git a/sys-cluster/nova/nova-2015.1.1-r1.ebuild b/sys-cluster/nova/nova-2015.1.1-r1.ebuild
index 37cbed3b1a78..bb5887007bba 100644
--- a/sys-cluster/nova/nova-2015.1.1-r1.ebuild
+++ b/sys-cluster/nova/nova-2015.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.1-r1.ebuild,v 1.1 2015/07/30 05:40:53 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.1-r1.ebuild,v 1.2 2015/08/05 02:19:21 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -140,12 +140,13 @@ RDEPEND="
>=dev-python/psutil-1.1.1[${PYTHON_USEDEP}]
<dev-python/psutil-2.0.0[${PYTHON_USEDEP}]
dev-python/libvirt-python[${PYTHON_USEDEP}]
+ app-emulation/libvirt[iscsi?]
novncproxy? ( www-apps/novnc )
sys-apps/iproute2
openvswitch? ( net-misc/openvswitch )
rabbitmq? ( net-misc/rabbitmq-server )
memcached? ( net-misc/memcached
- dev-python/python-memcached )
+ dev-python/python-memcached )
sys-fs/sysfsutils
sys-fs/multipath-tools
net-misc/bridge-utils
@@ -157,6 +158,7 @@ RDEPEND="
)
iscsi? (
sys-fs/lsscsi
+ >=sys-block/open-iscsi-2.0.872-r3
)"
PATCHES=(
@@ -241,3 +243,9 @@ python_install() {
doins "${FILESDIR}/scsi-openscsi-link.sh"
fi
}
+
+pkg_postinst() {
+ if use iscsi ; then
+ elog "iscsid needs to be running if you want cinder to connect"
+ fi
+}
diff --git a/sys-cluster/nova/nova-2015.1.9999.ebuild b/sys-cluster/nova/nova-2015.1.9999.ebuild
index 8dc79df4c840..d4447bed116a 100644
--- a/sys-cluster/nova/nova-2015.1.9999.ebuild
+++ b/sys-cluster/nova/nova-2015.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.9999.ebuild,v 1.15 2015/07/30 05:40:53 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.9999.ebuild,v 1.16 2015/08/05 02:19:21 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -141,12 +141,13 @@ RDEPEND="
>=dev-python/psutil-1.1.1[${PYTHON_USEDEP}]
<dev-python/psutil-2.0.0[${PYTHON_USEDEP}]
dev-python/libvirt-python[${PYTHON_USEDEP}]
+ app-emulation/libvirt[iscsi?]
novncproxy? ( www-apps/novnc )
sys-apps/iproute2
openvswitch? ( net-misc/openvswitch )
rabbitmq? ( net-misc/rabbitmq-server )
memcached? ( net-misc/memcached
- dev-python/python-memcached )
+ dev-python/python-memcached )
sys-fs/sysfsutils
sys-fs/multipath-tools
net-misc/bridge-utils
@@ -158,6 +159,7 @@ RDEPEND="
)
iscsi? (
sys-fs/lsscsi
+ >=sys-block/open-iscsi-2.0.872-r3
)"
PATCHES=(
@@ -242,3 +244,9 @@ python_install() {
doins "${FILESDIR}/scsi-openscsi-link.sh"
fi
}
+
+pkg_postinst() {
+ if use iscsi ; then
+ elog "iscsid needs to be running if you want cinder to connect"
+ fi
+}