summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-06-26 15:47:56 +0000
committerMichael Imhof <tantive@gentoo.org>2003-06-26 15:47:56 +0000
commit525532860f5f0271c72f7a442a9086fd25364019 (patch)
tree1026d7a55ed3cf9a3fba84978319d809d3f3ebd2 /sys-cluster/xpvm
parentVersion bump. (diff)
downloadgentoo-2-525532860f5f0271c72f7a442a9086fd25364019.tar.gz
gentoo-2-525532860f5f0271c72f7a442a9086fd25364019.tar.bz2
gentoo-2-525532860f5f0271c72f7a442a9086fd25364019.zip
Should close #22689
Diffstat (limited to 'sys-cluster/xpvm')
-rw-r--r--sys-cluster/xpvm/Manifest4
-rw-r--r--sys-cluster/xpvm/files/xpvm-1.2.5-gentoo.diff33
-rw-r--r--sys-cluster/xpvm/xpvm-1.2.5.ebuild6
3 files changed, 36 insertions, 7 deletions
diff --git a/sys-cluster/xpvm/Manifest b/sys-cluster/xpvm/Manifest
index fae2c708dd0f..585db574fe26 100644
--- a/sys-cluster/xpvm/Manifest
+++ b/sys-cluster/xpvm/Manifest
@@ -1,4 +1,4 @@
-MD5 777c4c9d7cbc2a87fcaa97a8671412da xpvm-1.2.5.ebuild 1514
+MD5 f98f1e822673bb15499b1a1f0f4046cb xpvm-1.2.5.ebuild 1516
MD5 3a0174bdc31483dffd666269c6f9107b ChangeLog 376
-MD5 8612050ae54924fde11b114f95ea5e63 files/xpvm-1.2.5-gentoo.diff 2049
+MD5 4844e6d445655538fdc6b850dc33e539 files/xpvm-1.2.5-gentoo.diff 2910
MD5 915d49a269c55c9d68cf0d7d30f1b272 files/digest-xpvm-1.2.5 63
diff --git a/sys-cluster/xpvm/files/xpvm-1.2.5-gentoo.diff b/sys-cluster/xpvm/files/xpvm-1.2.5-gentoo.diff
index ce107cdd2a57..307c808f8d29 100644
--- a/sys-cluster/xpvm/files/xpvm-1.2.5-gentoo.diff
+++ b/sys-cluster/xpvm/files/xpvm-1.2.5-gentoo.diff
@@ -1,5 +1,20 @@
---- xpvm/src/Makefile.aimk 1998-04-09 23:11:22.000000000 +0200
-+++ /opt/pvm3/xpvm/src/Makefile.aimk 2003-05-31 11:53:31.000000000 +0200
+diff -ur test/xpvm/Makefile xpvm/Makefile
+--- test/xpvm/Makefile 1998-04-09 23:11:23.000000000 +0200
++++ xpvm/Makefile 2003-06-02 10:45:26.000000000 +0200
+@@ -2,6 +2,10 @@
+ # $Id: xpvm-1.2.5-gentoo.diff,v 1.2 2003/06/26 15:47:38 tantive Exp $
+ #
+
++xpvm:
++ cd src ; $(PVM_ROOT)/lib/aimk trclib
++ cd src ; $(PVM_ROOT)/lib/aimk xpvm
++
+ install:
+ cd src ; $(PVM_ROOT)/lib/aimk install
+
+diff -ur test/xpvm/src/Makefile.aimk xpvm/src/Makefile.aimk
+--- test/xpvm/src/Makefile.aimk 1998-04-09 23:11:22.000000000 +0200
++++ xpvm/src/Makefile.aimk 2003-06-02 10:45:26.000000000 +0200
@@ -25,8 +25,8 @@
CFLOPTS = -O
#CFLOPTS = -g
@@ -84,3 +99,17 @@
# IBM Shared Library Systems
#SHLIB = -lld
# HP, Some Linux Shared Library Systems
+diff -ur test/xpvm/src/Makefile.xpvm xpvm/src/Makefile.xpvm
+--- test/xpvm/src/Makefile.xpvm 1998-04-09 23:11:23.000000000 +0200
++++ xpvm/src/Makefile.xpvm 2003-06-02 10:45:26.000000000 +0200
+@@ -2,6 +2,10 @@
+ # $Id: xpvm-1.2.5-gentoo.diff,v 1.2 2003/06/26 15:47:38 tantive Exp $
+ #
+
++xpvm:
++ cd src ; $(PVM_ROOT)/lib/aimk trclib
++ cd src ; $(PVM_ROOT)/lib/aimk xpvm
++
+ install:
+ cd src ; $(PVM_ROOT)/lib/aimk install
+
diff --git a/sys-cluster/xpvm/xpvm-1.2.5.ebuild b/sys-cluster/xpvm/xpvm-1.2.5.ebuild
index d3c07baf940a..190cd996f8ce 100644
--- a/sys-cluster/xpvm/xpvm-1.2.5.ebuild
+++ b/sys-cluster/xpvm/xpvm-1.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/xpvm/xpvm-1.2.5.ebuild,v 1.1 2003/06/22 20:56:33 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/xpvm/xpvm-1.2.5.ebuild,v 1.2 2003/06/26 15:47:38 tantive Exp $
S=${WORKDIR}/${P}
DESCRIPTION="XPVM: A graphical console and monitor for PVM"
@@ -19,7 +19,7 @@ LICENSE="LGPL-2"
src_unpack() {
unpack ${A}
- patch -p0 <${DISTDIR}/xpvm-1.2.5-gentoo.diff || die
+ patch -p0 <${FILESDIR}/xpvm-1.2.5-gentoo.diff || die
}
src_compile() {
@@ -29,7 +29,7 @@ src_compile() {
export PVM_ARCH="LINUX"
export XPVM_ROOT=${WORKDIR}"/xpvm"
- make xpvm || die
+ emake xpvm || die
}
src_install() {