summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-09-22 09:12:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-09-22 09:12:37 +0000
commit81be31faeeb25973fae7d409b5864b0a02783fbb (patch)
treed732c4c7c753f4f0140fe80a362d46dc2e3b074d /sys-cluster/keepalived
parentstable on ppc64 (diff)
downloadgentoo-2-81be31faeeb25973fae7d409b5864b0a02783fbb.tar.gz
gentoo-2-81be31faeeb25973fae7d409b5864b0a02783fbb.tar.bz2
gentoo-2-81be31faeeb25973fae7d409b5864b0a02783fbb.zip
Version bump.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-cluster/keepalived')
-rw-r--r--sys-cluster/keepalived/ChangeLog8
-rw-r--r--sys-cluster/keepalived/files/digest-keepalived-1.1.153
-rw-r--r--sys-cluster/keepalived/keepalived-1.1.15.ebuild83
3 files changed, 93 insertions, 1 deletions
diff --git a/sys-cluster/keepalived/ChangeLog b/sys-cluster/keepalived/ChangeLog
index 8bdb9925873f..5204198ff609 100644
--- a/sys-cluster/keepalived/ChangeLog
+++ b/sys-cluster/keepalived/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/keepalived
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.42 2007/04/30 06:45:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.43 2007/09/22 09:12:36 robbat2 Exp $
+
+*keepalived-1.1.15 (22 Sep 2007)
+
+ 22 Sep 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +keepalived-1.1.15.ebuild:
+ Version bump.
30 Apr 2007; Robin H. Johnson <robbat2@gentoo.org> files/init-keepalived:
Make init.d baselayout2 safe.
diff --git a/sys-cluster/keepalived/files/digest-keepalived-1.1.15 b/sys-cluster/keepalived/files/digest-keepalived-1.1.15
new file mode 100644
index 000000000000..3fcf31a9515d
--- /dev/null
+++ b/sys-cluster/keepalived/files/digest-keepalived-1.1.15
@@ -0,0 +1,3 @@
+MD5 4c93f5d8b6bfabe84b02828a5bbb7aa0 keepalived-1.1.15.tar.gz 227003
+RMD160 5043db0e531fbed43a5488efb451d1e23a5267a5 keepalived-1.1.15.tar.gz 227003
+SHA256 9d9291b0b24d9147a2a68c78c3227d996002ef6401340123f1dda3ddf8718b44 keepalived-1.1.15.tar.gz 227003
diff --git a/sys-cluster/keepalived/keepalived-1.1.15.ebuild b/sys-cluster/keepalived/keepalived-1.1.15.ebuild
new file mode 100644
index 000000000000..c7b752de4687
--- /dev/null
+++ b/sys-cluster/keepalived/keepalived-1.1.15.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.15.ebuild,v 1.1 2007/09/22 09:12:36 robbat2 Exp $
+
+inherit flag-o-matic autotools
+
+DESCRIPTION="add a strong & robust keepalive facility to the Linux Virtual Server project"
+HOMEPAGE="http://www.keepalived.org/"
+SRC_URI="http://www.keepalived.org/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug profile"
+
+RDEPEND="dev-libs/popt
+ sys-apps/iproute2
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ =sys-kernel/linux-headers-2.6*"
+
+src_unpack() {
+ unpack ${A}
+
+ # This patch allows us to avoid needing kernel sources for the configure phase
+ EPATCH_OPTS="-p1 -d${S}" epatch \
+ ${FILESDIR}/${PN}-1.1.13-do-not-need-kernel-sources.patch
+ cd ${S}
+ eautoreconf
+
+ # Prepare a suitable copy of the IPVS headers
+ # So that we don't need kernel sources at all!
+ mkdir -p ${S}/include/net || die "Failed to prepare ipvs header directory"
+ cp -f ${FILESDIR}/${PN}-1.1.13-linux-2.6.21-ip_vs.h \
+ ${S}/include/net/ip_vs.h || die "Failed to add ipvs header"
+
+ # Ensure that keepalived can find the header that we are injecting
+ append-flags -I${S}/include
+}
+
+src_compile() {
+ local myconf
+
+ myconf="--enable-vrrp"
+
+ # This is not an error
+ # The upstream makefile used to add man/, but doesn't anymore
+ myconf="${myconf} --mandir=/usr/share/man"
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ # disable -fomit-frame-pointer for profiling
+ if use profile; then
+ filter-flags -fomit-frame-pointer
+ myconf="${myconf} --enable-profile"
+ fi
+
+ econf ${myconf} STRIP=/bin/true || die "configure failed"
+ emake || die "emake failed (myconf=${myconf})"
+}
+
+src_install() {
+ # Not parallel safe
+ emake -j1 install DESTDIR="${D}" || die "emake install failed"
+
+ newinitd ${FILESDIR}/init-keepalived keepalived
+
+ dodoc doc/keepalived.conf.SYNOPSIS
+ dodoc README CONTRIBUTORS INSTALL VERSION ChangeLog AUTHOR TODO
+
+ docinto genhash
+ dodoc genhash/README genhash/AUTHOR genhash/ChangeLog genhash/VERSION
+ # This was badly named by upstream, it's more HOWTO than anything else.
+ newdoc INSTALL INSTALL+HOWTO
+
+ # Security risk to bundle SSL certs
+ rm -f ${D}/etc/keepalived/samples/*.pem
+ rm -rf ${D}/etc/sysconfig ${D}/etc/rc.d/
+}
+
+pkg_postinst() {
+ elog "For internal debug support, compile with USE=debug via package.use"
+}