summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawek Lis <slis@gentoo.org>2014-11-05 05:30:37 +0000
committerSlawek Lis <slis@gentoo.org>2014-11-05 05:30:37 +0000
commit401ea8df0f2e94097fd93220f0d3fdd1cf2a75a9 (patch)
treeec225af0ccf76531faeb6625564b8c398cd4f878 /sys-cluster/hpx
parentBump (diff)
downloadgentoo-2-401ea8df0f2e94097fd93220f0d3fdd1cf2a75a9.tar.gz
gentoo-2-401ea8df0f2e94097fd93220f0d3fdd1cf2a75a9.tar.bz2
gentoo-2-401ea8df0f2e94097fd93220f0d3fdd1cf2a75a9.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x55265D89)
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/ChangeLog7
-rw-r--r--sys-cluster/hpx/hpx-0.9.9.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/sys-cluster/hpx/ChangeLog b/sys-cluster/hpx/ChangeLog
index a00a9aceac27..29b2bdf8ef20 100644
--- a/sys-cluster/hpx/ChangeLog
+++ b/sys-cluster/hpx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/hpx
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpx/ChangeLog,v 1.1 2014/07/31 12:26:11 slis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpx/ChangeLog,v 1.2 2014/11/05 05:30:37 slis Exp $
+
+*hpx-0.9.9 (05 Nov 2014)
+
+ 05 Nov 2014; Sławek Lis <slis@gentoo.org> +hpx-0.9.9.ebuild:
+ version bump
*hpx-0.9.8 (31 Jul 2014)
diff --git a/sys-cluster/hpx/hpx-0.9.9.ebuild b/sys-cluster/hpx/hpx-0.9.9.ebuild
new file mode 100644
index 000000000000..d212c458ed53
--- /dev/null
+++ b/sys-cluster/hpx/hpx-0.9.9.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpx/hpx-0.9.9.ebuild,v 1.1 2014/11/05 05:30:37 slis Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+
+inherit cmake-utils fortran-2 multilib python-single-r1 versionator
+
+MY_PV="$(replace_version_separator _ -)"
+
+SRC_URI="https://github.com/STEllAR-GROUP/hpx/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="C++ runtime system for parallel and distributed applications"
+HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+IUSE="doc examples jemalloc papi +perftools tbb test"
+
+RDEPEND="
+ tbb? ( dev-cpp/tbb )
+ >=dev-libs/boost-1.49
+ papi? ( dev-libs/papi )
+ perftools? ( >=dev-util/google-perftools-1.7.1 )
+ >=sys-apps/hwloc-1.8
+ >=sys-libs/libunwind-1
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-lang/python )
+"
+REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )
+ jemalloc? ( !perftools !tbb )
+ perftools? ( !jemalloc !tbb )
+ tbb? ( !jemalloc !perftools )
+ "
+
+pkg_setup() {
+ use test && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release
+ local mycmakeargs=(
+ -DHPX_BUILD_EXAMPLES=OFF
+ -DHPX_MALLOC=system
+ -DLIB=$(get_libdir)
+ -Dcmake_dir=cmake
+ $(cmake-utils_use doc HPX_BUILD_DOCUMENTATION)
+ $(cmake-utils_use jemalloc HPX_JEMALLOC)
+ $(cmake-utils_use test BUILD_TESTING)
+ $(cmake-utils_use perftools HPX_GOOGLE_PERFTOOLS)
+ $(cmake-utils_use papi HPX_PAPI)
+ )
+
+ use perftools && mycmakeargs+=( -DHPX_MALLOC=tcmalloc )
+ use jemalloc && mycmakeargs+=( -DHPX_MALLOC=jemalloc )
+ use tbb && mycmakeargs+=( -DHPX_MALLOC=tbbmalloc )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # avoid over-suscribing
+ cmake-utils_src_make -j1 tests
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}