summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Longland <redhatter@gentoo.org>2007-02-24 16:18:48 +0000
committerStuart Longland <redhatter@gentoo.org>2007-02-24 16:18:48 +0000
commitbb09dd8c5c91cbb96a4fab112ee65229de5ec336 (patch)
tree76b1cbf6f7329453e6fe5a67e45efa70bd67fc52 /sys-boot
parentRegen for Manifest2 - Bug #165195 (diff)
downloadgentoo-2-bb09dd8c5c91cbb96a4fab112ee65229de5ec336.tar.gz
gentoo-2-bb09dd8c5c91cbb96a4fab112ee65229de5ec336.tar.bz2
gentoo-2-bb09dd8c5c91cbb96a4fab112ee65229de5ec336.zip
Version bump to 1.22... Cobalt Users: Please test this package and report back... I intend to bump this to stable *very* soon.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/colo/ChangeLog8
-rw-r--r--sys-boot/colo/colo-1.22.ebuild109
-rw-r--r--sys-boot/colo/files/digest-colo-1.223
3 files changed, 119 insertions, 1 deletions
diff --git a/sys-boot/colo/ChangeLog b/sys-boot/colo/ChangeLog
index 4f54bc423f6e..b3c24428d2e0 100644
--- a/sys-boot/colo/ChangeLog
+++ b/sys-boot/colo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/colo
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.17 2007/02/09 05:50:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.18 2007/02/24 16:18:48 redhatter Exp $
+
+*colo-1.22 (24 Feb 2007)
+
+ 24 Feb 2007; Stuart Longland <redhatter@gentoo.org> +colo-1.22.ebuild:
+ Version bump to 1.22... Cobalt Users: Please test this package and report
+ back... I intend to bump this to stable *very* soon.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/sys-boot/colo/colo-1.22.ebuild b/sys-boot/colo/colo-1.22.ebuild
new file mode 100644
index 000000000000..9c97a55cde24
--- /dev/null
+++ b/sys-boot/colo/colo-1.22.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/colo-1.22.ebuild,v 1.1 2007/02/24 16:18:48 redhatter Exp $
+
+inherit eutils
+
+DESCRIPTION="CObalt LOader - Modern bootloader for Cobalt MIPS machines"
+HOMEPAGE="http://www.colonel-panic.org/cobalt-mips/"
+SRC_URI="http://www.colonel-panic.org/cobalt-mips/colo/colo-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* mips"
+IUSE=""
+DEPEND=""
+RESTRICT="nostrip"
+
+
+pkg_setup() {
+ # See if we're on a cobalt system (must use the cobalt-mips profile)
+ if [ "${PROFILE_ARCH}" != "cobalt" ]; then
+ echo -e ""
+ eerror "This package is only intended for the Cobalt Microserver MIPS-based"
+ eerror "systems. It will not function on any other MIPS-based system or any"
+ eerror "other architecture"
+ echo -e ""
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ echo -e ""
+ einfo ">>> Building the CoLo Bootloader ..."
+ cd ${S}
+ make clean || die # emake breaks the build
+ make || die
+}
+
+src_install() {
+ # bins
+ cd ${S}
+ dodir /usr/lib/colo
+ cp binaries/colo-chain.elf ${D}/usr/lib/colo
+ cp binaries/colo-rom-image.bin ${D}/usr/lib/colo
+
+ # docs
+ dodoc CHANGES COPYING INSTALL README README.{restore,shell,netcon} tools/README.tools TODO
+
+ # all tools except lcdtools (see below)
+ local tool
+ for tool in flash-tool colo-perm copy-rom elf2rfx; do
+
+ einfo "Installing ${tool} binary to ${D}/usr/sbin"
+ dosbin tools/${tool}/${tool}
+ if [ -f tools/${tool}/${tool}.8 ]; then
+ einfo "Installing ${tool} manpage to ${D}/usr/share/man"
+ doman tools/flash-tool/flash-tool.8
+ fi
+
+ done
+
+ # lcdtools
+ for tool in paneld putlcd e2fsck-lcd; do
+ einfo "Installing ${tool} binary and manpage to ${D}/usr/sbin"
+ dosbin tools/lcdtools/${tool}/${tool}
+ doman tools/lcdtools/${tool}/${tool}.8
+ done
+ dolib.a tools/lcdtools/liblcd/liblcd.a
+
+ # bootscripts
+ dodir /usr/lib/colo/scripts
+ cp ${FILESDIR}/*.colo ${D}/usr/lib/colo/scripts
+}
+
+pkg_postinst() {
+ echo -e ""
+ einfo "Install locations:"
+ einfo " Binaries:\t/usr/lib/${PN}"
+ einfo " Docs:\t/usr/share/doc/${PF}"
+ einfo " Tools:\t/usr/sbin/{flash-tool,colo-perm,copy-rom,"
+ einfo " \tputlcd,paneld,e2fsck-lcd,elf2rfx}"
+ einfo " Scripts:\t/usr/lib/${PN}/scripts"
+ echo -e ""
+ einfo "Please read the docs to fully understand the behavior of this bootloader, and"
+ einfo "edit the boot scripts to suit your needs."
+ echo -e ""
+ ewarn "Users installing ${PN} for the first time need to be aware that newer"
+ ewarn "versions of ${PN} disable the serial port by default. If the serial port"
+ ewarn "is needed, select it from the boot menu. Users using the example boot"
+ ewarn "scripts provided will have the serial port automatically enabled."
+ echo -e ""
+ ewarn "Note: It is HIGHLY recommended that you use the chain"
+ ewarn "bootloader (colo-chain.elf) first before attempting to"
+ ewarn "write the bootloader to the flash chip to verify that"
+ ewarn "it will work for you. It is also recommended that"
+ ewarn "you read the documentation in /usr/share/doc/${PF}"
+ ewarn "as it explains how to properly use this package."
+ echo -e ""
+ eerror "Warning: Make sure that IF you plan on flashing the"
+ eerror "bootloader into the flash chip that you are using a"
+ eerror "modern 2.4 Linux kernel (i.e., >2.4.18), otherwise"
+ eerror "you run a risk of destroying the contents of the"
+ eerror "flash chip and rendering the machine unusable."
+ echo -e ""
+ echo -e ""
+}
diff --git a/sys-boot/colo/files/digest-colo-1.22 b/sys-boot/colo/files/digest-colo-1.22
new file mode 100644
index 000000000000..776340917593
--- /dev/null
+++ b/sys-boot/colo/files/digest-colo-1.22
@@ -0,0 +1,3 @@
+MD5 52c16ad31f3b88f710f0fdb5abed0457 colo-1.22.tar.gz 257968
+RMD160 4a07cfe5050f395a8eb7c7d5fe71748877377084 colo-1.22.tar.gz 257968
+SHA256 ec51237286be9581d6be1ff3e43c9a654aaf4e1414d1bb194f02032e57119163 colo-1.22.tar.gz 257968