summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2012-02-24 15:18:55 +0000
committerJoseph Jezak <josejx@gentoo.org>2012-02-24 15:18:55 +0000
commit8d154104ac446b1a95e081e712e4dcf5940f2518 (patch)
tree90b9d75730fc8bfd1f8458e2365704c731347aca /sys-boot
parentx86 stable wrt bug #400329 (diff)
downloadgentoo-2-8d154104ac446b1a95e081e712e4dcf5940f2518.tar.gz
gentoo-2-8d154104ac446b1a95e081e712e4dcf5940f2518.tar.bz2
gentoo-2-8d154104ac446b1a95e081e712e4dcf5940f2518.zip
Version bump.
(Portage version: 2.1.10.46/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/yaboot-static/ChangeLog11
-rw-r--r--sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild24
-rw-r--r--sys-boot/yaboot-static/yaboot-static-1.3.17.ebuild (renamed from sys-boot/yaboot-static/yaboot-static-1.3.16.ebuild)4
3 files changed, 35 insertions, 4 deletions
diff --git a/sys-boot/yaboot-static/ChangeLog b/sys-boot/yaboot-static/ChangeLog
index d4ee34049bd0..188fb15eb5f6 100644
--- a/sys-boot/yaboot-static/ChangeLog
+++ b/sys-boot/yaboot-static/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/yaboot-static
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/ChangeLog,v 1.25 2011/04/10 14:24:22 ulm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/ChangeLog,v 1.26 2012/02/24 15:18:55 josejx Exp $
+
+*yaboot-static-1.3.17 (24 Feb 2012)
+*yaboot-static-1.3.16-r1 (24 Feb 2012)
+
+ 24 Feb 2012; Joseph Jezak <josejx@gentoo.org> -yaboot-static-1.3.16.ebuild,
+ +yaboot-static-1.3.16-r1.ebuild, +yaboot-static-1.3.17.ebuild:
+ Fixed the file issue for 1.3.16, bumped to the new version.
10 Apr 2011; Ulrich Mueller <ulm@gentoo.org> yaboot-static-1.3.14-r1.ebuild,
yaboot-static-1.3.16.ebuild:
diff --git a/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild b/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild
new file mode 100644
index 000000000000..14950c9fc618
--- /dev/null
+++ b/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild,v 1.1 2012/02/24 15:18:55 josejx Exp $
+
+inherit eutils
+
+DESCRIPTION="Static yaboot ppc boot loader for machines with open firmware"
+### Generated by using quickpkg on a ppc32 machine, compiled with -O2 -pipe
+
+HOMEPAGE="http://penguinppc.org/projects/yaboot/"
+SRC_URI="mirror://gentoo/yaboot-static-${PV}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~ppc64"
+IUSE="ibm"
+DEPEND="!sys-boot/yaboot
+ sys-apps/powerpc-utils"
+RDEPEND="!ibm? ( sys-fs/hfsutils
+ sys-fs/hfsplusutils
+ sys-fs/mac-fdisk )"
+
+src_install() {
+ cp -pPR "${WORKDIR}"/* "${D}" || die "cp failed"
+}
diff --git a/sys-boot/yaboot-static/yaboot-static-1.3.16.ebuild b/sys-boot/yaboot-static/yaboot-static-1.3.17.ebuild
index 0ce4dcea423d..3306cdfdaa53 100644
--- a/sys-boot/yaboot-static/yaboot-static-1.3.16.ebuild
+++ b/sys-boot/yaboot-static/yaboot-static-1.3.17.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.16.ebuild,v 1.2 2011/04/10 14:24:22 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.17.ebuild,v 1.1 2012/02/24 15:18:55 josejx Exp $
inherit eutils