summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-03-30 04:21:10 +0000
committerMike Gilbert <floppym@gentoo.org>2012-03-30 04:21:10 +0000
commit7ada2dff9df34985b604cac17cadfd38ac4b5d67 (patch)
tree9b2fb34a2cd08b853d3e46e0551f6ad6d413da6e /sys-boot
parentVersion bump. (diff)
downloadgentoo-2-7ada2dff9df34985b604cac17cadfd38ac4b5d67.tar.gz
gentoo-2-7ada2dff9df34985b604cac17cadfd38ac4b5d67.tar.bz2
gentoo-2-7ada2dff9df34985b604cac17cadfd38ac4b5d67.zip
Version bump.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/os-prober/ChangeLog7
-rw-r--r--sys-boot/os-prober/os-prober-1.51.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/sys-boot/os-prober/ChangeLog b/sys-boot/os-prober/ChangeLog
index 8b6dffa86de6..41d426141d8c 100644
--- a/sys-boot/os-prober/ChangeLog
+++ b/sys-boot/os-prober/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/os-prober
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.12 2012/02/14 15:37:25 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.13 2012/03/30 04:21:10 floppym Exp $
+
+*os-prober-1.51 (30 Mar 2012)
+
+ 30 Mar 2012; Mike Gilbert <floppym@gentoo.org> +os-prober-1.51.ebuild:
+ Version bump.
14 Feb 2012; Tomáš Chvátal <scarabeus@gentoo.org> os-prober-1.47.ebuild:
Stable on amd64 and x86, works fine and usefull for grub2.
diff --git a/sys-boot/os-prober/os-prober-1.51.ebuild b/sys-boot/os-prober/os-prober-1.51.ebuild
new file mode 100644
index 000000000000..7d78175b7902
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.51.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/os-prober-1.51.ebuild,v 1.1 2012/03/30 04:21:10 floppym Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="http://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ find "${S}" -type f -exec sed -i -e "s:/usr/lib/:/usr/libexec/:g" {} + || die
+
+ # use default GNU rules
+ rm Makefile
+}
+
+src_compile() {
+ tc-export CC
+ emake newns
+}
+
+src_install() {
+ dobin os-prober linux-boot-prober
+
+ exeinto /usr/libexec/os-prober
+ doexe newns
+
+ insinto /usr/share/os-prober
+ doins common.sh
+
+ keepdir /var/lib/os-prober
+
+ local debarch=${ARCH%-*} dir
+
+ case ${debarch} in
+ amd64) debarch=x86 ;;
+ ppc|ppc64) debarch=powerpc ;;
+ esac
+
+ for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+ exeinto /usr/libexec/$dir
+ doexe $dir/common/*
+ if [[ -d $dir/$debarch ]]; then
+ doexe $dir/$debarch/*
+ fi
+ done
+
+ if use amd64 || use x86; then
+ exeinto /usr/libexec/os-probes/mounted
+ doexe os-probes/mounted/powerpc/20macosx
+ fi
+
+ dodoc README TODO debian/changelog
+}
+
+pkg_postinst() {
+ elog "If you intend for os-prober to detect versions of Windows installed on"
+ elog "NTFS-formatted partitions, your system must be capable of reading the"
+ elog "NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g"
+}