summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-03-30 17:20:32 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-03-30 17:20:32 +0000
commit76f9132c73f9e97dffff3dfd843fd3085a3f485b (patch)
treea9754192b6afa9675ddab24853455478a513e10c /sys-boot
parentAdded ~ppc64 (diff)
downloadgentoo-2-76f9132c73f9e97dffff3dfd843fd3085a3f485b.tar.gz
gentoo-2-76f9132c73f9e97dffff3dfd843fd3085a3f485b.tar.bz2
gentoo-2-76f9132c73f9e97dffff3dfd843fd3085a3f485b.zip
Bring in the warning from bug #98768, as it's now important with the new Grub patches.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/grub-0.97-r5.ebuild13
2 files changed, 16 insertions, 3 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index e2b10c25eef8..bfdc7f06f3dc 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.85 2008/03/30 05:12:38 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.86 2008/03/30 17:20:32 robbat2 Exp $
+
+ 30 Mar 2008; Robin H. Johnson <robbat2@gentoo.org> grub-0.97-r5.ebuild:
+ Bring in the warning from bug #98768, as it's now important with the new
+ Grub patches.
30 Mar 2008; Robin H. Johnson <robbat2@gentoo.org> grub-0.97-r5.ebuild:
Per bug #160801, Grub needs modification to support kernels larger than
diff --git a/sys-boot/grub/grub-0.97-r5.ebuild b/sys-boot/grub/grub-0.97-r5.ebuild
index 9c7fa880b9bc..8cc0e5ae9ea8 100644
--- a/sys-boot/grub/grub-0.97-r5.ebuild
+++ b/sys-boot/grub/grub-0.97-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r5.ebuild,v 1.4 2008/03/30 05:12:38 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r5.ebuild,v 1.5 2008/03/30 17:20:32 robbat2 Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs autotools
@@ -163,7 +163,16 @@ setup_boot_dir() {
ln -snf grub.conf "${dir}"/menu.lst
fi
- [[ -e ${dir}/stage2 ]] && mv "${dir}"/stage2{,.old}
+ if [[ -e ${dir}/stage2 ]]; then
+ mv "${dir}"/stage2 \
+ "${dir}"/stage2-$(date -u +%Y%m%d-%H%MZ)
+ ewarn "*** IMPORTANT NOTE: you must run grub and install"
+ ewarn "the new version's stage1 to your MBR. Until you do,"
+ ewarn "stage1 and stage2 will still be the old version, but"
+ ewarn "later stages will be the new version, which could"
+ ewarn "cause problems such as an unbootable system."
+ ebeep
+ fi
einfo "Copying files from /lib/grub and /usr/lib/grub to ${dir}"
for x in "${ROOT}"/lib*/grub/*/* "${ROOT}"/usr/lib*/grub/*/* ; do