summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-10-22 21:28:39 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-10-22 21:28:39 +0000
commit6495460001fefd597009a4891547a8b714247758 (patch)
tree36da50ac7888733821847b29449539d3d7af0b16 /sys-boot
parentUse test-flags-CC instead of gcc-version check, thanks to vapier. (diff)
downloadgentoo-2-6495460001fefd597009a4891547a8b714247758.tar.gz
gentoo-2-6495460001fefd597009a4891547a8b714247758.tar.bz2
gentoo-2-6495460001fefd597009a4891547a8b714247758.zip
grub:0 - undid the ugly patch-based hacks for forcing ld.bfd, thanks to vapier and floppym
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/files/grub-0.97-force-ld.bfd.patch12
-rw-r--r--sys-boot/grub/grub-0.97-r14.ebuild17
3 files changed, 11 insertions, 25 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index f912156755c2..5a2304a77b09 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.325 2014/10/22 21:03:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.326 2014/10/22 21:28:39 axs Exp $
+
+ 22 Oct 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ -files/grub-0.97-force-ld.bfd.patch, grub-0.97-r14.ebuild:
+ grub:0 - undid the ugly patch-based hacks for forcing ld.bfd, thanks to vapier
+ and floppym
22 Oct 2014; Mike Gilbert <floppym@gentoo.org> grub-2.02_beta2-r2.ebuild,
grub-9999-r1.ebuild:
diff --git a/sys-boot/grub/files/grub-0.97-force-ld.bfd.patch b/sys-boot/grub/files/grub-0.97-force-ld.bfd.patch
deleted file mode 100644
index 0b3794adbc71..000000000000
--- a/sys-boot/grub/files/grub-0.97-force-ld.bfd.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.ac 2014-10-20 12:48:18.680041136 -0400
-+++ configure.ac.new 2014-10-20 12:52:11.950045394 -0400
-@@ -54,6 +54,9 @@
- CFLAGS="-m32 $CFLAGS"
- fi
-
-+# Force linking with ld.bfd
-+CFLAGS="$CFLAGS -fuse-ld=bfd"
-+
- #
- # Programs
- #
diff --git a/sys-boot/grub/grub-0.97-r14.ebuild b/sys-boot/grub/grub-0.97-r14.ebuild
index 807aea67abfd..1c08c1edc431 100644
--- a/sys-boot/grub/grub-0.97-r14.ebuild
+++ b/sys-boot/grub/grub-0.97-r14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r14.ebuild,v 1.3 2014/10/22 16:59:39 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r14.ebuild,v 1.4 2014/10/22 21:28:39 axs Exp $
# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
@@ -47,7 +47,7 @@ DEPEND="${RDEPEND}
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
# Bugs 526348 , 466536
- if ! version_is_at_least 4.8 "$(gcc-version)" &&
+ if ! test-flags-CC -fuse-ld=bfd &>/dev/null &&
$(tc-getLD) --version | grep -q "GNU gold"; then
eerror "GRUB does not function correctly when built with the gold linker."
eerror "Please select the bfd linker with binutils-config."
@@ -85,17 +85,7 @@ src_prepare() {
|| die
EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
-
rm -f "${S}"/aclocal.m4 # seems to keep bug 418287 away
-
- # Force ld.bfd via configure.ac so as to not mess up the CFLAGS stuff in src_configure()
- # Note: NOT adding this to the patchset because it's a hack that I don't like.
- # (bug 466536)
- # Conditionally epatch (*yuck*) so gcc-4.7 and earlier don't fail, bug 526348
- if version_is_at_least 4.8 "$(gcc-version)"; then
- epatch "${FILESDIR}"/${P}-force-ld.bfd.patch
- fi
-
eautoreconf
}
@@ -120,6 +110,9 @@ src_configure() {
# -fno-stack-protector detected by configure, removed from netboot's emake.
use custom-cflags || unset CFLAGS
+ # Force ld.bfd if we can set it, bug 466536
+ append-ldflags $(test-flags-CC -fuse-ld=bfd)
+
export grub_cv_prog_objcopy_absolute=yes #79734
use static && append-ldflags -static