summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2004-02-08 13:48:40 +0000
committerMartin Schlemmer <azarah@gentoo.org>2004-02-08 13:48:40 +0000
commit23d8a73c301bf49c7308c2f27a2b94caccea1c05 (patch)
tree36ec44e1ffbef8050fbf08ee2d6ebc699d37a897 /sys-boot
parentUpdate version. New version is done by Mr. Bones. <mr_bones_@gentoo.org>. This (diff)
downloadgentoo-2-23d8a73c301bf49c7308c2f27a2b94caccea1c05.tar.gz
gentoo-2-23d8a73c301bf49c7308c2f27a2b94caccea1c05.tar.bz2
gentoo-2-23d8a73c301bf49c7308c2f27a2b94caccea1c05.zip
Fix creation of install dirs, bug #39405. Patch thanks to Ed Grimm
<paranoid@gentoo.evolution.tgape.org>.
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/lilo/ChangeLog7
-rw-r--r--sys-boot/lilo/files/lilo-22.5.8-create-install-dirs.patch21
-rw-r--r--sys-boot/lilo/lilo-22.5.8-r1.ebuild5
3 files changed, 31 insertions, 2 deletions
diff --git a/sys-boot/lilo/ChangeLog b/sys-boot/lilo/ChangeLog
index bdd50e1b6352..05fc2aec464f 100644
--- a/sys-boot/lilo/ChangeLog
+++ b/sys-boot/lilo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/lilo
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.4 2004/02/01 11:56:24 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.5 2004/02/08 13:48:40 azarah Exp $
+
+ 08 Feb 2004; Martin Schlemmer <azarah@gentoo.org> lilo-22.5.8-r1.ebuild,
+ files/lilo-22.5.8-create-install-dirs.patch:
+ Fix creation of install dirs, bug #39405. Patch thanks to Ed Grimm
+ <paranoid@gentoo.evolution.tgape.org>.
01 Feb 2004; <plasmaroo@gentoo.org> lilo-22.5.8-r1.ebuild,
files/lilo-22.5.8.lvm.2-6headers.patch:
diff --git a/sys-boot/lilo/files/lilo-22.5.8-create-install-dirs.patch b/sys-boot/lilo/files/lilo-22.5.8-create-install-dirs.patch
new file mode 100644
index 000000000000..c9e58a2312a5
--- /dev/null
+++ b/sys-boot/lilo/files/lilo-22.5.8-create-install-dirs.patch
@@ -0,0 +1,21 @@
+--- lilo-22.5.8/Makefile.bak 2004-02-06 01:41:06.000000000 +0000
++++ lilo-22.5.8/Makefile 2004-02-06 02:02:57.000000000 +0000
+@@ -302,16 +302,8 @@
+ # normal install, but doesn't make the diagnostic binaries
+ #
+ install: all
+- if [ ! -d $$ROOT$(SBIN_DIR) ]; then mkdir $$ROOT$(SBIN_DIR); fi
+- if [ ! -d $$ROOT$(CFG_DIR) ]; then mkdir $$ROOT$(CFG_DIR); fi
+- if [ ! -d $$ROOT$(BOOT_DIR) ]; then mkdir $$ROOT$(BOOT_DIR); fi
+- if [ ! -d $$ROOT$(USRSBIN_DIR) ]; then \
+- mkdir -p $$ROOT$(USRSBIN_DIR); fi
+- if [ ! -d $$ROOT$(MAN_DIR) ]; then mkdir $$ROOT$(MAN_DIR); fi
+- if [ ! -d $$ROOT$(MAN_DIR)/man5 ]; then \
+- mkdir $$ROOT$(MAN_DIR)/man5; fi
+- if [ ! -d $$ROOT$(MAN_DIR)/man8 ]; then \
+- mkdir $$ROOT$(MAN_DIR)/man8; fi
++ mkdir -p $$ROOT$(SBIN_DIR) $$ROOT$(CFG_DIR) $$ROOT$(BOOT_DIR) \
++ $$ROOT$(USRSBIN_DIR) $$ROOT$(MAN_DIR)/man5 $$ROOT$(MAN_DIR)/man8
+ if [ -f diag1.img ]; then \
+ cp -f diag1.img $$ROOT$(BOOT_DIR); fi
+ if [ -f diag2.img ]; then \
diff --git a/sys-boot/lilo/lilo-22.5.8-r1.ebuild b/sys-boot/lilo/lilo-22.5.8-r1.ebuild
index c5a7c677608d..83d2c8decc24 100644
--- a/sys-boot/lilo/lilo-22.5.8-r1.ebuild
+++ b/sys-boot/lilo/lilo-22.5.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.5.8-r1.ebuild,v 1.4 2004/02/01 11:56:25 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.5.8-r1.ebuild,v 1.5 2004/02/08 13:48:40 azarah Exp $
inherit mount-boot eutils
@@ -42,7 +42,10 @@ src_unpack() {
# Fixup things for glibc-2.3.3 (and later CVS versions of 2.3.2)
cd ${S}; epatch ${FILESDIR}/${PN}-glibc233.patch
+ # Fix building against 2.6 headers
cd ${S}; epatch ${FILESDIR}/${P}.lvm.2-6headers.patch
+ # Fix creating install dirs, bug #39405
+ cd ${S}; epatch ${FILESDIR}/${P}-create-install-dirs.patch
}
src_compile() {