summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-07-07 22:55:48 +0000
committerMike Gilbert <floppym@gentoo.org>2012-07-07 22:55:48 +0000
commit201148609da6b272c38f8004e3e91af4efcf1dfa (patch)
tree20313cd67bb13fabf42820f614fe30e4cc136693 /sys-boot
parentVersion bump. Added examples flag (diff)
downloadgentoo-2-201148609da6b272c38f8004e3e91af4efcf1dfa.tar.gz
gentoo-2-201148609da6b272c38f8004e3e91af4efcf1dfa.tar.bz2
gentoo-2-201148609da6b272c38f8004e3e91af4efcf1dfa.zip
Add additional fix for bug 424231.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/files/grub-2.00-manpage-race.patch16
-rw-r--r--sys-boot/grub/files/grub-2.00-parallel-make.patch24
-rw-r--r--sys-boot/grub/grub-2.00.ebuild7
-rw-r--r--sys-boot/grub/grub-9999.ebuild8
5 files changed, 37 insertions, 25 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 45f329c590e0..648bb8862311 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.226 2012/07/05 01:32:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.227 2012/07/07 22:55:48 floppym Exp $
+
+ 07 Jul 2012; Mike Gilbert <floppym@gentoo.org>
+ +files/grub-2.00-parallel-make.patch, -files/grub-2.00-manpage-race.patch,
+ grub-2.00.ebuild, grub-9999.ebuild:
+ Add additional fix for bug 424231.
05 Jul 2012; Mike Frysinger <vapier@gentoo.org>
+files/grub-2.00-no-gets.patch, grub-2.00.ebuild:
diff --git a/sys-boot/grub/files/grub-2.00-manpage-race.patch b/sys-boot/grub/files/grub-2.00-manpage-race.patch
deleted file mode 100644
index 0781942f4fbf..000000000000
--- a/sys-boot/grub/files/grub-2.00-manpage-race.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Fix race condition when generating manpages.
-https://bugs.gentoo.org/show_bug.cgi?id=424231
-https://savannah.gnu.org/bugs/?36758
-
---- gentpl.py 2012-05-28 15:57:18 +0000
-+++ gentpl.py 2012-07-01 20:17:09 +0000
-@@ -487,7 +487,7 @@
- def manpage():
- r = "if COND_MAN_PAGES\n"
- r += gvar_add("man_MANS", "[+ name +].[+ mansection +]\n")
-- r += rule("[+ name +].[+ mansection +]", "[+ name +]", """
-+ r += rule("[+ name +].[+ mansection +]", "[+ name +] grub-mkconfig_lib", """
- chmod a+x [+ name +]
- PATH=$(builddir):$$PATH pkgdatadir=$(builddir) $(HELP2MAN) --section=[+ mansection +] -i $(top_srcdir)/docs/man/[+ name +].h2m -o $@ [+ name +]
- """)
-
diff --git a/sys-boot/grub/files/grub-2.00-parallel-make.patch b/sys-boot/grub/files/grub-2.00-parallel-make.patch
new file mode 100644
index 000000000000..8af8b36d8ff7
--- /dev/null
+++ b/sys-boot/grub/files/grub-2.00-parallel-make.patch
@@ -0,0 +1,24 @@
+Fix parallel make problems.
+Upstream changesets 4547, 4552.
+--- gentpl.py
++++ gentpl.py
+@@ -487,7 +487,7 @@
+ def manpage():
+ r = "if COND_MAN_PAGES\n"
+ r += gvar_add("man_MANS", "[+ name +].[+ mansection +]\n")
+- r += rule("[+ name +].[+ mansection +]", "[+ name +]", """
++ r += rule("[+ name +].[+ mansection +]", "[+ name +] grub-mkconfig_lib", """
+ chmod a+x [+ name +]
+ PATH=$(builddir):$$PATH pkgdatadir=$(builddir) $(HELP2MAN) --section=[+ mansection +] -i $(top_srcdir)/docs/man/[+ name +].h2m -o $@ [+ name +]
+ """)
+--- grub-core/Makefile.am
++++ grub-core/Makefile.am
+@@ -63,7 +63,7 @@
+ rs_decoder.S: $(srcdir)/lib/reed_solomon.c
+ $(TARGET_CC) $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -Os -I$(top_builddir) -S -DSTANDALONE -o $@ $< -g0 -mregparm=3 -ffreestanding
+
+-kern/i386/pc/startup.S: $(builddir)/rs_decoder.S
++boot/i386/pc/startup_raw.S: $(builddir)/rs_decoder.S
+ boot/mips/loongson/fwstart.S: $(builddir)/sm712_start.S
+
+ CLEANFILES += grub_script.yy.c grub_script.yy.h
diff --git a/sys-boot/grub/grub-2.00.ebuild b/sys-boot/grub/grub-2.00.ebuild
index 844e1620bdaf..4be1e7ce7305 100644
--- a/sys-boot/grub/grub-2.00.ebuild
+++ b/sys-boot/grub/grub-2.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.11 2012/07/05 01:32:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.12 2012/07/07 22:55:48 floppym Exp $
EAPI=4
@@ -207,10 +207,8 @@ grub_src_install() {
}
src_prepare() {
- local i j
-
if [[ ${PV} != 9999 ]]; then
- epatch "${FILESDIR}/${P}-manpage-race.patch"
+ epatch "${FILESDIR}/${P}-parallel-make.patch" #424231
epatch "${FILESDIR}/${P}-no-gets.patch" #424703
fi
@@ -238,6 +236,7 @@ src_prepare() {
# get enabled platforms
GRUB_ENABLED_PLATFORMS=""
+ local i
for i in ${GRUB_PLATFORMS[@]}; do
use grub_platforms_${i} && GRUB_ENABLED_PLATFORMS+=" ${i}"
done
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 9e593804912c..443d64245e06 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.76 2012/07/01 22:11:04 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.77 2012/07/07 22:55:48 floppym Exp $
EAPI=4
@@ -207,10 +207,9 @@ grub_src_install() {
}
src_prepare() {
- local i j
-
if [[ ${PV} != 9999 ]]; then
- epatch "${FILESDIR}/${P}-manpage-race.patch"
+ epatch "${FILESDIR}/${P}-parallel-make.patch" #424231
+ epatch "${FILESDIR}/${P}-no-gets.patch" #424703
fi
# fix texinfo file name, bug 416035
@@ -237,6 +236,7 @@ src_prepare() {
# get enabled platforms
GRUB_ENABLED_PLATFORMS=""
+ local i
for i in ${GRUB_PLATFORMS[@]}; do
use grub_platforms_${i} && GRUB_ENABLED_PLATFORMS+=" ${i}"
done