summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-10 00:32:49 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-10 00:32:49 +0000
commit4ba22256c7ff6d11bcbf5d33b517cc16df9282ed (patch)
treef3c59f9ffaa050b6c7bfb2e2666602cd7ec50e03 /sys-boot/syslinux
parentold (Manifest recommit) (diff)
downloadgentoo-2-4ba22256c7ff6d11bcbf5d33b517cc16df9282ed.tar.gz
gentoo-2-4ba22256c7ff6d11bcbf5d33b517cc16df9282ed.tar.bz2
gentoo-2-4ba22256c7ff6d11bcbf5d33b517cc16df9282ed.zip
Version bump.
Diffstat (limited to 'sys-boot/syslinux')
-rw-r--r--sys-boot/syslinux/ChangeLog7
-rw-r--r--sys-boot/syslinux/files/digest-syslinux-2.131
-rw-r--r--sys-boot/syslinux/syslinux-2.13.ebuild33
3 files changed, 40 insertions, 1 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 13afbf688179..81717492cc67 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/syslinux
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.11 2005/01/10 00:26:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.12 2005/01/10 00:32:49 vapier Exp $
+
+*syslinux-2.13 (09 Jan 2005)
+
+ 09 Jan 2005; Mike Frysinger <vapier@gentoo.org> +syslinux-2.13.ebuild:
+ Version bump.
*syslinux-1.76 (09 Jan 2005)
diff --git a/sys-boot/syslinux/files/digest-syslinux-2.13 b/sys-boot/syslinux/files/digest-syslinux-2.13
new file mode 100644
index 000000000000..e2a48eaa8280
--- /dev/null
+++ b/sys-boot/syslinux/files/digest-syslinux-2.13
@@ -0,0 +1 @@
+MD5 d04fad58d78acfe4d0143d16067053f7 syslinux-2.13.tar.bz2 421753
diff --git a/sys-boot/syslinux/syslinux-2.13.ebuild b/sys-boot/syslinux/syslinux-2.13.ebuild
new file mode 100644
index 000000000000..faa252ea3a8f
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-2.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-2.13.ebuild,v 1.1 2005/01/10 00:32:49 vapier Exp $
+
+inherit eutils gcc
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/Old/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ make INSTALLROOT="${D}" install || die
+ dodoc README NEWS TODO *.doc memdisk/memdisk.doc
+}