summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-14 10:49:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-14 10:49:54 +0000
commit42e42b54587d334deb7869d288b7d03aeeef3d56 (patch)
tree94c373a96d705824c53c777cf6de743721d05886 /sys-boot/syslinux
parentDocumentation generation requires X, so docs are cached on Gentoo mirrors. Cl... (diff)
downloadgentoo-2-42e42b54587d334deb7869d288b7d03aeeef3d56.tar.gz
gentoo-2-42e42b54587d334deb7869d288b7d03aeeef3d56.tar.bz2
gentoo-2-42e42b54587d334deb7869d288b7d03aeeef3d56.zip
Install utilities (by likewhoa).
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/syslinux')
-rw-r--r--sys-boot/syslinux/ChangeLog8
-rw-r--r--sys-boot/syslinux/syslinux-3.82-r1.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index c2af0c0607c9..202def5fd251 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.46 2009/06/27 17:42:59 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.47 2009/09/14 10:49:54 ssuominen Exp $
+
+*syslinux-3.82-r1 (14 Sep 2009)
+
+ 14 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +syslinux-3.82-r1.ebuild:
+ Install utilities (by likewhoa).
*syslinux-3.82 (27 Jun 2009)
diff --git a/sys-boot/syslinux/syslinux-3.82-r1.ebuild b/sys-boot/syslinux/syslinux-3.82-r1.ebuild
new file mode 100644
index 000000000000..046a0a530175
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-3.82-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.82-r1.ebuild,v 1.1 2009/09/14 10:49:54 ssuominen Exp $
+
+inherit eutils
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/Digest-SHA1"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.72-nopie.patch
+ # Don't prestrip, makes portage angry
+ epatch "${FILESDIR}"/${PN}-3.72-nostrip.patch
+
+ rm -f gethostip #bug 137081
+}
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ emake INSTALLSUBDIRS=utils INSTALLROOT="${D}" MANDIR=/usr/share/man install || die
+ dodoc README NEWS TODO doc/*
+}