summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-07-18 16:33:42 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-07-18 16:33:42 +0000
commitf9db46a7c7ce83a4ce52089f573ae821d1e3adb8 (patch)
tree231d27a1f821d2c98b5f9726a1d94903e82eb529 /sys-boot/os-prober
parentamd64/x86 stable wrt bug #392671 (diff)
downloadgentoo-2-f9db46a7c7ce83a4ce52089f573ae821d1e3adb8.tar.gz
gentoo-2-f9db46a7c7ce83a4ce52089f573ae821d1e3adb8.tar.bz2
gentoo-2-f9db46a7c7ce83a4ce52089f573ae821d1e3adb8.zip
Bump to 1.62, adding support for EFI. Thanks to Ben Kohler, bug #477312.
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'sys-boot/os-prober')
-rw-r--r--sys-boot/os-prober/ChangeLog7
-rw-r--r--sys-boot/os-prober/os-prober-1.62.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/sys-boot/os-prober/ChangeLog b/sys-boot/os-prober/ChangeLog
index fa1a4a184236..391b3bc3904a 100644
--- a/sys-boot/os-prober/ChangeLog
+++ b/sys-boot/os-prober/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/os-prober
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.18 2013/04/07 08:42:42 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.19 2013/07/18 16:33:42 maksbotan Exp $
+
+*os-prober-1.62 (18 Jul 2013)
+
+ 18 Jul 2013; <maks@gentoo.org> +os-prober-1.62.ebuild:
+ Bump to 1.62, adding support for EFI. Thanks to Ben Kohler, bug #477312.
*os-prober-1.57-r1 (07 Apr 2013)
diff --git a/sys-boot/os-prober/os-prober-1.62.ebuild b/sys-boot/os-prober/os-prober-1.62.ebuild
new file mode 100644
index 000000000000..b3fbc4582f6d
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.62.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/os-prober-1.62.ebuild,v 1.1 2013/07/18 16:33:42 maksbotan Exp $
+
+EAPI=5
+
+#inherit eutils multilib toolchain-funcs
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="http://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ # use default GNU rules
+ rm Makefile || die 'rm Makefile failed'
+ # Fix references to grub-mount
+ sed -i -e 's:grub-mount:grub2-mount:g' \
+ common.sh \
+ linux-boot-probes/common/50mounted-tests \
+ os-probes/common/50mounted-tests
+}
+
+src_compile() {
+ tc-export CC
+ emake newns
+}
+
+src_install() {
+ dobin os-prober linux-boot-prober
+
+ # Note: as no shared libraries are installed, /usr/lib is correct
+ exeinto /usr/lib/os-prober
+ doexe newns
+
+ insinto /usr/share/os-prober
+ doins common.sh
+
+ keepdir /var/lib/os-prober
+
+ local debarch=${ARCH%-*} dir
+
+ case ${debarch} in
+ amd64) debarch=x86 ;;
+ ppc|ppc64) debarch=powerpc ;;
+ esac
+
+ for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+ exeinto /usr/lib/$dir
+ doexe $dir/common/*
+ if [[ -d $dir/$debarch ]]; then
+ doexe $dir/$debarch/*
+ fi
+ if [[ -d $dir/$debarch/efi ]]; then
+ exeinto /usr/lib/$dir/efi
+ doexe $dir/$debarch/efi/*
+ fi
+ done
+
+ if use amd64 || use x86; then
+ exeinto /usr/lib/os-probes/mounted
+ doexe os-probes/mounted/powerpc/20macosx
+ fi
+
+ dodoc README TODO debian/changelog
+}
+
+pkg_postinst() {
+ elog "If you intend for os-prober to detect versions of Windows installed on"
+ elog "NTFS-formatted partitions, your system must be capable of reading the"
+ elog "NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g"
+}