summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-01-30 20:24:08 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-01-30 20:24:08 +0000
commit0cd3c7980e9f4d32885a799e37e4fe2407ad3463 (patch)
tree3d2ad4fcfadf3d8348a27e70d9a09663825d4651 /sys-boot/netboot
parentffmpeg 0.4.9_p20070129 compatibility patch (diff)
downloadgentoo-2-0cd3c7980e9f4d32885a799e37e4fe2407ad3463.tar.gz
gentoo-2-0cd3c7980e9f4d32885a799e37e4fe2407ad3463.tar.bz2
gentoo-2-0cd3c7980e9f4d32885a799e37e4fe2407ad3463.zip
changes recommended by upstream
(Portage version: 2.1.2-r2)
Diffstat (limited to 'sys-boot/netboot')
-rw-r--r--sys-boot/netboot/netboot-0.10.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-boot/netboot/netboot-0.10.1.ebuild b/sys-boot/netboot/netboot-0.10.1.ebuild
index 02c09700e997..71ff45428b2d 100644
--- a/sys-boot/netboot/netboot-0.10.1.ebuild
+++ b/sys-boot/netboot/netboot-0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/netboot-0.10.1.ebuild,v 1.1 2007/01/29 08:00:12 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/netboot-0.10.1.ebuild,v 1.2 2007/01/30 20:24:08 dragonheart Exp $
inherit eutils toolchain-funcs
@@ -24,15 +24,15 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-nossp.patch
epatch "${FILESDIR}"/${P}-destdir.patch
sed -i -e "s/-s$//" "${S}"/make.config.in
+ find "${S}" -name \*.lo -exec rm {} \;
}
src_compile() {
-# export GCC86DEBUG="-fno-pie -fno-stack-protector"
econf --enable-bootrom --with-gnu-cc86="$(tc-getCC)" \
--with-gnu-as86="$(tc-getAS)" --with-gnu-ld86="$(tc-getLD)"|| die 'cannot configure'
# --enable-config-file
sed -i -e "s/-llzo/-llzo2/" "${S}"/make.config
- emake -j1 || die 'cannot make'
+ emake || die 'cannot make'
}
src_install() {
@@ -43,7 +43,7 @@ src_install() {
mv "${D}"/usr/share/misc "${D}"/usr/share/${PN}
rm -rf "${D}"/usr/lib/netboot/utils
- dobin "${S}"/mknbi-dos/utils/mntnbi.pl
+ dodoc "${S}"/mknbi-dos/utils/mntnbi.pl
insinto /usr/share/vim/vimfiles/syntax
doins "${S}"/mknbi-mgl/misc/mgl.vim