summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-20 02:52:00 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-20 02:52:00 +0000
commitbbdede81c1c31e609234e7776f24dff1415f5f86 (patch)
tree28ca24f7b282a870f68dd65f71854d5a5d40b8bb /sys-boot/efibootmgr
parentold (diff)
downloadgentoo-2-bbdede81c1c31e609234e7776f24dff1415f5f86.tar.gz
gentoo-2-bbdede81c1c31e609234e7776f24dff1415f5f86.tar.bz2
gentoo-2-bbdede81c1c31e609234e7776f24dff1415f5f86.zip
Version bump.
(Portage version: 2.2_pre2)
Diffstat (limited to 'sys-boot/efibootmgr')
-rw-r--r--sys-boot/efibootmgr/ChangeLog9
-rw-r--r--sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/sys-boot/efibootmgr/ChangeLog b/sys-boot/efibootmgr/ChangeLog
index f948b7df19bc..89dcf5472a81 100644
--- a/sys-boot/efibootmgr/ChangeLog
+++ b/sys-boot/efibootmgr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/efibootmgr
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/ChangeLog,v 1.16 2008/02/14 15:08:22 opfer Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/ChangeLog,v 1.17 2008/02/20 02:52:00 vapier Exp $
+
+*efibootmgr-0.5.4 (20 Feb 2008)
+
+ 20 Feb 2008; Mike Frysinger <vapier@gentoo.org> +efibootmgr-0.5.4.ebuild:
+ Version bump.
14 Feb 2008; Christian Faulhammer <opfer@gentoo.org>
efibootmgr-0.5.3.ebuild:
diff --git a/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild b/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild
new file mode 100644
index 000000000000..973e0082054a
--- /dev/null
+++ b/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild,v 1.1 2008/02/20 02:52:00 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Interact with the EFI Boot Manager on IA-64 Systems"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+SRC_URI="http://linux.dell.com/efibootmgr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ia64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+
+pkg_config() {
+ # should prob get moved into tc-funcs or something ...
+ if [[ ${PKG_CONFIG+set} == "set" ]] ; then
+ echo ${PKG_CONFIG}
+ elif type -p ${CHOST}-pkg-config >/dev/null ; then
+ echo ${CHOST}-pkg-config
+ else
+ echo pkg-config
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^LIBS/s:=.*:=$($(pkg_config) libpci --libs):" \
+ src/efibootmgr/module.mk || die
+}
+
+src_compile() {
+ strip-flags
+ tc-export CC
+ emake EXTRA_CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ # build system uses perl, so just do it ourselves
+ dosbin src/efibootmgr/efibootmgr || die
+ doman src/man/man8/efibootmgr.8
+ dodoc AUTHORS README doc/ChangeLog doc/TODO
+}