summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-02-21 08:09:03 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-02-21 08:09:03 +0000
commit7e6fce8cbe6cf85ca149770c06349d56720eab9c (patch)
treed8ecf293d667caf2299ac4f7e76d3e1dba869cdb /sys-block
parentRestricting jython (diff)
downloadgentoo-2-7e6fce8cbe6cf85ca149770c06349d56720eab9c.tar.gz
gentoo-2-7e6fce8cbe6cf85ca149770c06349d56720eab9c.tar.bz2
gentoo-2-7e6fce8cbe6cf85ca149770c06349d56720eab9c.zip
version bump.
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/fio/ChangeLog9
-rw-r--r--sys-block/fio/fio-2.0.3.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/sys-block/fio/ChangeLog b/sys-block/fio/ChangeLog
index 356a6aac79f9..ecc24c60017c 100644
--- a/sys-block/fio/ChangeLog
+++ b/sys-block/fio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/fio
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/ChangeLog,v 1.22 2011/11/07 08:25:39 robbat2 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/ChangeLog,v 1.23 2012/02/21 08:09:03 robbat2 Exp $
+
+*fio-2.0.3 (21 Feb 2012)
+
+ 21 Feb 2012; Robin H. Johnson <robbat2@gentoo.org> +fio-2.0.3.ebuild:
+ version bump.
*fio-1.99.10 (07 Nov 2011)
diff --git a/sys-block/fio/fio-2.0.3.ebuild b/sys-block/fio/fio-2.0.3.ebuild
new file mode 100644
index 000000000000..36a6544c10cf
--- /dev/null
+++ b/sys-block/fio/fio-2.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/fio-2.0.3.ebuild,v 1.1 2012/02/21 08:09:03 robbat2 Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Jens Axboe's Flexible IO tester"
+HOMEPAGE="http://brick.kernel.dk/snaps/"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libaio"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i \
+ -e '/filter /s:-o:$(LDFLAGS) -o:' \
+ -e '/: depend$/d' \
+ Makefile || die
+}
+
+src_compile() {
+ append-flags -W
+ emake CC="$(tc-getCC)" OPTFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man" || die "emake install failed"
+ dodoc README REPORTING-BUGS HOWTO
+ docinto examples
+ dodoc examples/*
+ doman fio.1
+}