summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-06-18 06:23:35 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-06-18 06:23:35 +0000
commit5e6728afdca558bc2d81f5622e56f86c05071f62 (patch)
tree776ab860352c1d75a55b08106489fb6d4ee99a52 /sys-block/qla-fc-firmware
parentDo not use the MID/MIDX firmware by default. It sucks compared to IP/IPX firm... (diff)
downloadgentoo-2-5e6728afdca558bc2d81f5622e56f86c05071f62.tar.gz
gentoo-2-5e6728afdca558bc2d81f5622e56f86c05071f62.tar.bz2
gentoo-2-5e6728afdca558bc2d81f5622e56f86c05071f62.zip
Update to newest upstream firmware.
(Portage version: 2.1.5.5)
Diffstat (limited to 'sys-block/qla-fc-firmware')
-rw-r--r--sys-block/qla-fc-firmware/ChangeLog8
-rw-r--r--sys-block/qla-fc-firmware/qla-fc-firmware-20080423.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-block/qla-fc-firmware/ChangeLog b/sys-block/qla-fc-firmware/ChangeLog
index 8505401aa8cf..f997d36b4297 100644
--- a/sys-block/qla-fc-firmware/ChangeLog
+++ b/sys-block/qla-fc-firmware/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-block/qla-fc-firmware
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/qla-fc-firmware/ChangeLog,v 1.17 2008/06/18 06:19:22 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/qla-fc-firmware/ChangeLog,v 1.18 2008/06/18 06:23:35 robbat2 Exp $
+
+*qla-fc-firmware-20080423 (18 Jun 2008)
+
+ 18 Jun 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +qla-fc-firmware-20080423.ebuild:
+ Update to newest upstream firmware.
*qla-fc-firmware-20071207-r1 (18 Jun 2008)
diff --git a/sys-block/qla-fc-firmware/qla-fc-firmware-20080423.ebuild b/sys-block/qla-fc-firmware/qla-fc-firmware-20080423.ebuild
new file mode 100644
index 000000000000..ac3480090f34
--- /dev/null
+++ b/sys-block/qla-fc-firmware/qla-fc-firmware-20080423.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/qla-fc-firmware/qla-fc-firmware-20080423.ebuild,v 1.1 2008/06/18 06:23:35 robbat2 Exp $
+
+DESCRIPTION="QLogic Linux Fibre Channel HBA Firmware for ql2xxx cards"
+HOMEPAGE="ftp://ftp.qlogic.com/outgoing/linux/firmware/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="qlogic-fibre-channel-firmware"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+# really depends on absolutely nothing
+DEPEND=""
+RDEPEND=""
+
+FW_BASENAME="ql2100_fw.bin ql2200_fw.bin ql2300_fw.bin ql2322_fw.bin ql2400_fw.bin ql2500_fw.bin ql6312_fw.bin"
+
+src_install() {
+ # We must install this, say QLogic's people.
+ # They have claimed to me that the /license/ directory isn't sufficient, as
+ # there is no guarantee it will be on a system - and it would not be in any
+ # binpkg either. If you do something else with the firmware blobs, you are
+ # thus strongly encouraged to keep a copy of the LICENSE file with them on
+ # the system.
+ dodoc LICENSE
+ dodoc README.* CURRENT_VERSIONS
+ insinto /lib/firmware
+ # some older firmware are always provided by upstream
+ # for reasons documented in CURRENT_VERSIONS.
+
+ # Please see README.* as to why we do not use the MID/MIDX versions by
+ # default if they are newer.
+ # TODO: Provide a means to get them for people that really want them.
+ for f in ${FW_BASENAME} ; do
+ doins ${f}.*
+ latest_f="$(ls ${f}.* |grep -v MID | sort -n | tail -n1)"
+ dosym ${latest_f} /lib/firmware/${f}
+ done
+}