summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-07-08 06:45:46 +0000
committerMike Frysinger <vapier@gentoo.org>2015-07-08 06:45:46 +0000
commit8b3fa4b2792eeb111a74d19133fd55c9340a6aa5 (patch)
treecc4f36b7ba046afdc9e1862ae3e79f78a2391035 /sys-auth
parentVersion bump. (diff)
downloadgentoo-2-8b3fa4b2792eeb111a74d19133fd55c9340a6aa5.tar.gz
gentoo-2-8b3fa4b2792eeb111a74d19133fd55c9340a6aa5.tar.bz2
gentoo-2-8b3fa4b2792eeb111a74d19133fd55c9340a6aa5.zip
Fix by Leho Kraav for username locale matching issues #412941.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_blue/ChangeLog12
-rw-r--r--sys-auth/pam_blue/files/pam_blue-0.9.0-bad-log.patch11
-rw-r--r--sys-auth/pam_blue/files/pam_blue-0.9.0-char-locales.patch17
-rw-r--r--sys-auth/pam_blue/pam_blue-0.9.0-r1.ebuild48
4 files changed, 85 insertions, 3 deletions
diff --git a/sys-auth/pam_blue/ChangeLog b/sys-auth/pam_blue/ChangeLog
index d7c572ae2581..b744a04ff62b 100644
--- a/sys-auth/pam_blue/ChangeLog
+++ b/sys-auth/pam_blue/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/pam_blue
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_blue/ChangeLog,v 1.7 2010/06/11 11:06:48 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_blue/ChangeLog,v 1.8 2015/07/08 06:45:46 vapier Exp $
+
+*pam_blue-0.9.0-r1 (08 Jul 2015)
+
+ 08 Jul 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/pam_blue-0.9.0-bad-log.patch, +files/pam_blue-0.9.0-char-locales.patch,
+ +pam_blue-0.9.0-r1.ebuild:
+ Fix by Leho Kraav for username locale matching issues #412941.
11 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> pam_blue-0.9.0.ebuild:
Drop bluez-libs support wrt #301630.
@@ -35,4 +42,3 @@
25 May 2007; Jakub Moc <jakub@gentoo.org> +pam_blue-0.9.0.ebuild,
+metadata.xml:
New ebuild for KingTaco. Bug 180325.
-
diff --git a/sys-auth/pam_blue/files/pam_blue-0.9.0-bad-log.patch b/sys-auth/pam_blue/files/pam_blue-0.9.0-bad-log.patch
new file mode 100644
index 000000000000..5f2a2628e4b0
--- /dev/null
+++ b/sys-auth/pam_blue/files/pam_blue-0.9.0-bad-log.patch
@@ -0,0 +1,11 @@
+--- a/src/bluepmain.c
++++ b/src/bluepmain.c
+@@ -88,7 +88,7 @@
+
+ if ( (lst = parse_rc()) == NULL) { /* something goes wrong (no config file, ...) */
+ user = NULL;
+- syslog (LOG_ERR, "Can't parse configuration file [%s]!" CONFIG_FILE);
++ syslog (LOG_ERR, "Can't parse configuration file [%s]!", CONFIG_FILE);
+ return PAM_AUTH_ERR;
+ }
+
diff --git a/sys-auth/pam_blue/files/pam_blue-0.9.0-char-locales.patch b/sys-auth/pam_blue/files/pam_blue-0.9.0-char-locales.patch
new file mode 100644
index 000000000000..40d2810f486c
--- /dev/null
+++ b/sys-auth/pam_blue/files/pam_blue-0.9.0-char-locales.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/412941
+
+fix matching in various locales
+
+patch by Leho Kraav <leho@kraav.com>
+
+--- a/src/lexer.l
++++ b/src/lexer.l
+@@ -28,7 +28,7 @@
+ bluemac { return BLUEMAC; }
+ @ { return AT;}
+ ; { return SEMICOLON; }
+-[a-zA-Z][a-zA-Z0-9_]* { yylval.word = (char *) strdup(yytext); return WORD; }
++[[:alpha:]][[:alnum:]_-]* { yylval.word = (char *) strdup(yytext); return WORD; }
+ {HXDIGD}{HXDIGD}{HXDIG} { yylval.word = (char *) strdup(yytext); return MAC; }
+ [0-9][0-9]* { yylval.value = atoi(yytext); return DIGIT; }
+ = { return EQUAL; }
diff --git a/sys-auth/pam_blue/pam_blue-0.9.0-r1.ebuild b/sys-auth/pam_blue/pam_blue-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..cb72ada6bf30
--- /dev/null
+++ b/sys-auth/pam_blue/pam_blue-0.9.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_blue/pam_blue-0.9.0-r1.ebuild,v 1.1 2015/07/08 06:45:46 vapier Exp $
+
+EAPI="5"
+
+inherit pam autotools multilib
+
+DESCRIPTION="Linux PAM module providing ability to authenticate via a bluetooth compatible device"
+HOMEPAGE="http://pam.0xdef.net/"
+SRC_URI="http://pam.0xdef.net/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/pam
+ net-wireless/bluez"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-char-locales.patch #412941
+ epatch "${FILESDIR}"/${P}-bad-log.patch
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --libdir="$(getpam_mod_dir)"
+}
+
+src_install() {
+ # manual install to avoid sandbox violation and installing useless .la file
+ dopammod src/.libs/pam_blue.so
+ newpamsecurity . data/sample.conf bluesscan.conf.sample
+
+ dodoc AUTHORS NEWS README ChangeLog
+ doman doc/${PN}.7
+}
+
+pkg_postinst() {
+ elog "For configuration info, see /etc/security/bluesscan.conf.sample"
+ elog "http://pam.0xdef.net/doc.html and http://pam.0xdef.net/faq.html"
+ elog "Edit the file as required and copy/rename to bluesscan.conf when done."
+}