summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-12-17 21:59:48 +0000
committerHanno Böck <hanno@gentoo.org>2008-12-17 21:59:48 +0000
commit88552f230dd99f88d13f698329045c26191e5b5a (patch)
treee8289274a8ef53c89e724d4b35546cfd9c879e9f /sys-auth
parentFix bug 227475. Thanks to bonsaikitten, aka DrEevil, aka Evil Compile Person ... (diff)
downloadgentoo-2-88552f230dd99f88d13f698329045c26191e5b5a.tar.gz
gentoo-2-88552f230dd99f88d13f698329045c26191e5b5a.tar.bz2
gentoo-2-88552f230dd99f88d13f698329045c26191e5b5a.zip
pam_monut bump
(Portage version: 2.2_rc17/cvs/Linux 2.6.28-rc8 x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-1.5.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 217c1396a09d..ac261d371ae4 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.23 2008/10/09 16:53:20 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.24 2008/12/17 21:59:48 hanno Exp $
+
+*pam_mount-1.5 (17 Dec 2008)
+
+ 17 Dec 2008; Hanno Boeck <hanno@gentoo.org> +pam_mount-1.5.ebuild:
+ Version bump.
*pam_mount-0.49 (09 Oct 2008)
diff --git a/sys-auth/pam_mount/pam_mount-1.5.ebuild b/sys-auth/pam_mount/pam_mount-1.5.ebuild
new file mode 100644
index 000000000000..bd46f4c60d45
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-1.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-1.5.ebuild,v 1.1 2008/12/17 21:59:48 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.25
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.25
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}